aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-kivy
diff options
context:
space:
mode:
authordbn <dbn@FreeBSD.org>2017-04-14 22:16:19 +0800
committerdbn <dbn@FreeBSD.org>2017-04-14 22:16:19 +0800
commitc547602315b606b6dd0e3b8233c23f6b210147f4 (patch)
tree4bd64ce304f2eeb5ab049fd8e9c41ee0926c55d4 /x11-toolkits/py-kivy
parent6de92105a197e8c135206d27c66d3b59550710c1 (diff)
downloadfreebsd-ports-gnome-c547602315b606b6dd0e3b8233c23f6b210147f4.tar.gz
freebsd-ports-gnome-c547602315b606b6dd0e3b8233c23f6b210147f4.tar.zst
freebsd-ports-gnome-c547602315b606b6dd0e3b8233c23f6b210147f4.zip
x11-toolkits/py-kivy: fix concurrency, dependency
- Chase change in name of opencv - Switch to using autoplist (makes installing with python 3 easier) - Mark the port as concurrent
Diffstat (limited to 'x11-toolkits/py-kivy')
-rw-r--r--x11-toolkits/py-kivy/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/py-kivy/Makefile b/x11-toolkits/py-kivy/Makefile
index 58a0cef37762..6c818291edc7 100644
--- a/x11-toolkits/py-kivy/Makefile
+++ b/x11-toolkits/py-kivy/Makefile
@@ -22,9 +22,9 @@ MAKE_ENV= KIVY_NO_CONFIG=yes KIVY_NO_FILELOG=yes USE_OPENGL_ES2=1 \
PYTHONPATH=${WRKSRC}
USE_GITHUB= yes
-USES= display:test python:2.7+,concurrent uniquefiles:dirs
+USES= display:test python uniquefiles:dirs
USE_GL= egl gl glesv2
-USE_PYTHON= distutils
+USE_PYTHON= autoplist concurrent distutils
PYDISTUTILS_BUILD_TARGET= build_ext
PYDISTUTILS_BUILDARGS= --inplace