aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-pyxfce
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2007-03-13 17:20:26 +0800
committernivit <nivit@FreeBSD.org>2007-03-13 17:20:26 +0800
commit6bfade4019b9ea41e5dfa09471c9e2287da17609 (patch)
tree81400fe0ed65bc76509a1b70d2185d6134604df6 /x11-toolkits/py-pyxfce
parent74736b664c1dc5f4f09a3aa8228a15b02d6f2c69 (diff)
downloadfreebsd-ports-gnome-6bfade4019b9ea41e5dfa09471c9e2287da17609.tar.gz
freebsd-ports-gnome-6bfade4019b9ea41e5dfa09471c9e2287da17609.tar.zst
freebsd-ports-gnome-6bfade4019b9ea41e5dfa09471c9e2287da17609.zip
Pyxfce are Xfce bindings for Python. You can use Python to create
Xfce programs. WWW: http://pyxfce.xfce.org/
Diffstat (limited to 'x11-toolkits/py-pyxfce')
-rw-r--r--x11-toolkits/py-pyxfce/Makefile29
-rw-r--r--x11-toolkits/py-pyxfce/distinfo3
-rw-r--r--x11-toolkits/py-pyxfce/pkg-descr4
-rw-r--r--x11-toolkits/py-pyxfce/pkg-plist89
4 files changed, 125 insertions, 0 deletions
diff --git a/x11-toolkits/py-pyxfce/Makefile b/x11-toolkits/py-pyxfce/Makefile
new file mode 100644
index 000000000000..5f7ca7c7f2ec
--- /dev/null
+++ b/x11-toolkits/py-pyxfce/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: py-pyxfce
+# Date created: 2007-03-12
+# Whom: Nicola Vitale <nivit@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyxfce
+PORTVERSION= 4.4.0
+CATEGORIES= x11-toolkits python xfce
+MASTER_SITES= http://pyxfce.xfce.org/ \
+ http://nivi.interfree.it/distfiles/${PORTNAME}/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= XFCE bindings for Python
+
+LIB_DEPENDS= xfcegui4:${PORTSDIR}/x11-toolkits/libxfce4gui \
+ xfce4mcs-manager:${PORTSDIR}/x11/libxfce4mcs \
+ xfce4panel:${PORTSDIR}/x11-wm/xfce4-panel \
+ xfce4util:${PORTSDIR}/x11/libxfce4util
+
+CONFIGURE_ARGS= --libdir=${PREFIX}/libdata
+GNU_CONFIGURE= yes
+
+USE_GNOME= pygtk2
+USE_PYTHON= yes
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-pyxfce/distinfo b/x11-toolkits/py-pyxfce/distinfo
new file mode 100644
index 000000000000..208b992c51b1
--- /dev/null
+++ b/x11-toolkits/py-pyxfce/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyxfce-4.4.0.tar.gz) = 5f9ac63908adc9eaf9eb3e3b2d41167b
+SHA256 (pyxfce-4.4.0.tar.gz) = bd26e2be435a9ffe987f26d3b233709b7e47fa1b5117874f71d52b8082964d7b
+SIZE (pyxfce-4.4.0.tar.gz) = 449069
diff --git a/x11-toolkits/py-pyxfce/pkg-descr b/x11-toolkits/py-pyxfce/pkg-descr
new file mode 100644
index 000000000000..7399b0f20d8c
--- /dev/null
+++ b/x11-toolkits/py-pyxfce/pkg-descr
@@ -0,0 +1,4 @@
+Pyxfce are Xfce bindings for Python. You can use Python to create
+Xfce programs.
+
+WWW: http://pyxfce.xfce.org/
diff --git a/x11-toolkits/py-pyxfce/pkg-plist b/x11-toolkits/py-pyxfce/pkg-plist
new file mode 100644
index 000000000000..4da20878aa9a
--- /dev/null
+++ b/x11-toolkits/py-pyxfce/pkg-plist
@@ -0,0 +1,89 @@
+@comment $FreeBSD$
+libdata/pkgconfig/pyxfce-1.0.pc
+%%PYTHON_SITELIBDIR%%/xfce4/__init__.py
+%%PYTHON_SITELIBDIR%%/xfce4/__init__.pyc
+%%PYTHON_SITELIBDIR%%/xfce4/__init__.pyo
+%%PYTHON_SITELIBDIR%%/xfce4/_gui.la
+%%PYTHON_SITELIBDIR%%/xfce4/_gui.so
+%%PYTHON_SITELIBDIR%%/xfce4/_mcs.la
+%%PYTHON_SITELIBDIR%%/xfce4/_mcs.so
+%%PYTHON_SITELIBDIR%%/xfce4/_netk.la
+%%PYTHON_SITELIBDIR%%/xfce4/_netk.so
+%%PYTHON_SITELIBDIR%%/xfce4/_panel.la
+%%PYTHON_SITELIBDIR%%/xfce4/_panel.so
+%%PYTHON_SITELIBDIR%%/xfce4/_util.la
+%%PYTHON_SITELIBDIR%%/xfce4/_util.so
+%%PYTHON_SITELIBDIR%%/xfce4/gui.py
+%%PYTHON_SITELIBDIR%%/xfce4/gui.pyc
+%%PYTHON_SITELIBDIR%%/xfce4/gui.pyo
+%%PYTHON_SITELIBDIR%%/xfce4/mcs.py
+%%PYTHON_SITELIBDIR%%/xfce4/mcs.pyc
+%%PYTHON_SITELIBDIR%%/xfce4/mcs.pyo
+%%PYTHON_SITELIBDIR%%/xfce4/netk.py
+%%PYTHON_SITELIBDIR%%/xfce4/netk.pyc
+%%PYTHON_SITELIBDIR%%/xfce4/netk.pyo
+%%PYTHON_SITELIBDIR%%/xfce4/panel.py
+%%PYTHON_SITELIBDIR%%/xfce4/panel.pyc
+%%PYTHON_SITELIBDIR%%/xfce4/panel.pyo
+%%PYTHON_SITELIBDIR%%/xfce4/util.py
+%%PYTHON_SITELIBDIR%%/xfce4/util.pyc
+%%PYTHON_SITELIBDIR%%/xfce4/util.pyo
+%%DATADIR%%/4.2/defs/aboutdialog.defs
+%%DATADIR%%/4.2/defs/application.defs
+%%DATADIR%%/4.2/defs/appmenuitem.defs
+%%DATADIR%%/4.2/defs/arrow_button.defs
+%%DATADIR%%/4.2/defs/class_group.defs
+%%DATADIR%%/4.2/defs/clock.defs
+%%DATADIR%%/4.2/defs/colorbutton.defs
+%%DATADIR%%/4.2/defs/decorbutton.defs
+%%DATADIR%%/4.2/defs/decortoggle.defs
+%%DATADIR%%/4.2/defs/desktopentry.defs
+%%DATADIR%%/4.2/defs/dialogs.defs
+%%DATADIR%%/4.2/defs/enum_types.defs
+%%DATADIR%%/4.2/defs/enums.defs
+%%DATADIR%%/4.2/defs/external_plugin.defs
+%%DATADIR%%/4.2/defs/filechooser.defs
+%%DATADIR%%/4.2/defs/fileutils.defs
+%%DATADIR%%/4.2/defs/framebox.defs
+%%DATADIR%%/4.2/defs/gdk_extensions.defs
+%%DATADIR%%/4.2/defs/gtk_extensions.defs
+%%DATADIR%%/4.2/defs/gtk_style.defs
+%%DATADIR%%/4.2/defs/gtktoxevent.defs
+%%DATADIR%%/4.2/defs/i18n.defs
+%%DATADIR%%/4.2/defs/iconbutton.defs
+%%DATADIR%%/4.2/defs/icons.defs
+%%DATADIR%%/4.2/defs/icontheme.defs
+%%DATADIR%%/4.2/defs/itembar.defs
+%%DATADIR%%/4.2/defs/kiosk.defs
+%%DATADIR%%/4.2/defs/mcs_client.defs
+%%DATADIR%%/4.2/defs/mcs_common.defs
+%%DATADIR%%/4.2/defs/mcs_manager.defs
+%%DATADIR%%/4.2/defs/menubutton.defs
+%%DATADIR%%/4.2/defs/miscutils.defs
+%%DATADIR%%/4.2/defs/movehandler.defs
+%%DATADIR%%/4.2/defs/pager.defs
+%%DATADIR%%/4.2/defs/plugin_iface.defs
+%%DATADIR%%/4.2/defs/rc.defs
+%%DATADIR%%/4.2/defs/resource.defs
+%%DATADIR%%/4.2/defs/scaled_image.defs
+%%DATADIR%%/4.2/defs/screen.defs
+%%DATADIR%%/4.2/defs/session_client.defs
+%%DATADIR%%/4.2/defs/startup-notification.defs
+%%DATADIR%%/4.2/defs/systemtray.defs
+%%DATADIR%%/4.2/defs/tasklist.defs
+%%DATADIR%%/4.2/defs/titled_dialog.defs
+%%DATADIR%%/4.2/defs/togglebutton.defs
+%%DATADIR%%/4.2/defs/trayicon.defs
+%%DATADIR%%/4.2/defs/utf8.defs
+%%DATADIR%%/4.2/defs/util.defs
+%%DATADIR%%/4.2/defs/window.defs
+%%DATADIR%%/4.2/defs/window_action_menu.defs
+%%DATADIR%%/4.2/defs/window_menu.defs
+%%DATADIR%%/4.2/defs/workspace.defs
+%%DATADIR%%/4.2/defs/xfce_mcs-channel.defs
+%%DATADIR%%/4.2/defs/xfce_mcs-client.defs
+%%DATADIR%%/4.2/defs/xfce_mcs-manager.defs
+@dirrm %%PYTHON_SITELIBDIR%%/xfce4
+@dirrm %%DATADIR%%/4.2/defs
+@dirrm %%DATADIR%%/4.2
+@dirrm %%DATADIR%%
> docsInfo?: DocsInfo; style?: React.CSSProperties; isNightVersion?: boolean; } interface TopBarState { isDrawerOpen: boolean; } const styles: Styles = { address: { marginRight: 12, overflow: 'hidden', paddingTop: 4, textOverflow: 'ellipsis', whiteSpace: 'nowrap', width: 70, }, topBar: { backgroundcolor: colors.white, height: 59, width: '100%', position: 'fixed', top: 0, zIndex: 1100, paddingBottom: 1, }, bottomBar: { boxShadow: 'rgba(0, 0, 0, 0.187647) 0px 1px 3px', }, menuItem: { fontSize: 14, color: colors.darkestGrey, paddingTop: 6, paddingBottom: 6, marginTop: 17, cursor: 'pointer', fontWeight: 400, }, }; export class TopBar extends React.Component<TopBarProps, TopBarState> { public static defaultProps: Partial<TopBarProps> = { shouldFullWidth: false, style: {}, isNightVersion: false, }; constructor(props: TopBarProps) { super(props); this.state = { isDrawerOpen: false, }; } public render() { const isNightVersion = this.props.isNightVersion; const isFullWidthPage = this.props.shouldFullWidth; const parentClassNames = `flex mx-auto ${isFullWidthPage ? 'pl2' : 'max-width-4'}`; const developerSectionMenuItems = [ <Link key="subMenuItem-zeroEx" to={WebsitePaths.ZeroExJs} className="text-decoration-none" > <MenuItem style={{fontSize: styles.menuItem.fontSize}} primaryText="0x.js" /> </Link>, <Link key="subMenuItem-smartContracts" to={WebsitePaths.SmartContracts} className="text-decoration-none" > <MenuItem style={{fontSize: styles.menuItem.fontSize}} primaryText="Smart Contracts" /> </Link>, <Link key="subMenuItem-0xconnect" to={WebsitePaths.Connect} className="text-decoration-none" > <MenuItem style={{fontSize: styles.menuItem.fontSize}} primaryText="0x Connect" /> </Link>, <a key="subMenuItem-standard-relayer-api" target="_blank" className="text-decoration-none" href={constants.STANDARD_RELAYER_API_GITHUB} > <MenuItem style={{fontSize: styles.menuItem.fontSize}} primaryText="Standard Relayer API" /> </a>, <a key="subMenuItem-github" target="_blank" className="text-decoration-none" href={constants.GITHUB_URL} > <MenuItem style={{fontSize: styles.menuItem.fontSize}} primaryText="GitHub" /> </a>, <a key="subMenuItem-whitePaper" target="_blank" className="text-decoration-none" href={`${WebsitePaths.Whitepaper}`} > <MenuItem style={{fontSize: styles.menuItem.fontSize}} primaryText="Whitepaper" /> </a>, ]; const bottomBorderStyle = this.shouldDisplayBottomBar() ? styles.bottomBar : {}; const fullWidthClasses = isFullWidthPage ? 'pr4' : ''; const logoUrl = isNightVersion ? '/images/protocol_logo_white.png' : '/images/protocol_logo_black.png'; const menuClasses = `col col-${isFullWidthPage ? '4' : '5'} ${fullWidthClasses} lg-pr0 md-pr2 sm-hide xs-hide`; const menuIconStyle = { fontSize: 25, color: isNightVersion ? 'white' : 'black', cursor: 'pointer', paddingTop: 16, }; return ( <div style={{...styles.topBar, ...bottomBorderStyle, ...this.props.style}} className="pb1"> <div className={parentClassNames}> <div className="col col-2 sm-pl2 md-pl2 lg-pl0" style={{paddingTop: 15}}> <Link to={`${WebsitePaths.Home}`} className="text-decoration-none"> <img src={logoUrl} height="30" /> </Link> </div> <div className={`col col-${isFullWidthPage ? '8' : '9'} lg-hide md-hide`} /> <div className={`col col-${isFullWidthPage ? '6' : '5'} sm-hide xs-hide`} /> {!this.isViewingPortal() && <div className={menuClasses} > <div className="flex justify-between"> <DropDownMenuItem title="Developers" subMenuItems={developerSectionMenuItems} style={styles.menuItem} isNightVersion={isNightVersion} /> <TopBarMenuItem title="Wiki" path={`${WebsitePaths.Wiki}`} style={styles.menuItem} isNightVersion={isNightVersion} /> <TopBarMenuItem title="About" path={`${WebsitePaths.About}`} style={styles.menuItem} isNightVersion={isNightVersion} /> <TopBarMenuItem title="Portal DApp" path={`${WebsitePaths.Portal}`} isPrimary={true} style={styles.menuItem} className={`${isFullWidthPage && 'md-hide'}`} isNightVersion={isNightVersion} /> </div> </div> } {this.props.blockchainIsLoaded && !_.isEmpty(this.props.userAddress) && <div className="col col-5"> {this.renderUser()} </div> } {!this.isViewingPortal() && <div className={`col ${isFullWidthPage ? 'col-2 pl2' : 'col-1'} md-hide lg-hide`} > <div style={menuIconStyle}> <i className="zmdi zmdi-menu" onClick={this.onMenuButtonClick.bind(this)} /> </div> </div> } </div> {this.renderDrawer()} </div> ); } private renderDrawer() { return ( <Drawer open={this.state.isDrawerOpen} docked={false} openSecondary={true} onRequestChange={this.onMenuButtonClick.bind(this)} > {this.renderPortalMenu()} {this.renderDocsMenu()} {this.renderWiki()} <div className="pl1 py1 mt3" style={{backgroundColor: colors.lightGrey}}>Website</div> <Link to={WebsitePaths.Home} className="text-decoration-none"> <MenuItem className="py2">Home</MenuItem> </Link> <Link to={`${WebsitePaths.Wiki}`} className="text-decoration-none"> <MenuItem className="py2">Wiki</MenuItem> </Link> {!this.isViewing0xjsDocs() && <Link to={WebsitePaths.ZeroExJs} className="text-decoration-none"> <MenuItem className="py2">0x.js Docs</MenuItem> </Link> } {!this.isViewingConnectDocs() && <Link to={WebsitePaths.Connect} className="text-decoration-none"> <MenuItem className="py2">0x Connect Docs</MenuItem> </Link> } {!this.isViewingSmartContractsDocs() && <Link to={WebsitePaths.SmartContracts} className="text-decoration-none"> <MenuItem className="py2">Smart Contract Docs</MenuItem> </Link> } {!this.isViewingPortal() && <Link to={`${WebsitePaths.Portal}`} className="text-decoration-none"> <MenuItem className="py2">Portal DApp</MenuItem> </Link> } <a className="text-decoration-none" target="_blank" href={`${WebsitePaths.Whitepaper}`} > <MenuItem className="py2">Whitepaper</MenuItem> </a> <Link to={`${WebsitePaths.About}`} className="text-decoration-none"> <MenuItem className="py2">About</MenuItem> </Link> <a className="text-decoration-none" target="_blank" href={constants.BLOG_URL} > <MenuItem className="py2">Blog</MenuItem> </a> <Link to={`${WebsitePaths.FAQ}`} className="text-decoration-none"> <MenuItem className="py2" onTouchTap={this.onMenuButtonClick.bind(this)} > FAQ </MenuItem> </Link> </Drawer> ); } private renderDocsMenu() { if (!this.isViewing0xjsDocs() && !this.isViewingSmartContractsDocs() && !this.isViewingConnectDocs() || _.isUndefined(this.props.menu)) { return; } const sectionTitle = `${this.props.docsInfo.displayName} Docs`; return ( <div className="lg-hide md-hide"> <div className="pl1 py1" style={{backgroundColor: colors.lightGrey}}>{sectionTitle}</div> <NestedSidebarMenu topLevelMenu={this.props.menu} menuSubsectionsBySection={this.props.menuSubsectionsBySection} shouldDisplaySectionHeaders={false} onMenuItemClick={this.onMenuButtonClick.bind(this)} selectedVersion={this.props.docsVersion} docPath={this.props.docsInfo.websitePath} versions={this.props.availableDocVersions} /> </div> ); } private renderWiki() { if (!this.isViewingWiki()) { return; } return ( <div className="lg-hide md-hide"> <div className="pl1 py1" style={{backgroundColor: colors.lightGrey}}>0x Protocol Wiki</div> <NestedSidebarMenu topLevelMenu={this.props.menuSubsectionsBySection} menuSubsectionsBySection={this.props.menuSubsectionsBySection} shouldDisplaySectionHeaders={false} onMenuItemClick={this.onMenuButtonClick.bind(this)} /> </div> ); } private renderPortalMenu() { if (!this.isViewingPortal()) { return; } return ( <div className="lg-hide md-hide"> <div className="pl1 py1" style={{backgroundColor: colors.lightGrey}}>Portal DApp</div> <PortalMenu menuItemStyle={{color: 'black'}} onClick={this.onMenuButtonClick.bind(this)} /> </div> ); } private renderUser() { const userAddress = this.props.userAddress; const identiconDiameter = 26; return ( <div className="flex right lg-pr0 md-pr2 sm-pr2" style={{paddingTop: 16}} > <div style={styles.address} data-tip={true} data-for="userAddressTooltip" > {!_.isEmpty(userAddress) ? userAddress : ''} </div> <ReactTooltip id="userAddressTooltip">{userAddress}</ReactTooltip> <div> <Identicon address={userAddress} diameter={identiconDiameter} /> </div> </div> ); } private onMenuButtonClick() { this.setState({ isDrawerOpen: !this.state.isDrawerOpen, }); } private isViewingPortal() { return _.includes(this.props.location.pathname, WebsitePaths.Portal); } private isViewingFAQ() { return _.includes(this.props.location.pathname, WebsitePaths.FAQ); } private isViewing0xjsDocs() { return _.includes(this.props.location.pathname, WebsitePaths.ZeroExJs); } private isViewingConnectDocs() { return _.includes(this.props.location.pathname, WebsitePaths.Connect); } private isViewingSmartContractsDocs() { return _.includes(this.props.location.pathname, WebsitePaths.SmartContracts); } private isViewingWiki() { return _.includes(this.props.location.pathname, WebsitePaths.Wiki); } private shouldDisplayBottomBar() { return this.isViewingWiki() || this.isViewing0xjsDocs() || this.isViewingFAQ() || this.isViewingSmartContractsDocs() || this.isViewingConnectDocs(); } }