aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-wxPython24
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /x11-toolkits/py-wxPython24
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'x11-toolkits/py-wxPython24')
-rw-r--r--x11-toolkits/py-wxPython24/Makefile1
-rw-r--r--x11-toolkits/py-wxPython24/files/patch-aa16
2 files changed, 17 insertions, 0 deletions
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
index 6b5e99b3849c..5da7ca741286 100644
--- a/x11-toolkits/py-wxPython24/Makefile
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -26,6 +26,7 @@ USE_GMAKE= yes
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}"
+PYDISTUTILS_NOEGGINFO= yes
USE_WX= 2.4
DEMO_DIR= ${PYTHONPREFIX_SITELIBDIR}/wxPython/demo
diff --git a/x11-toolkits/py-wxPython24/files/patch-aa b/x11-toolkits/py-wxPython24/files/patch-aa
new file mode 100644
index 000000000000..42bd28ded7f2
--- /dev/null
+++ b/x11-toolkits/py-wxPython24/files/patch-aa
@@ -0,0 +1,16 @@
+--- wxPython/py/introspect.py.orig Mon Jul 30 08:07:25 2007
++++ wxPython/py/introspect.py Mon Jul 30 08:07:35 2007
+@@ -1,11 +1,11 @@
+ """Provides a variety of introspective-type support functions for
+ things like call tips and command auto completion."""
+
++from __future__ import nested_scopes
++
+ __author__ = "Patrick K. O'Brien <pobrien@orbtech.com>"
+ __cvsid__ = "$Id: introspect.py,v 1.1.2.2 2003/05/19 21:41:24 PKO Exp $"
+ __revision__ = "$Revision: 1.1.2.2 $"[11:-2]
+-
+-from __future__ import nested_scopes
+
+ import cStringIO
+ import inspect