aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-wxPython24
diff options
context:
space:
mode:
authorreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
committerreg <reg@FreeBSD.org>2000-10-05 14:42:57 +0800
commit72ce7050d03c812e37966786e11996a90713afea (patch)
tree9ec01d647da1c4e80223e31fc766740c2a43ebff /x11-toolkits/py-wxPython24
parent97830337b8c0333a12d15a49ea1f9c9cdc3dfddf (diff)
downloadfreebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.gz
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.tar.zst
freebsd-ports-gnome-72ce7050d03c812e37966786e11996a90713afea.zip
Implement USE_GTK, part 2.
Diffstat (limited to 'x11-toolkits/py-wxPython24')
-rw-r--r--x11-toolkits/py-wxPython24/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-toolkits/py-wxPython24/Makefile b/x11-toolkits/py-wxPython24/Makefile
index 87fadb373c49..9e8a136742b9 100644
--- a/x11-toolkits/py-wxPython24/Makefile
+++ b/x11-toolkits/py-wxPython24/Makefile
@@ -18,9 +18,10 @@ LIB_DEPENDS= wx_gtk.2:${PORTSDIR}/x11-toolkits/wxgtk
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_PYTHON= YES
-USE_GMAKE= YES
-USE_NEWGCC= YES
+USE_GMAKE= yes
+USE_NEWGCC= yes
+USE_PYTHON= yes
+USE_GTK= yes
MAKE_ENV= "LN_S=${LN} -s" "INSTALL_DATA=${INSTALL_DATA}"
ALL_TARGET= default
INSTALL_TARGET= install-freebsd
@@ -30,8 +31,8 @@ TARGETDIR= ${PYTHON_SITELIBDIR}/wxPython
HELPERLIBDIR= ${PREFIX}/lib
do-configure:
- ${SED} -e "s:%CFLAGS%:${CFLAGS} `gtk12-config --cflags`:" \
- -e "s:%LFLAGS%:`gtk12-config --libs` -L${WRKSRC}:" \
+ ${SED} -e "s:%CFLAGS%:${CFLAGS} `${GTK_CONFIG} --cflags`:" \
+ -e "s:%LFLAGS%:`${GTK_CONFIG} --libs` -L${WRKSRC}:" \
-e "s:%TARGETDIR%:${TARGETDIR}:" \
-e "s:%HELPERLIBDIR%:${HELPERLIBDIR}:" \
-e "s:%CXX%:${CXX}:" -e "s:%WRKSRC%:${WRKSRC}:" \