aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-wxPython28/Makefile
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-06-05 11:54:09 +0800
committerlioux <lioux@FreeBSD.org>2003-06-05 11:54:09 +0800
commitf8146a41c74c6472791a4e52ced063add375c854 (patch)
tree4b47943f27975092dac838b93df23c37289489a2 /x11-toolkits/py-wxPython28/Makefile
parent4323322a994b49e350482ee42cc3434ca5bff399 (diff)
downloadfreebsd-ports-gnome-f8146a41c74c6472791a4e52ced063add375c854.tar.gz
freebsd-ports-gnome-f8146a41c74c6472791a4e52ced063add375c854.tar.zst
freebsd-ports-gnome-f8146a41c74c6472791a4e52ced063add375c854.zip
Fix wxgtk gtk12 or gtk20 detection code
Noticed by: Adam <blueeskimo@gmx.net>
Diffstat (limited to 'x11-toolkits/py-wxPython28/Makefile')
-rw-r--r--x11-toolkits/py-wxPython28/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/py-wxPython28/Makefile b/x11-toolkits/py-wxPython28/Makefile
index c719a2f90346..cb832c25ad56 100644
--- a/x11-toolkits/py-wxPython28/Makefile
+++ b/x11-toolkits/py-wxPython28/Makefile
@@ -51,12 +51,12 @@ post-install:
.if exists(${WX_CONFIG})
# detect if wxgtk was linked against gtk1 or gtk2
-DECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs | ${GREP} glib-2.0
+DECISION_GTK_1_OR_2!= ${WX_CONFIG} --static --libs
.else
DECISION_GTK_1_OR_2= ""
.endif
-.if (${DECISION_GTK_1_OR_2} != "")
+.if ${DECISION_GTK_1_OR_2:M*glib-2.0} != ""
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --enable-gtk2
PYDISTUTILS_BUILDARGS+= WXPORT=gtk2