aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/py-xlib
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-07-20 07:25:17 +0800
committerrafan <rafan@FreeBSD.org>2006-07-20 07:25:17 +0800
commitbe7a25c17729cbb534e19a977ae5eb90697a12fd (patch)
treed85cf61e3b361472f8cd7b74745726c1f880327e /x11-toolkits/py-xlib
parente02f7dd92039dc4cf22448b7e215b1ec0b5b664f (diff)
downloadfreebsd-ports-gnome-be7a25c17729cbb534e19a977ae5eb90697a12fd.tar.gz
freebsd-ports-gnome-be7a25c17729cbb534e19a977ae5eb90697a12fd.tar.zst
freebsd-ports-gnome-be7a25c17729cbb534e19a977ae5eb90697a12fd.zip
The py-xlib code has some problems running in a modern
environment. It refers to modules that don't exist any more, is missing encoding declerations, and needs a buffer bumped. This commit addresses these problems. PR: ports/100569 Submitted by: maintainer
Diffstat (limited to 'x11-toolkits/py-xlib')
-rw-r--r--x11-toolkits/py-xlib/Makefile1
-rw-r--r--x11-toolkits/py-xlib/files/patch-display18
-rw-r--r--x11-toolkits/py-xlib/files/patch-unix_connect14
3 files changed, 33 insertions, 0 deletions
diff --git a/x11-toolkits/py-xlib/Makefile b/x11-toolkits/py-xlib/Makefile
index fa03ace20312..df51b93fec17 100644
--- a/x11-toolkits/py-xlib/Makefile
+++ b/x11-toolkits/py-xlib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xlib
PORTVERSION= 0.12a
+PORTREVISION= 1
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= python-xlib
diff --git a/x11-toolkits/py-xlib/files/patch-display b/x11-toolkits/py-xlib/files/patch-display
new file mode 100644
index 000000000000..4d573c94ad81
--- /dev/null
+++ b/x11-toolkits/py-xlib/files/patch-display
@@ -0,0 +1,18 @@
+--- Xlib/protocol/display.py-orig Tue Jul 18 15:28:31 2006
++++ Xlib/protocol/display.py Tue Jul 18 15:29:31 2006
+@@ -1,5 +1,5 @@
+ # $Id: display.py,v 1.17 2002/02/25 11:09:23 petli Exp $
+-#
++# -*- coding: latin-1 -*-
+ # Xlib.protocol.display -- core display communication
+ #
+ # Copyright (C) 2000-2002 Peter Liljenberg <petli@ctrl-c.liu.se>
+@@ -527,7 +527,7 @@
+ # We're the recieving thread, parse the data
+ if recieving:
+ try:
+- recv = self.socket.recv(2048)
++ recv = self.socket.recv(4096)
+ except socket.error, err:
+ self.close_internal('server: %s' % err[1])
+ raise self.socket_error
diff --git a/x11-toolkits/py-xlib/files/patch-unix_connect b/x11-toolkits/py-xlib/files/patch-unix_connect
new file mode 100644
index 000000000000..d068cdf0f942
--- /dev/null
+++ b/x11-toolkits/py-xlib/files/patch-unix_connect
@@ -0,0 +1,14 @@
+--- Xlib/support/unix_connect.py-orig Tue Jul 18 15:34:34 2006
++++ Xlib/support/unix_connect.py Tue Jul 18 15:35:10 2006
+@@ -23,7 +23,10 @@
+ import os
+ import socket
+ import fcntl
+-import FCNTL
++try:
++ import FCNTL
++except ImportError:
++ FCNTL = fcntl
+
+ from Xlib import error
+