aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt23
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-08-30 07:44:32 +0800
committerwill <will@FreeBSD.org>2000-08-30 07:44:32 +0800
commitd48002a5eba327be116a39d98284bc777b760595 (patch)
treea17c9f2dbb27c76df3b636a3efb150d8b5e361e3 /x11-toolkits/qt23
parentf41da54892a3f20904be09edeeac50bf02fd36f3 (diff)
downloadfreebsd-ports-gnome-d48002a5eba327be116a39d98284bc777b760595.tar.gz
freebsd-ports-gnome-d48002a5eba327be116a39d98284bc777b760595.tar.zst
freebsd-ports-gnome-d48002a5eba327be116a39d98284bc777b760595.zip
Update to 20000829A snapshot. Disable kdenetwork2 for the time being so
I can address some of its issues (should see it marked un-broken in about 3 hours, if they're trivial enough). It took too long to get this update out the door... :-( This is a rather stable version of KDE2. Release is hoped for sometime next month, so I'm going to try to reroll snapshots this weekend. Also decide policy by removing the interactive requirement in qt22's configure script. I don't know why they bothered adding it there.. Bugged by: *many* bug-reports, requests, etc.
Diffstat (limited to 'x11-toolkits/qt23')
-rw-r--r--x11-toolkits/qt23/Makefile52
-rw-r--r--x11-toolkits/qt23/distinfo2
-rw-r--r--x11-toolkits/qt23/files/patch-aa41
-rw-r--r--x11-toolkits/qt23/pkg-plist298
4 files changed, 327 insertions, 66 deletions
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 1109303f8414..3fdceaa569b5 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -6,17 +6,15 @@
#
PORTNAME= qt
-PORTVERSION= 20000724A
+PORTVERSION= 20000829A
CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= will
+MASTER_SITES= http://www.physics.purdue.edu/~will/
MAINTAINER= will@FreeBSD.org
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-WRKSRC= ${WRKDIR}/${PORTNAME}-copy
USE_MESA= yes
USE_BZIP2= yes
NO_LATEST_LINK= yes
@@ -27,7 +25,7 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
CONFIGURE_ENV= QTDIR=${WRKSRC}
-MAKE_ENV= QTDIR=${WRKSRC}
+MAKE_ENV= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib
CONFIG= ${WRKSRC}/configs/freebsd-g++-shared
@@ -46,17 +44,20 @@ pre-fetch:
@${ECHO} "that installation, deinstall it and then install this port."
@${ECHO} "Note that this port contains beta-quality source code and"
@${ECHO} "must be used only wherever absolutely needed, such as for"
- @${ECHO} "KDE2 snapshot 20000724A and later."
+ @${ECHO} "KDE2 snapshot 20000829A and later."
@${FALSE}
.endif
pre-configure:
- ${PERL} -pi -e "s,gcc,${CC},g" ${CONFIG}
- ${PERL} -pi -e "s,g\+\+,${CXX},g" ${CONFIG}
- ${PERL} -pi -e "s,/usr/X11R6,${X11BASE},g" ${CONFIG}
- ${PERL} -pi -e "s,-pipe -O2,${CXXFLAGS},g" ${CONFIG}
+ @${CP} ${CONFIG} ${CONFIG}.new
+ ${SED} -e "s,gcc,${CC},g" ${CONFIG}.new | ${SED} -e "s,g\+\+,${CXX},g" | \
+ ${SED} -e "s,/usr/X11R6,${X11BASE},g" | ${SED} -e "s,-pipe -O2,${CXXFLAGS},g" > ${CONFIG}
${PERL} -pi -e "s@VER_MAJ = 2@VER_MAJ = 4@g" ${WRKSRC}/src/Makefile.in
${PERL} -pi -e "s@TARGET = qt@TARGET = qt2@g" ${WRKSRC}/src/Makefile.in
+ ${PERL} -pi -e "s@TARGET = moc@TARGET = moc2@g" ${WRKSRC}/src/moc/Makefile.in
+ ${PERL} -pi -e "s@cp src/moc/moc bin/moc@cp src/moc/moc bin/moc2@g" ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s@symlinks moc src-mt src tools tutorial examples@symlinks moc src-mt src tools@g" ${WRKSRC}/Makefile
+ ${PERL} -pi -e "s@-L../lib@-L${WRKSRC}/lib@g" ${WRKSRC}/tools/designer/uic/Makefile.in
post-configure:
@(cd ${WRKSRC} ; ${GMAKE} symlinks)
@@ -66,21 +67,19 @@ pre-install:
do-install:
${MKDIR} ${PREFIX}/include/qt2
- (cd ${WRKSRC} ; \
- ${INSTALL_PROGRAM} bin/mergetr ${PREFIX}/bin ; \
- ${INSTALL_PROGRAM} bin/moc ${PREFIX}/bin/moc2 ; \
- ${INSTALL_PROGRAM} bin/msg2qm ${PREFIX}/bin ; \
- ${INSTALL_SCRIPT} bin/findtr ${PREFIX}/bin ; \
- ${INSTALL_SCRIPT} bin/qt20fix ${PREFIX}/bin ; \
- ${INSTALL_SCRIPT} bin/qtrename140 ${PREFIX}/bin ; \
- ${INSTALL_DATA} include/*.h ${PREFIX}/include/qt2 ; \
- ${INSTALL_DATA} lib/libqgl.a ${PREFIX}/lib ; \
- ${INSTALL_DATA} lib/libqxt.a ${PREFIX}/lib ; \
- ${INSTALL_DATA} lib/libqt2.so.4 ${PREFIX}/lib )
- ${LN} -sf libqt2.so.4 ${PREFIX}/lib/libqt2.so
- ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
+.for BIN in designer moc2 uic
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${BIN} ${PREFIX}/bin
+.endfor
+.for SCRIPT in findtr qt20fix qtrename140
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/${SCRIPT} ${PREFIX}/bin
+.endfor
+ ${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/include/qt2
+.for LIB in qt2 qutil
+ ${INSTALL_DATA} ${WRKSRC}/lib/lib${LIB}* ${PREFIX}/lib
+.endfor
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/qt2/html
+ ${MKDIR} ${PREFIX}/share/doc/qt2/html/designer/figures
+ ${MKDIR} ${PREFIX}/share/doc/qt2/html/designer/stylesheet-images
(cd ${WRKSRC} ; \
${INSTALL_DATA} ANNOUNCE ${PREFIX}/share/doc/qt2 ; \
${INSTALL_DATA} FAQ ${PREFIX}/share/doc/qt2 ; \
@@ -88,7 +87,10 @@ do-install:
${INSTALL_DATA} PORTING ${PREFIX}/share/doc/qt2 ; \
${INSTALL_DATA} README ${PREFIX}/share/doc/qt2 ; \
${INSTALL_DATA} README.QT ${PREFIX}/share/doc/qt2 ; \
- ${INSTALL_DATA} doc/html/* ${PREFIX}/share/doc/qt2/html ; \
+ ${INSTALL_DATA} doc/html/*.html doc/html/*.png doc/html/*.jpg ${PREFIX}/share/doc/qt2/html ; \
+ ${INSTALL_DATA} doc/html/designer/*.html ${PREFIX}/share/doc/qt2/html/designer ; \
+ ${INSTALL_DATA} doc/html/designer/stylesheet-images/* ${PREFIX}/share/doc/qt2/html/designer/stylesheet-images ; \
+ ${INSTALL_DATA} doc/html/designer/figures/* ${PREFIX}/share/doc/qt2/html/designer/figures ; \
${INSTALL_MAN} doc/man/man3/q* ${PREFIX}/man/man3 )
.endif
diff --git a/x11-toolkits/qt23/distinfo b/x11-toolkits/qt23/distinfo
index 9b64f04a1e6b..fd457316a45d 100644
--- a/x11-toolkits/qt23/distinfo
+++ b/x11-toolkits/qt23/distinfo
@@ -1 +1 @@
-MD5 (qt-20000724A.tar.bz2) = c7af2fd05a40c47d7d5bdaa1c4f65e0a
+MD5 (qt-20000829A.tar.bz2) = 273445b4aaa4eef58acb908b20794e2f
diff --git a/x11-toolkits/qt23/files/patch-aa b/x11-toolkits/qt23/files/patch-aa
index a18a37d486c6..3fa5dacea8c5 100644
--- a/x11-toolkits/qt23/files/patch-aa
+++ b/x11-toolkits/qt23/files/patch-aa
@@ -1,29 +1,28 @@
---- configs/freebsd-g++-shared.orig Thu Feb 17 01:55:56 2000
-+++ configs/freebsd-g++-shared Sat Feb 26 20:25:51 2000
-@@ -16,7 +16,7 @@
+--- configs/freebsd-g++-shared Tue Aug 22 03:11:09 2000
++++ configs/freebsd-g++-shared.new Sat Aug 26 09:50:52 2000
+@@ -21,7 +21,7 @@
SYSCONF_LIBS_X11 = -lXext -lX11 -lm
# Qt, Qt+OpenGL
SYSCONF_LFLAGS_QT = -L$(QTDIR)/lib
--SYSCONF_LIBS_QT = -lqt
-+SYSCONF_LIBS_QT = -lqt2
- SYSCONF_LIBS_QT_OPENGL = -lqgl
+-SYSCONF_LIBS_QT = -lqt$(QT_THREAD_SUFFIX)
++SYSCONF_LIBS_QT = -lqt2$(QT_THREAD_SUFFIX)
+ SYSCONF_LIBS_QT_OPENGL =
# OpenGL
SYSCONF_LFLAGS_OPENGL = -L/usr/X11R6/lib
-@@ -27,7 +27,7 @@
- # Linking applications
- SYSCONF_LINK = g++
- SYSCONF_LFLAGS =
--SYSCONF_LIBS =
-+SYSCONF_LIBS = -lxpg4
+@@ -44,7 +44,7 @@
+ SYSCONF_LIBS_THREAD =
- # Link flags shared objects
- SYSCONF_LFLAGS_SHOBJ = -shared
-@@ -41,16 +41,26 @@
+ # Meta-object compiler
+-SYSCONF_MOC = $(QTDIR)/bin/moc
++SYSCONF_MOC = $(QTDIR)/bin/moc2
+
+ # UI compiler
+ SYSCONF_UIC = $(QTDIR)/bin/uic
+@@ -55,16 +55,15 @@
# - Usually needs to incorporate $(VER_MAJ), $(VER_MIN) and $(VER_PATCH)
#
SYSCONF_LINK_SHLIB = g++
-SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ).$(VER_MIN).$(VER_PATCH)
-+ifeq ($(PORTOBJFORMAT),elf)
+SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ)
SYSCONF_LINK_LIB_SHARED = $(SYSCONF_LINK_SHLIB) -shared \
$(LFLAGS) -o $(SYSCONF_LINK_TARGET_SHARED) \
@@ -37,16 +36,6 @@
- ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so.$(VER_MAJ).$(VER_MIN)
+ rm -f lib$(TARGET).so; \
+ ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so
-+else
-+SYSCONF_LINK_TARGET_SHARED = lib$(TARGET).so.$(VER_MAJ).$(VER_MIN)$(VER_PATCH)
-+SYSCONF_LINK_LIB_SHARED = $(SYSCONF_LINK_SHLIB) -shared \
-+ $(LFLAGS) -o $(SYSCONF_LINK_TARGET_SHARED) \
-+ $(OBJECTS) $(OBJMOC) $(LIBS) && \
-+ mv $(SYSCONF_LINK_TARGET_SHARED) $(DESTDIR); \
-+ cd $(DESTDIR) && \
-+ rm -f lib$(TARGET).so; \
-+ ln -s $(SYSCONF_LINK_TARGET_SHARED) lib$(TARGET).so
-+endif
# Linking static libraries
# - Build the $(TARGET) library, eg. lib$(TARGET).a
diff --git a/x11-toolkits/qt23/pkg-plist b/x11-toolkits/qt23/pkg-plist
index 008d49d82c4d..e19c6deda73b 100644
--- a/x11-toolkits/qt23/pkg-plist
+++ b/x11-toolkits/qt23/pkg-plist
@@ -1,9 +1,9 @@
+bin/designer
bin/findtr
-bin/mergetr
bin/moc2
-bin/msg2qm
bin/qt20fix
bin/qtrename140
+bin/uic
include/qt2/q1xcompatibility.h
include/qt2/qabstractlayout.h
include/qt2/qaccel.h
@@ -38,7 +38,7 @@ include/qt2/qcolordialog.h
include/qt2/qcombo.h
include/qt2/qcombobox.h
include/qt2/qcommonstyle.h
-include/qt2/qcompactstyle.h
+include/qt2/qconfig-dist.h
include/qt2/qconfig-embedded.h
include/qt2/qconfig-minimal.h
include/qt2/qconfig.h
@@ -54,12 +54,12 @@ include/qt2/qdialog.h
include/qt2/qdict.h
include/qt2/qdir.h
include/qt2/qdns.h
+include/qt2/qdom.h
include/qt2/qdragobject.h
include/qt2/qdrawutil.h
include/qt2/qdrawutl.h
include/qt2/qdropsite.h
include/qt2/qdstream.h
-include/qt2/qerrormessage.h
include/qt2/qeucjpcodec.h
include/qt2/qeuckrcodec.h
include/qt2/qevent.h
@@ -135,6 +135,8 @@ include/qt2/qmetaobject.h
include/qt2/qmime.h
include/qt2/qmlined.h
include/qt2/qmngio.h
+include/qt2/qmodules.h
+include/qt2/qmotifplusstyle.h
include/qt2/qmotifstyle.h
include/qt2/qmovie.h
include/qt2/qmsgbox.h
@@ -143,7 +145,6 @@ include/qt2/qmultilineedit.h
include/qt2/qnamespace.h
include/qt2/qnetwork.h
include/qt2/qnetworkprotocol.h
-include/qt2/qnp.h
include/qt2/qobjcoll.h
include/qt2/qobjdefs.h
include/qt2/qobject.h
@@ -231,6 +232,7 @@ include/qt2/qt_x11.h
include/qt2/qtabbar.h
include/qt2/qtabdialog.h
include/qt2/qtabdlg.h
+include/qt2/qtable.h
include/qt2/qtableview.h
include/qt2/qtablevw.h
include/qt2/qtabwidget.h
@@ -272,11 +274,12 @@ include/qt2/qwindowsstyle.h
include/qt2/qwizard.h
include/qt2/qwmatrix.h
include/qt2/qworkspace.h
+include/qt2/qxml.h
include/qt2/qxt.h
-lib/libqgl.a
-lib/libqt2.so.4
lib/libqt2.so
-lib/libqxt.a
+lib/libqt2.so.4
+lib/libqutil.so
+lib/libqutil.so.1
share/doc/qt2/ANNOUNCE
share/doc/qt2/FAQ
share/doc/qt2/LICENSE.QPL
@@ -284,10 +287,13 @@ share/doc/qt2/PORTING
share/doc/qt2/README
share/doc/qt2/README.QT
share/doc/qt2/html/HOWTO-framebuffer.html
+share/doc/qt2/html/XML-SAX.html
+share/doc/qt2/html/XML.html
share/doc/qt2/html/aboutqt.html
share/doc/qt2/html/abstractwidgets.html
share/doc/qt2/html/accelerators.html
share/doc/qt2/html/aclock-main-cpp.html
+share/doc/qt2/html/action-main-cpp.html
share/doc/qt2/html/addressbook-main-cpp.html
share/doc/qt2/html/advanced.html
share/doc/qt2/html/annotated.html
@@ -304,8 +310,12 @@ share/doc/qt2/html/buttongroup-m.png
share/doc/qt2/html/buttongroup-w.png
share/doc/qt2/html/buttongroups-main-cpp.html
share/doc/qt2/html/buyhowto.html
+share/doc/qt2/html/canvas.html
+share/doc/qt2/html/casestudy-qws.html
share/doc/qt2/html/changes21.html
share/doc/qt2/html/changes211.html
+share/doc/qt2/html/changes22.html
+share/doc/qt2/html/charinput-qws.html
share/doc/qt2/html/checklists-main-cpp.html
share/doc/qt2/html/classes.html
share/doc/qt2/html/collection.html
@@ -320,6 +330,144 @@ share/doc/qt2/html/datastreamformat.html
share/doc/qt2/html/dclock-main-cpp.html
share/doc/qt2/html/debug.html
share/doc/qt2/html/design.html
+share/doc/qt2/html/designer.html
+share/doc/qt2/html/designer.png
+share/doc/qt2/html/designer/book1.html
+share/doc/qt2/html/designer/c23.html
+share/doc/qt2/html/designer/c289.html
+share/doc/qt2/html/designer/c291.html
+share/doc/qt2/html/designer/c33.html
+share/doc/qt2/html/designer/c498.html
+share/doc/qt2/html/designer/c502.html
+share/doc/qt2/html/designer/c638.html
+share/doc/qt2/html/designer/c645.html
+share/doc/qt2/html/designer/c654.html
+share/doc/qt2/html/designer/c657.html
+share/doc/qt2/html/designer/c660.html
+share/doc/qt2/html/designer/c663.html
+share/doc/qt2/html/designer/c906.html
+share/doc/qt2/html/designer/c909.html
+share/doc/qt2/html/designer/c912.html
+share/doc/qt2/html/designer/c915.html
+share/doc/qt2/html/designer/c918.html
+share/doc/qt2/html/designer/f2.html
+share/doc/qt2/html/designer/figures/adjustsize.png
+share/doc/qt2/html/designer/figures/breaklayout.png
+share/doc/qt2/html/designer/figures/buttongroup.png
+share/doc/qt2/html/designer/figures/buttongroupovercheckboxes.png
+share/doc/qt2/html/designer/figures/checkbox.png
+share/doc/qt2/html/designer/figures/combobox.png
+share/doc/qt2/html/designer/figures/connections.png
+share/doc/qt2/html/designer/figures/connecttool.png
+share/doc/qt2/html/designer/figures/customwidget.png
+share/doc/qt2/html/designer/figures/editcopy.png
+share/doc/qt2/html/designer/figures/editcustomwidgets.png
+share/doc/qt2/html/designer/figures/editcut.png
+share/doc/qt2/html/designer/figures/editdelete.png
+share/doc/qt2/html/designer/figures/editgrid.png
+share/doc/qt2/html/designer/figures/edithlayout.png
+share/doc/qt2/html/designer/figures/editlower.png
+share/doc/qt2/html/designer/figures/editpaste.png
+share/doc/qt2/html/designer/figures/editraise.png
+share/doc/qt2/html/designer/figures/editslots.png
+share/doc/qt2/html/designer/figures/emptydialog.png
+share/doc/qt2/html/designer/figures/filenew.png
+share/doc/qt2/html/designer/figures/filesave.png
+share/doc/qt2/html/designer/figures/firstdialog.png
+share/doc/qt2/html/designer/figures/form.png
+share/doc/qt2/html/designer/figures/fourcheckboxes.png
+share/doc/qt2/html/designer/figures/frame.png
+share/doc/qt2/html/designer/figures/groupbox.png
+share/doc/qt2/html/designer/figures/help.png
+share/doc/qt2/html/designer/figures/home.png
+share/doc/qt2/html/designer/figures/iconview.png
+share/doc/qt2/html/designer/figures/image.png
+share/doc/qt2/html/designer/figures/label.png
+share/doc/qt2/html/designer/figures/layout.png
+share/doc/qt2/html/designer/figures/layouttutstep1.png
+share/doc/qt2/html/designer/figures/layouttutstep10.png
+share/doc/qt2/html/designer/figures/layouttutstep11.png
+share/doc/qt2/html/designer/figures/layouttutstep2.png
+share/doc/qt2/html/designer/figures/layouttutstep3.png
+share/doc/qt2/html/designer/figures/layouttutstep4.png
+share/doc/qt2/html/designer/figures/layouttutstep5.png
+share/doc/qt2/html/designer/figures/layouttutstep6.png
+share/doc/qt2/html/designer/figures/layouttutstep7.png
+share/doc/qt2/html/designer/figures/layouttutstep9.png
+share/doc/qt2/html/designer/figures/lcdnumber.png
+share/doc/qt2/html/designer/figures/left.png
+share/doc/qt2/html/designer/figures/line.png
+share/doc/qt2/html/designer/figures/lineedit.png
+share/doc/qt2/html/designer/figures/listbox.png
+share/doc/qt2/html/designer/figures/listview.png
+share/doc/qt2/html/designer/figures/load.png
+share/doc/qt2/html/designer/figures/multilineedit.png
+share/doc/qt2/html/designer/figures/newform.png
+share/doc/qt2/html/designer/figures/newformdialog.png
+share/doc/qt2/html/designer/figures/objecthierarchy.png
+share/doc/qt2/html/designer/figures/onecheckbox.png
+share/doc/qt2/html/designer/figures/ordertool.png
+share/doc/qt2/html/designer/figures/pixlabel.png
+share/doc/qt2/html/designer/figures/pointer.png
+share/doc/qt2/html/designer/figures/print.png
+share/doc/qt2/html/designer/figures/progress.png
+share/doc/qt2/html/designer/figures/pushbutton.png
+share/doc/qt2/html/designer/figures/radiobutton.png
+share/doc/qt2/html/designer/figures/redo.png
+share/doc/qt2/html/designer/figures/right.png
+share/doc/qt2/html/designer/figures/slider.png
+share/doc/qt2/html/designer/figures/slots.png
+share/doc/qt2/html/designer/figures/spacer.png
+share/doc/qt2/html/designer/figures/spinbox.png
+share/doc/qt2/html/designer/figures/startup.png
+share/doc/qt2/html/designer/figures/taborderform.png
+share/doc/qt2/html/designer/figures/tabwidget.png
+share/doc/qt2/html/designer/figures/testmode.png
+share/doc/qt2/html/designer/figures/textbrowser.png
+share/doc/qt2/html/designer/figures/textview.png
+share/doc/qt2/html/designer/figures/toolbutton.png
+share/doc/qt2/html/designer/figures/undo.png
+share/doc/qt2/html/designer/figures/vlayout.png
+share/doc/qt2/html/designer/i666.html
+share/doc/qt2/html/designer/i921.html
+share/doc/qt2/html/designer/p21.html
+share/doc/qt2/html/designer/p652.html
+share/doc/qt2/html/designer/p904.html
+share/doc/qt2/html/designer/qt-designer-sec-layoutmanagement.html
+share/doc/qt2/html/designer/stylesheet-images/caution.gif
+share/doc/qt2/html/designer/stylesheet-images/home.gif
+share/doc/qt2/html/designer/stylesheet-images/important.gif
+share/doc/qt2/html/designer/stylesheet-images/next.gif
+share/doc/qt2/html/designer/stylesheet-images/note.gif
+share/doc/qt2/html/designer/stylesheet-images/prev.gif
+share/doc/qt2/html/designer/stylesheet-images/tip.gif
+share/doc/qt2/html/designer/stylesheet-images/toc-blank.gif
+share/doc/qt2/html/designer/stylesheet-images/toc-minus.gif
+share/doc/qt2/html/designer/stylesheet-images/toc-plus.gif
+share/doc/qt2/html/designer/stylesheet-images/up.gif
+share/doc/qt2/html/designer/stylesheet-images/warning.gif
+share/doc/qt2/html/designer/x12.html
+share/doc/qt2/html/designer/x17.html
+share/doc/qt2/html/designer/x180.html
+share/doc/qt2/html/designer/x182.html
+share/doc/qt2/html/designer/x233.html
+share/doc/qt2/html/designer/x235.html
+share/doc/qt2/html/designer/x270.html
+share/doc/qt2/html/designer/x272.html
+share/doc/qt2/html/designer/x324.html
+share/doc/qt2/html/designer/x326.html
+share/doc/qt2/html/designer/x438.html
+share/doc/qt2/html/designer/x442.html
+share/doc/qt2/html/designer/x479.html
+share/doc/qt2/html/designer/x483.html
+share/doc/qt2/html/designer/x604.html
+share/doc/qt2/html/designer/x608.html
+share/doc/qt2/html/designer/x643.html
+share/doc/qt2/html/designer/x649.html
+share/doc/qt2/html/designer/x701.html
+share/doc/qt2/html/designer/x778.html
+share/doc/qt2/html/designer/x851.html
+share/doc/qt2/html/designer/x869.html
share/doc/qt2/html/desktop-desktop-cpp.html
share/doc/qt2/html/dialogs.html
share/doc/qt2/html/dirview-main-cpp.html
@@ -338,13 +486,13 @@ share/doc/qt2/html/face.png
share/doc/qt2/html/features.html
share/doc/qt2/html/fileiconview-main-cpp.html
share/doc/qt2/html/focus.html
+share/doc/qt2/html/fonts-qws.html
share/doc/qt2/html/forever-forever-cpp.html
share/doc/qt2/html/frames.png
share/doc/qt2/html/functions.html
share/doc/qt2/html/geomanagement.html
share/doc/qt2/html/geometry.html
share/doc/qt2/html/geometry.png
-share/doc/qt2/html/graph.g1n
share/doc/qt2/html/grapher-grapher-cpp.html
share/doc/qt2/html/gridlayout.png
share/doc/qt2/html/groupbox-m.png
@@ -358,12 +506,15 @@ share/doc/qt2/html/hierarchy.html
share/doc/qt2/html/i18n-main-cpp.html
share/doc/qt2/html/i18n.html
share/doc/qt2/html/iconview-main-cpp.html
+share/doc/qt2/html/iconview.html
+share/doc/qt2/html/imageio.html
share/doc/qt2/html/images.html
-share/doc/qt2/html/index
share/doc/qt2/html/index.html
+share/doc/qt2/html/install-qws.html
share/doc/qt2/html/installation.html
share/doc/qt2/html/io.html
share/doc/qt2/html/keyfeatures21.html
+share/doc/qt2/html/keyfeatures22.html
share/doc/qt2/html/layout-layout-cpp.html
share/doc/qt2/html/layout.html
share/doc/qt2/html/letter.png
@@ -385,6 +536,7 @@ share/doc/qt2/html/menu-menu-cpp.html
share/doc/qt2/html/metaobjects.html
share/doc/qt2/html/misc.html
share/doc/qt2/html/moc.html
+share/doc/qt2/html/modules.html
share/doc/qt2/html/movies-main-cpp.html
share/doc/qt2/html/network.html
share/doc/qt2/html/nsplugin.html
@@ -397,13 +549,14 @@ share/doc/qt2/html/palette.png
share/doc/qt2/html/picture-picture-cpp.html
share/doc/qt2/html/pictures.html
share/doc/qt2/html/pnglogo.png
+share/doc/qt2/html/pointer-qws.html
share/doc/qt2/html/popup-popup-cpp.html
+share/doc/qt2/html/porting-qws.html
share/doc/qt2/html/porting.html
share/doc/qt2/html/primes.html
share/doc/qt2/html/progress-progress-cpp.html
share/doc/qt2/html/progressbar-main-cpp.html
share/doc/qt2/html/properties.html
-share/doc/qt2/html/propertyindex
share/doc/qt2/html/qabstractlayout-h.html
share/doc/qt2/html/qaccel-h.html
share/doc/qt2/html/qaccel-members.html
@@ -467,6 +620,7 @@ share/doc/qt2/html/qcacheiterator.html
share/doc/qt2/html/qcanvas-h.html
share/doc/qt2/html/qcanvas-members.html
share/doc/qt2/html/qcanvas.html
+share/doc/qt2/html/qcanvas.png
share/doc/qt2/html/qcanvasellipse-members.html
share/doc/qt2/html/qcanvasellipse.html
share/doc/qt2/html/qcanvasitem-members.html
@@ -540,6 +694,8 @@ share/doc/qt2/html/qcombobox.html
share/doc/qt2/html/qcommonstyle-h.html
share/doc/qt2/html/qcommonstyle-members.html
share/doc/qt2/html/qcommonstyle.html
+share/doc/qt2/html/qcondition-members.html
+share/doc/qt2/html/qcondition.html
share/doc/qt2/html/qconnection-h.html
share/doc/qt2/html/qconnection-members.html
share/doc/qt2/html/qconnection.html
@@ -585,6 +741,44 @@ share/doc/qt2/html/qdictiterator.html
share/doc/qt2/html/qdir-h.html
share/doc/qt2/html/qdir-members.html
share/doc/qt2/html/qdir.html
+share/doc/qt2/html/qdns-h.html
+share/doc/qt2/html/qdns-members.html
+share/doc/qt2/html/qdns.html
+share/doc/qt2/html/qdom-h.html
+share/doc/qt2/html/qdomattr-members.html
+share/doc/qt2/html/qdomattr.html
+share/doc/qt2/html/qdomcdatasection-members.html
+share/doc/qt2/html/qdomcdatasection.html
+share/doc/qt2/html/qdomcharacterdata-members.html
+share/doc/qt2/html/qdomcharacterdata.html
+share/doc/qt2/html/qdomcomment-members.html
+share/doc/qt2/html/qdomcomment.html
+share/doc/qt2/html/qdomdocument-members.html
+share/doc/qt2/html/qdomdocument.html
+share/doc/qt2/html/qdomdocumentfragment-members.html
+share/doc/qt2/html/qdomdocumentfragment.html
+share/doc/qt2/html/qdomdocumenttype-members.html
+share/doc/qt2/html/qdomdocumenttype.html
+share/doc/qt2/html/qdomelement-members.html
+share/doc/qt2/html/qdomelement.html
+share/doc/qt2/html/qdomentity-members.html
+share/doc/qt2/html/qdomentity.html
+share/doc/qt2/html/qdomentityreference-members.html
+share/doc/qt2/html/qdomentityreference.html
+share/doc/qt2/html/qdomimplementation-members.html
+share/doc/qt2/html/qdomimplementation.html
+share/doc/qt2/html/qdomnamednodemap-members.html
+share/doc/qt2/html/qdomnamednodemap.html
+share/doc/qt2/html/qdomnode-members.html
+share/doc/qt2/html/qdomnode.html
+share/doc/qt2/html/qdomnodelist-members.html
+share/doc/qt2/html/qdomnodelist.html
+share/doc/qt2/html/qdomnotation-members.html
+share/doc/qt2/html/qdomnotation.html
+share/doc/qt2/html/qdomprocessinginstruction-members.html
+share/doc/qt2/html/qdomprocessinginstruction.html
+share/doc/qt2/html/qdomtext-members.html
+share/doc/qt2/html/qdomtext.html
share/doc/qt2/html/qdoublevalidator-members.html
share/doc/qt2/html/qdoublevalidator.html
share/doc/qt2/html/qdragenterevent-members.html
@@ -652,6 +846,9 @@ share/doc/qt2/html/qfontmetrics.html
share/doc/qt2/html/qframe-h.html
share/doc/qt2/html/qframe-members.html
share/doc/qt2/html/qframe.html
+share/doc/qt2/html/qftp-h.html
+share/doc/qt2/html/qftp-members.html
+share/doc/qt2/html/qftp.html
share/doc/qt2/html/qgarray-h.html
share/doc/qt2/html/qgarray-members.html
share/doc/qt2/html/qgarray.html
@@ -725,6 +922,9 @@ share/doc/qt2/html/qhgroupbox-members.html
share/doc/qt2/html/qhgroupbox.html
share/doc/qt2/html/qhideevent-members.html
share/doc/qt2/html/qhideevent.html
+share/doc/qt2/html/qhostaddress-h.html
+share/doc/qt2/html/qhostaddress-members.html
+share/doc/qt2/html/qhostaddress.html
share/doc/qt2/html/qicondrag-members.html
share/doc/qt2/html/qicondrag.html
share/doc/qt2/html/qicondragitem-members.html
@@ -871,6 +1071,10 @@ share/doc/qt2/html/qmimesourcefactory-members.html
share/doc/qt2/html/qmimesourcefactory.html
share/doc/qt2/html/qmlined-m.png
share/doc/qt2/html/qmlined-w.png
+share/doc/qt2/html/qmngio-h.html
+share/doc/qt2/html/qmotifplusstyle-h.html
+share/doc/qt2/html/qmotifplusstyle-members.html
+share/doc/qt2/html/qmotifplusstyle.html
share/doc/qt2/html/qmotifstyle-h.html
share/doc/qt2/html/qmotifstyle-members.html
share/doc/qt2/html/qmotifstyle.html
@@ -887,6 +1091,8 @@ share/doc/qt2/html/qmsgbox-w.png
share/doc/qt2/html/qmultilineedit-h.html
share/doc/qt2/html/qmultilineedit-members.html
share/doc/qt2/html/qmultilineedit.html
+share/doc/qt2/html/qmutex-members.html
+share/doc/qt2/html/qmutex.html
share/doc/qt2/html/qnamespace-h.html
share/doc/qt2/html/qnetworkegg.html
share/doc/qt2/html/qnetworkoperation-members.html
@@ -1012,9 +1218,14 @@ share/doc/qt2/html/qscrollview-vp.png
share/doc/qt2/html/qscrollview-vp2.png
share/doc/qt2/html/qscrollview-w.png
share/doc/qt2/html/qscrollview.html
+share/doc/qt2/html/qsemaphore-members.html
+share/doc/qt2/html/qsemaphore.html
share/doc/qt2/html/qsemimodal-h.html
share/doc/qt2/html/qsemimodal-members.html
share/doc/qt2/html/qsemimodal.html
+share/doc/qt2/html/qserversocket-h.html
+share/doc/qt2/html/qserversocket-members.html
+share/doc/qt2/html/qserversocket.html
share/doc/qt2/html/qsessionmanager-h.html
share/doc/qt2/html/qsessionmanager-members.html
share/doc/qt2/html/qsessionmanager.html
@@ -1046,11 +1257,20 @@ share/doc/qt2/html/qsizegrip.html
share/doc/qt2/html/qsizepolicy-h.html
share/doc/qt2/html/qsizepolicy-members.html
share/doc/qt2/html/qsizepolicy.html
+share/doc/qt2/html/qsjiscodec-h.html
+share/doc/qt2/html/qsjiscodec-members.html
+share/doc/qt2/html/qsjiscodec.html
share/doc/qt2/html/qslider-h.html
share/doc/qt2/html/qslider-m.png
share/doc/qt2/html/qslider-members.html
share/doc/qt2/html/qslider-w.png
share/doc/qt2/html/qslider.html
+share/doc/qt2/html/qsocket-h.html
+share/doc/qt2/html/qsocket-members.html
+share/doc/qt2/html/qsocket.html
+share/doc/qt2/html/qsocketdevice-h.html
+share/doc/qt2/html/qsocketdevice-members.html
+share/doc/qt2/html/qsocketdevice.html
share/doc/qt2/html/qsocketnotifier-h.html
share/doc/qt2/html/qsocketnotifier-members.html
share/doc/qt2/html/qsocketnotifier.html
@@ -1119,6 +1339,14 @@ share/doc/qt2/html/qtabdialog-members.html
share/doc/qt2/html/qtabdialog.html
share/doc/qt2/html/qtabdlg-m.png
share/doc/qt2/html/qtabdlg-w.png
+share/doc/qt2/html/qtable-h.html
+share/doc/qt2/html/qtable-members.html
+share/doc/qt2/html/qtable.html
+share/doc/qt2/html/qtable.png
+share/doc/qt2/html/qtableitem-members.html
+share/doc/qt2/html/qtableitem.html
+share/doc/qt2/html/qtableselection-members.html
+share/doc/qt2/html/qtableselection.html
share/doc/qt2/html/qtableview-h.html
share/doc/qt2/html/qtableview-members.html
share/doc/qt2/html/qtableview.html
@@ -1153,6 +1381,9 @@ share/doc/qt2/html/qtextstream.html
share/doc/qt2/html/qtextview-h.html
share/doc/qt2/html/qtextview-members.html
share/doc/qt2/html/qtextview.html
+share/doc/qt2/html/qthread-h.html
+share/doc/qt2/html/qthread-members.html
+share/doc/qt2/html/qthread.html
share/doc/qt2/html/qtimage-qtimage-cpp.html
share/doc/qt2/html/qtime-members.html
share/doc/qt2/html/qtime.html
@@ -1177,6 +1408,9 @@ share/doc/qt2/html/qtooltipgroup.html
share/doc/qt2/html/qtranslator-h.html
share/doc/qt2/html/qtranslator-members.html
share/doc/qt2/html/qtranslator.html
+share/doc/qt2/html/qtsciicodec-h.html
+share/doc/qt2/html/qtsciicodec-members.html
+share/doc/qt2/html/qtsciicodec.html
share/doc/qt2/html/quridrag-members.html
share/doc/qt2/html/quridrag.html
share/doc/qt2/html/qurl-h.html
@@ -1218,6 +1452,7 @@ share/doc/qt2/html/qvbuttongroup.html
share/doc/qt2/html/qvector-h.html
share/doc/qt2/html/qvector-members.html
share/doc/qt2/html/qvector.html
+share/doc/qt2/html/qvfb-qws.html
share/doc/qt2/html/qvgroupbox-h.html
share/doc/qt2/html/qvgroupbox-members.html
share/doc/qt2/html/qvgroupbox.html
@@ -1248,6 +1483,38 @@ share/doc/qt2/html/qwmatrix.html
share/doc/qt2/html/qworkspace-h.html
share/doc/qt2/html/qworkspace-members.html
share/doc/qt2/html/qworkspace.html
+share/doc/qt2/html/qwsdecoration-members.html
+share/doc/qt2/html/qwsdecoration.html
+share/doc/qt2/html/qwsmanager_qws-h.html
+share/doc/qt2/html/qxml-h.html
+share/doc/qt2/html/qxmlattributes-members.html
+share/doc/qt2/html/qxmlattributes.html
+share/doc/qt2/html/qxmlcontenthandler-members.html
+share/doc/qt2/html/qxmlcontenthandler.html
+share/doc/qt2/html/qxmldeclhandler-members.html
+share/doc/qt2/html/qxmldeclhandler.html
+share/doc/qt2/html/qxmldefaulthandler-members.html
+share/doc/qt2/html/qxmldefaulthandler.html
+share/doc/qt2/html/qxmldtdhandler-members.html
+share/doc/qt2/html/qxmldtdhandler.html
+share/doc/qt2/html/qxmlentityresolver-members.html
+share/doc/qt2/html/qxmlentityresolver.html
+share/doc/qt2/html/qxmlerrorhandler-members.html
+share/doc/qt2/html/qxmlerrorhandler.html
+share/doc/qt2/html/qxmlinputsource-members.html
+share/doc/qt2/html/qxmlinputsource.html
+share/doc/qt2/html/qxmllexicalhandler-members.html
+share/doc/qt2/html/qxmllexicalhandler.html
+share/doc/qt2/html/qxmllocator-members.html
+share/doc/qt2/html/qxmllocator.html
+share/doc/qt2/html/qxmlnamespacesupport-members.html
+share/doc/qt2/html/qxmlnamespacesupport.html
+share/doc/qt2/html/qxmlparseexception-members.html
+share/doc/qt2/html/qxmlparseexception.html
+share/doc/qt2/html/qxmlreader-members.html
+share/doc/qt2/html/qxmlreader.html
+share/doc/qt2/html/qxmlsimplereader-members.html
+share/doc/qt2/html/qxmlsimplereader.html
share/doc/qt2/html/qxt-h.html
share/doc/qt2/html/qxtapplication-members.html
share/doc/qt2/html/qxtapplication.html
@@ -1260,6 +1527,7 @@ share/doc/qt2/html/rintersect.png
share/doc/qt2/html/rot13-rot13-cpp.html
share/doc/qt2/html/rsubtract.png
share/doc/qt2/html/runion.png
+share/doc/qt2/html/running-qws.html
share/doc/qt2/html/rxor.png
share/doc/qt2/html/scribble-main-cpp.html
share/doc/qt2/html/scrollview-scrollview-cpp.html
@@ -1355,14 +1623,13 @@ share/doc/qt2/html/t9.png
share/doc/qt2/html/t9_1.png
share/doc/qt2/html/t9_2.png
share/doc/qt2/html/tabdialog-main-cpp.html
-share/doc/qt2/html/table-main-cpp.html
+share/doc/qt2/html/table.html
share/doc/qt2/html/test.png
share/doc/qt2/html/tetrix-tetrix-cpp.html
share/doc/qt2/html/themes-main-cpp.html
share/doc/qt2/html/tictac-main-cpp.html
share/doc/qt2/html/time.html
share/doc/qt2/html/timers.html
-share/doc/qt2/html/titleindex
share/doc/qt2/html/tools.html
share/doc/qt2/html/tooltip-main-cpp.html
share/doc/qt2/html/topicals.html
@@ -1375,13 +1642,16 @@ share/doc/qt2/html/tutorial.png
share/doc/qt2/html/unicode.html
share/doc/qt2/html/unsmooth.png
share/doc/qt2/html/validator-main-cpp.html
-share/doc/qt2/html/whatsthis
share/doc/qt2/html/whatsthis.png
share/doc/qt2/html/winsystem.html
share/doc/qt2/html/wizard-main-cpp.html
+share/doc/qt2/html/workspace.html
share/doc/qt2/html/xform-xform-cpp.html
share/doc/qt2/html/xt.html
share/doc/qt2/html/y2k.html
+@dirrm share/doc/qt2/html/designer/stylesheet-images
+@dirrm share/doc/qt2/html/designer/figures
+@dirrm share/doc/qt2/html/designer
@dirrm share/doc/qt2/html
@dirrm share/doc/qt2
@dirrm include/qt2