aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt32/Makefile
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2000-12-26 12:07:50 +0800
committerwill <will@FreeBSD.org>2000-12-26 12:07:50 +0800
commited7bf015846657973a0b8250a5ac8b760109a922 (patch)
tree57ba36e635bb2ffd09bf1e592a36295936ecb789 /x11-toolkits/qt32/Makefile
parentf4e70d7600c0ab705310358999a1abbc42217740 (diff)
downloadfreebsd-ports-gnome-ed7bf015846657973a0b8250a5ac8b760109a922.tar.gz
freebsd-ports-gnome-ed7bf015846657973a0b8250a5ac8b760109a922.tar.zst
freebsd-ports-gnome-ed7bf015846657973a0b8250a5ac8b760109a922.zip
Fix build for XFree86 4.0.2 users: use threads by default in QT even though
it doesn't really work (or so I've been told). This does not affect the build for non-XFree86-4.0.2 users. Apologies for not getting this in sooner. Thanks to: Andrew <elitetek@flashcom.net> for loaning me access to a fast machine with XFree86 4.0.2 to do my testing on, as well as being the first one to contact me about this.
Diffstat (limited to 'x11-toolkits/qt32/Makefile')
-rw-r--r--x11-toolkits/qt32/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/qt32/Makefile b/x11-toolkits/qt32/Makefile
index ecad37d0a72c..e7fc891de579 100644
--- a/x11-toolkits/qt32/Makefile
+++ b/x11-toolkits/qt32/Makefile
@@ -34,7 +34,7 @@ USE_X_PREFIX= yes
USE_NEWGCC= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -system-zlib -system-libpng -system-jpeg -sm -gif \
- -system-libmng \
+ -system-libmng -thread \
-I${LOCALBASE}/include -L${LOCALBASE}/lib
CONFIGURE_ENV= ${YES} yes | QTDIR=${WRKSRC}
MAKE_ARGS+= MAKE="${GMAKE} -j2"
@@ -72,7 +72,7 @@ pre-configure:
-e "s,-pipe -O2,${CXXFLAGS},g" ${CONFIG}.new > ${CONFIG}
.if exists(${X11BASE}/lib/libXft.so) && !defined(NO_AA)
@${CP} ${CONFIG} ${CONFIG}.new
- ${SED} -e "s,= -lXext,= -lXft -lXext,g" -e "s,= -I${X11BASE}/include,= -DQT_XFT -I${X11BASE}/include,g" \
+ ${SED} -e "s,= -lXext,= -lXft -lXext,g" -e "s,QT= -I,QT= -DQT_XFT -I,g" \
${CONFIG}.new > ${CONFIG}
.endif
${CP} ${WRKSRC}/src/Makefile.in ${WRKSRC}/src/Makefile.in.new