aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt5-gui
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-03-18 17:37:42 +0800
committerrakuco <rakuco@FreeBSD.org>2015-03-18 17:37:42 +0800
commit3fc71f43a05b28a5b28e2ee1a0b522650ce30d17 (patch)
treec0c66b80a92a56c0bc2bea93add708c3873588aa /x11-toolkits/qt5-gui
parent322e1023078d50be84f3efbc8cc4b89a78022592 (diff)
downloadfreebsd-ports-gnome-3fc71f43a05b28a5b28e2ee1a0b522650ce30d17.tar.gz
freebsd-ports-gnome-3fc71f43a05b28a5b28e2ee1a0b522650ce30d17.tar.zst
freebsd-ports-gnome-3fc71f43a05b28a5b28e2ee1a0b522650ce30d17.zip
Update Qt5 to 5.4.1.
This is probably the first time our Qt 5 ports are tracking the latest upstream release :-) There isn't much to report in this update, thanks to the effort spent in the 5.2->5.3 update: a lot of the work is just small plist and patch updates. Thankfully, several patches have been upstreamed and are not needed on our side anymore. I would like to thank Alex Richardson <arichardson.kde@gmail.com> and Tobias Berner <tcberner@gmail.com> for their help with the plist updates and general testing. PR: 198585
Diffstat (limited to 'x11-toolkits/qt5-gui')
-rw-r--r--x11-toolkits/qt5-gui/Makefile5
-rw-r--r--x11-toolkits/qt5-gui/pkg-plist18
2 files changed, 19 insertions, 4 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index 61b0f87973d3..67ee719685fd 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,7 +2,6 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 2
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
@@ -12,6 +11,7 @@ COMMENT= Qt graphical user interface module
LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpng.so:${PORTSDIR}/graphics/png \
libxcb.so:${PORTSDIR}/x11/libxcb \
@@ -29,7 +29,8 @@ QT_DIST= base
USE_XORG= x11 xi xrender
HAS_CONFIGURE= yes
CONFIGURE_ARGS= -no-eglfs \
- -no-evdev
+ -no-evdev \
+ -system-harfbuzz
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
BUILD_WRKSRC= ${WRKSRC}/src/${PORTNAME}
diff --git a/x11-toolkits/qt5-gui/pkg-plist b/x11-toolkits/qt5-gui/pkg-plist
index 78e79e2471e5..26c257fb9e44 100644
--- a/x11-toolkits/qt5-gui/pkg-plist
+++ b/x11-toolkits/qt5-gui/pkg-plist
@@ -25,7 +25,7 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfont_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_ft_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_qpa_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengine_qpf2_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontengineglyphcache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfontsubset_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qfragmentmap_p.h
@@ -58,6 +58,7 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglextensions_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglframebufferobject_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglgradientcache_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglpaintdevice_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglpaintengine_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglqueryhelper_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglshadercache_meego_p.h
@@ -68,9 +69,11 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltextureglyphcache_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopengltexturehelper_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglversionfunctionsfactory_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qopenglvertexarrayobject_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qoutlinemapper_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qpagedpaintdevice_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qpaintbuffer_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qpaintdevicewindow_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qpaintengine_blitter_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qpaintengine_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qpaintengine_pic_p.h
@@ -145,7 +148,6 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformpixmap.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformscreen.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformscreen_p.h
-%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformscreenpageflipper.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformservices.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformsessionmanager.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/qpa/qplatformsharedgraphicscache.h
@@ -300,10 +302,12 @@
%%QT_INCDIR%%/QtGui/QOpenGLVersionFunctions
%%QT_INCDIR%%/QtGui/QOpenGLVersionProfile
%%QT_INCDIR%%/QtGui/QOpenGLVertexArrayObject
+%%QT_INCDIR%%/QtGui/QOpenGLWindow
%%QT_INCDIR%%/QtGui/QPageLayout
%%QT_INCDIR%%/QtGui/QPageSize
%%QT_INCDIR%%/QtGui/QPagedPaintDevice
%%QT_INCDIR%%/QtGui/QPaintDevice
+%%QT_INCDIR%%/QtGui/QPaintDeviceWindow
%%QT_INCDIR%%/QtGui/QPaintEngine
%%QT_INCDIR%%/QtGui/QPaintEngineState
%%QT_INCDIR%%/QtGui/QPaintEvent
@@ -316,12 +320,14 @@
%%QT_INCDIR%%/QtGui/QPicture
%%QT_INCDIR%%/QtGui/QPictureFormatPlugin
%%QT_INCDIR%%/QtGui/QPictureIO
+%%QT_INCDIR%%/QtGui/QPixelFormat
%%QT_INCDIR%%/QtGui/QPixmap
%%QT_INCDIR%%/QtGui/QPixmapCache
%%QT_INCDIR%%/QtGui/QPolygon
%%QT_INCDIR%%/QtGui/QPolygonF
%%QT_INCDIR%%/QtGui/QQuaternion
%%QT_INCDIR%%/QtGui/QRadialGradient
+%%QT_INCDIR%%/QtGui/QRasterWindow
%%QT_INCDIR%%/QtGui/QRawFont
%%QT_INCDIR%%/QtGui/QRegExpValidator
%%QT_INCDIR%%/QtGui/QRegion
@@ -467,10 +473,12 @@
%%QT_INCDIR%%/QtGui/qopengltimerquery.h
%%QT_INCDIR%%/QtGui/qopenglversionfunctions.h
%%QT_INCDIR%%/QtGui/qopenglvertexarrayobject.h
+%%QT_INCDIR%%/QtGui/qopenglwindow.h
%%QT_INCDIR%%/QtGui/qpagedpaintdevice.h
%%QT_INCDIR%%/QtGui/qpagelayout.h
%%QT_INCDIR%%/QtGui/qpagesize.h
%%QT_INCDIR%%/QtGui/qpaintdevice.h
+%%QT_INCDIR%%/QtGui/qpaintdevicewindow.h
%%QT_INCDIR%%/QtGui/qpaintengine.h
%%QT_INCDIR%%/QtGui/qpainter.h
%%QT_INCDIR%%/QtGui/qpainterpath.h
@@ -479,10 +487,12 @@
%%QT_INCDIR%%/QtGui/qpen.h
%%QT_INCDIR%%/QtGui/qpicture.h
%%QT_INCDIR%%/QtGui/qpictureformatplugin.h
+%%QT_INCDIR%%/QtGui/qpixelformat.h
%%QT_INCDIR%%/QtGui/qpixmap.h
%%QT_INCDIR%%/QtGui/qpixmapcache.h
%%QT_INCDIR%%/QtGui/qpolygon.h
%%QT_INCDIR%%/QtGui/qquaternion.h
+%%QT_INCDIR%%/QtGui/qrasterwindow.h
%%QT_INCDIR%%/QtGui/qrawfont.h
%%QT_INCDIR%%/QtGui/qregion.h
%%QT_INCDIR%%/QtGui/qrgb.h
@@ -521,10 +531,14 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/cglconvenience_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/constant_mappings_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/dbusconnection_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qaccessiblebridgeutils_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qbasicfontdatabase_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qcfsocketnotifier_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qcoretextfontdatabase_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_dummy_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_static_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdevicediscovery_udev_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglcompositor_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglconvenience_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglpbuffer_p.h