aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qt5-gui
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-09-17 17:46:54 +0800
committerrakuco <rakuco@FreeBSD.org>2016-09-17 17:46:54 +0800
commit7fdf0da385d7c6b2b7639653af91bc8fc409f713 (patch)
treeff6682b425056cf66ba4ca415211efb1b19cc258 /x11-toolkits/qt5-gui
parentdf8c76029e3c07b11560a8a3593db5b589718863 (diff)
downloadfreebsd-ports-gnome-7fdf0da385d7c6b2b7639653af91bc8fc409f713.tar.gz
freebsd-ports-gnome-7fdf0da385d7c6b2b7639653af91bc8fc409f713.tar.zst
freebsd-ports-gnome-7fdf0da385d7c6b2b7639653af91bc8fc409f713.zip
Update the Qt5 ports to 5.6.1.
This took longer than expected, but there are quite a few changes to the existing ports and a few new ones. General upstream changes: - Starting with Qt 5.6.2, Qt will fail at configuration time if LibreSSL is being used. According to the discussion here: https://codereview.qt-project.org/#/c/154800/ The Qt project is not opposed to LibreSSL, but does not want to mix support for it into the OpenSSL backend code, especially as they move towards supporting OpenSSL 1.1. People interested in LibreSSL support are welcome to submit a separate backend upstream, but are expected to maintain it. We (kde@) are not opposed to carrying some patches authored by others in the future, as long as they are not huge and destabilizing. - When Qt detects the compiler supports C++11, it will pass -std=gnu++11 by default (this is an upstream change). You can add "CONFIG -= c++11" to your .pro. Qt 5.7 will require C++11. - www/webkit-qt5: The QtWebKit module is deprecated upstream, and is shipped separately as a community release tarball. kde@ does not have an ETA for a qt5-webengine port, as it requires a huge effort (and number of patches) similar to maintaining www/chromium itself. - x11-toolkits/qt5-declarative has been deprecated upstream. The last release is 5.5.1. Relevant changes: - devel/qmake5: The freebsd-clang mkspec has become the default mkspec on FreeBSD, replacing the outdated freebsd-g++ one that was moved to unsupported/ (it still works though). - devel/qt5-qdoc: qdoc was moved to qttools upstream, but its data files are still in qtbase. The data files are now in the qt5-qdoc-data port. - misc/qt5-doc: Clean up and stop requiring a compiler and fumbling with mkspecs. Instead of running the `configure' script, which requires a compiler and adjustments to the mkspecs files and also ends up building a new qmake binary, we now leverage USES=qmake to generate all the Makefiles from the top-level qt.pro. Getting this to work requires some tricks, though, and qt.conf.in has a longer explanation of what's being done. Switch to USES=gmake to be able to drop MAKE_JOBS_UNSAFE=yes. New ports: - comms/qt5-serialbus - devel/qt5-qdoc-data - x11-toolkits/qt5-quickcontrols2 Big thanks to Adriaan de Groot (groot@kde.org), tcberner@ and Loise Nolden (nolden@kde.org) for the huge amount of work they put into this patch. Loise in particular also sent quite a few changes upstream that were essential for this update to work. PR: 211916
Diffstat (limited to 'x11-toolkits/qt5-gui')
-rw-r--r--x11-toolkits/qt5-gui/Makefile18
-rw-r--r--x11-toolkits/qt5-gui/pkg-plist25
2 files changed, 32 insertions, 11 deletions
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index be27ff85b2c1..112100ece8c3 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -2,7 +2,6 @@
PORTNAME= gui
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
CATEGORIES= x11-toolkits graphics
PKGNAMEPREFIX= qt5-
@@ -22,7 +21,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libxkbcommon.so:x11/libxkbcommon
RUN_DEPENDS= xdg-open:devel/xdg-utils
-USES= jpeg
+USES= compiler:features jpeg
USE_GL= gl egl
USE_GNOME= glib20
USE_QT5= core dbus network qmake_build buildtools_build
@@ -70,6 +69,19 @@ RUN_DEPENDS+= ${LOCALBASE}/share/fonts/encodings/encodings.dir:x11-fonts/encodin
CFLAGS_powerpc64= -mminimal-toc
+.include <bsd.port.pre.mk>
+
+# Base GCC fails to build qdrawhelper.cpp:
+# painting/qdrawhelper.cpp: In function 'void qConvertARGB64PMToA2RGB30PM_sse2(uint*, const QRgba64*, int)':
+# painting/qdrawhelper.cpp:1276: note: use -flax-vector-conversions to permit conversions between vectors with differing element types or numbers of subparts
+# painting/qdrawhelper.cpp:1276: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
+# painting/qdrawhelper.cpp:1277: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
+# painting/qdrawhelper.cpp:1278: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
+# painting/qdrawhelper.cpp:1282: error: cannot convert 'int __vector__' to 'long long int __vector__' for argument '1' to 'long long int __vector__ __builtin_ia32_psrlqi128(long long int __vector__, int)'
+.if ${COMPILER_TYPE} == gcc && ${COMPILER_VERSION} <= 42
+CXXFLAGS+= -flax-vector-conversions
+.endif
+
post-build:
.for d in ${MORE_WRKSRCS}
@cd ${WRKSRC}/${d} && \
@@ -84,4 +96,4 @@ post-install:
${MAKE_ARGS} ${INSTALL_TARGET}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt5-gui/pkg-plist b/x11-toolkits/qt5-gui/pkg-plist
index af4311541175..4f20f2a8425b 100644
--- a/x11-toolkits/qt5-gui/pkg-plist
+++ b/x11-toolkits/qt5-gui/pkg-plist
@@ -35,6 +35,7 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qguiapplication_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qharfbuzzng_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qhexstring_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qhighdpiscaling_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qicon_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qiconloader_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qimage_p.h
@@ -96,6 +97,7 @@
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qrasterizer_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qrawfont_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qrbtree_p.h
+%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qrgba64_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qscreen_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qsessionmanager_p.h
%%QT_INCDIR%%/QtGui/%%FULLVER%%/QtGui/private/qshapedpixmapdndwindow_p.h
@@ -267,6 +269,8 @@
%%QT_INCDIR%%/QtGui/QOpenGLContextGroup
%%QT_INCDIR%%/QtGui/QOpenGLDebugLogger
%%QT_INCDIR%%/QtGui/QOpenGLDebugMessage
+%%QT_INCDIR%%/QtGui/QOpenGLExtraFunctions
+%%QT_INCDIR%%/QtGui/QOpenGLExtraFunctionsPrivate
%%QT_INCDIR%%/QtGui/QOpenGLFramebufferObject
%%QT_INCDIR%%/QtGui/QOpenGLFramebufferObjectFormat
%%QT_INCDIR%%/QtGui/QOpenGLFunctions
@@ -341,6 +345,7 @@
%%QT_INCDIR%%/QtGui/QRegularExpressionValidator
%%QT_INCDIR%%/QtGui/QResizeEvent
%%QT_INCDIR%%/QtGui/QRgb
+%%QT_INCDIR%%/QtGui/QRgba64
%%QT_INCDIR%%/QtGui/QScreen
%%QT_INCDIR%%/QtGui/QScreenOrientationChangeEvent
%%QT_INCDIR%%/QtGui/QScrollEvent
@@ -448,6 +453,7 @@
%%QT_INCDIR%%/QtGui/qopengldebug.h
%%QT_INCDIR%%/QtGui/qopengles2ext.h
%%QT_INCDIR%%/QtGui/qopenglext.h
+%%QT_INCDIR%%/QtGui/qopenglextrafunctions.h
%%QT_INCDIR%%/QtGui/qopenglframebufferobject.h
%%QT_INCDIR%%/QtGui/qopenglfunctions.h
%%QT_INCDIR%%/QtGui/qopenglfunctions_1_0.h
@@ -507,6 +513,7 @@
%%QT_INCDIR%%/QtGui/qrawfont.h
%%QT_INCDIR%%/QtGui/qregion.h
%%QT_INCDIR%%/QtGui/qrgb.h
+%%QT_INCDIR%%/QtGui/qrgba64.h
%%QT_INCDIR%%/QtGui/qscreen.h
%%QT_INCDIR%%/QtGui/qsessionmanager.h
%%QT_INCDIR%%/QtGui/qstandarditemmodel.h
@@ -542,22 +549,30 @@
%%QT_INCDIR%%/QtOpenGLExtensions/qopenglextensions.h
%%QT_INCDIR%%/QtOpenGLExtensions/qtopenglextensionsversion.h
%%QT_INCDIR%%/QtPlatformHeaders/QCocoaNativeContext
+%%QT_INCDIR%%/QtPlatformHeaders/QCocoaWindowFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QEGLNativeContext
%%QT_INCDIR%%/QtPlatformHeaders/QEglFSFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QGLXNativeContext
+%%QT_INCDIR%%/QtPlatformHeaders/QPlatformHeaderHelper
%%QT_INCDIR%%/QtPlatformHeaders/QWGLNativeContext
%%QT_INCDIR%%/QtPlatformHeaders/QWindowsWindowFunctions
+%%QT_INCDIR%%/QtPlatformHeaders/QXcbIntegrationFunctions
+%%QT_INCDIR%%/QtPlatformHeaders/QXcbScreenFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QXcbWindowFunctions
%%QT_INCDIR%%/QtPlatformHeaders/QtPlatformHeaders
%%QT_INCDIR%%/QtPlatformHeaders/QtPlatformHeadersDepends
%%QT_INCDIR%%/QtPlatformHeaders/QtPlatformHeadersVersion
%%QT_INCDIR%%/QtPlatformHeaders/qcocoanativecontext.h
+%%QT_INCDIR%%/QtPlatformHeaders/qcocoawindowfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qeglfsfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qeglnativecontext.h
%%QT_INCDIR%%/QtPlatformHeaders/qglxnativecontext.h
+%%QT_INCDIR%%/QtPlatformHeaders/qplatformheaderhelper.h
%%QT_INCDIR%%/QtPlatformHeaders/qtplatformheadersversion.h
%%QT_INCDIR%%/QtPlatformHeaders/qwglnativecontext.h
%%QT_INCDIR%%/QtPlatformHeaders/qwindowswindowfunctions.h
+%%QT_INCDIR%%/QtPlatformHeaders/qxcbintegrationfunctions.h
+%%QT_INCDIR%%/QtPlatformHeaders/qxcbscreenfunctions.h
%%QT_INCDIR%%/QtPlatformHeaders/qxcbwindowfunctions.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/application_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/atspiadaptor_p.h
@@ -568,7 +583,6 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/dbusconnection_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qaccessiblebridgeutils_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qbasicfontdatabase_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qcfsocketnotifier_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qcoretextfontdatabase_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuadaptor_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qdbusmenuconnection_p.h
@@ -583,10 +597,7 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglconvenience_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglpbuffer_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglplatformcontext_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglplatformcursor_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglplatformintegration_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglplatformscreen_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglplatformwindow_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeglstreamconvenience_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboard_defaultmap_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboardhandler_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevkeyboardmanager_p.h
@@ -595,7 +606,6 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtablet_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtouchhandler_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qevdevtouchmanager_p.h
-%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeventdispatcher_cf_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qeventdispatcher_glib_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbbackingstore_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qfbcursor_p.h
@@ -620,6 +630,7 @@
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qstatusnotifieritemadaptor_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qtslib_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qunixeventdispatcher_qpa_p.h
+%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qwindowsguieventdispatcher_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qxdgnotificationproxy_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/qxlibeglintegration_p.h
%%QT_INCDIR%%/QtPlatformSupport/%%FULLVER%%/QtPlatformSupport/private/struct_marshallers_p.h
@@ -689,5 +700,3 @@
%%DEBUG%%%%QT_PLUGINDIR%%/xcbglintegrations/libqxcb-glx-integration.so.debug
libdata/pkgconfig/Qt5Gui.pc
libdata/pkgconfig/Qt5OpenGLExtensions.pc
-libdata/pkgconfig/Qt5PlatformSupport.pc
-libdata/pkgconfig/Qt5XcbQpa.pc