aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/qwt6-designerplugin
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-07-24 23:59:51 +0800
committermakc <makc@FreeBSD.org>2010-07-24 23:59:51 +0800
commit62f3dbb28da689b18b79759afcc8fb05aa83a8f5 (patch)
treeb39c9a9f1e79d542ebbe032df0792084e25195a8 /x11-toolkits/qwt6-designerplugin
parent0f895d56962d1552037843cd90a2e42fc8bef74b (diff)
downloadfreebsd-ports-gnome-62f3dbb28da689b18b79759afcc8fb05aa83a8f5.tar.gz
freebsd-ports-gnome-62f3dbb28da689b18b79759afcc8fb05aa83a8f5.tar.zst
freebsd-ports-gnome-62f3dbb28da689b18b79759afcc8fb05aa83a8f5.zip
Split qwt5 port into designer plugin and qwt library.
Designer plugin is not needed for regular users, while it pulls relatively heavy qt4 components.
Diffstat (limited to 'x11-toolkits/qwt6-designerplugin')
-rw-r--r--x11-toolkits/qwt6-designerplugin/Makefile40
-rw-r--r--x11-toolkits/qwt6-designerplugin/distinfo3
-rw-r--r--x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro11
-rw-r--r--x11-toolkits/qwt6-designerplugin/pkg-descr9
-rw-r--r--x11-toolkits/qwt6-designerplugin/pkg-plist3
5 files changed, 66 insertions, 0 deletions
diff --git a/x11-toolkits/qwt6-designerplugin/Makefile b/x11-toolkits/qwt6-designerplugin/Makefile
new file mode 100644
index 000000000000..3a6e11e33500
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: qwt5-designerplugin
+# Date created: 2010-07-02
+# Whom: Max Brazhnikov <makc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= qwt
+PORTVERSION= 5.2.1
+CATEGORIES= x11-toolkits
+MASTER_SITES= SF
+PKGNAMESUFFIX= -designerplugin
+
+MAINTAINER= makc@FreeBSD.org
+COMMENT= Qt Designer plugin for Qwt
+
+LIB_DEPENDS= qwt.5:${PORTSDIR}/x11-toolkits/qwt5
+
+USE_QT_VER= 4
+QT_COMPONENTS= designer moc_build qmake_build rcc_build
+USE_BZIP2= yes
+USE_GMAKE= yes
+QMAKE_ARGS+= -unix -recursive CONFIG+=QwtDesigner \
+ PLUGINDIR=${PREFIX}/${QT_PLUGINDIR_REL}
+HAS_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+STRIP_FILES= ${QT_PLUGINDIR_REL}/designer/libqwt_designer_plugin.so
+
+CONFIGURE_WRKSRC= ${WRKSRC}/designer
+BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+
+do-configure:
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS} ${QMAKE_ARGS})
+
+post-install:
+ ${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qwt6-designerplugin/distinfo b/x11-toolkits/qwt6-designerplugin/distinfo
new file mode 100644
index 000000000000..9000501966ef
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/distinfo
@@ -0,0 +1,3 @@
+MD5 (qwt-5.2.1.tar.bz2) = 4a595b8db0ec3856b117836c1d60cb27
+SHA256 (qwt-5.2.1.tar.bz2) = e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f
+SIZE (qwt-5.2.1.tar.bz2) = 1926453
diff --git a/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro b/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
new file mode 100644
index 000000000000..030bd15ede67
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/files/patch-designer__designer.pro
@@ -0,0 +1,11 @@
+--- ./designer/designer.pro.orig 2008-05-01 17:43:56.000000000 +0400
++++ ./designer/designer.pro 2008-05-03 02:21:17.000000000 +0400
+@@ -123,7 +123,7 @@
+ RESOURCES += \
+ qwt_designer_plugin.qrc
+
+- target.path = $$[QT_INSTALL_PLUGINS]/designer
++ target.path = $$PLUGINDIR/designer
+ INSTALLS += target
+ }
+ }
diff --git a/x11-toolkits/qwt6-designerplugin/pkg-descr b/x11-toolkits/qwt6-designerplugin/pkg-descr
new file mode 100644
index 000000000000..78ec23cc8883
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/pkg-descr
@@ -0,0 +1,9 @@
+The Qwt library contains GUI Components and utility classes which
+are primarily useful for programs with a technical background.
+Beside a 2D plot widget it provides scales, sliders, dials, compasses,
+thermometers, wheels and knobs to control or display values, arrays,
+or ranges of type double.
+
+This port installs Qt Designer plugin for Qwt library version 5.
+
+WWW: http://qwt.sourceforge.net
diff --git a/x11-toolkits/qwt6-designerplugin/pkg-plist b/x11-toolkits/qwt6-designerplugin/pkg-plist
new file mode 100644
index 000000000000..14e3c7ba01c2
--- /dev/null
+++ b/x11-toolkits/qwt6-designerplugin/pkg-plist
@@ -0,0 +1,3 @@
+%%QT_PLUGINDIR_REL%%/designer/libqwt_designer_plugin.so
+@dirrmtry %%QT_PLUGINDIR_REL%%/designer
+@dirrmtry %%QT_PLUGINDIR_REL%%