aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/ruby-fox10/Makefile
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-07-30 00:37:10 +0800
committerknu <knu@FreeBSD.org>2001-07-30 00:37:10 +0800
commitc8eff8f6332bafd27ea18b5eb075f00cfd4669a8 (patch)
treeb12eef2d3f14c86d6a16505a27d5f963ee62c957 /x11-toolkits/ruby-fox10/Makefile
parent5135f3729d59e9c1ce4a2ca0c06c784a76ba3405 (diff)
downloadfreebsd-ports-gnome-c8eff8f6332bafd27ea18b5eb075f00cfd4669a8.tar.gz
freebsd-ports-gnome-c8eff8f6332bafd27ea18b5eb075f00cfd4669a8.tar.zst
freebsd-ports-gnome-c8eff8f6332bafd27ea18b5eb075f00cfd4669a8.zip
Update to 0.99.173 and mark as broken, since x11-toolkits/fox is
already updated to version 0.99.174 and FXRuby is therefore out of sync with it. So install FOX 0.99.173 by hand, or wait until FXRuby 0.99.174 is released.
Diffstat (limited to 'x11-toolkits/ruby-fox10/Makefile')
-rw-r--r--x11-toolkits/ruby-fox10/Makefile32
1 files changed, 14 insertions, 18 deletions
diff --git a/x11-toolkits/ruby-fox10/Makefile b/x11-toolkits/ruby-fox10/Makefile
index ebcca34b855f..63e08ec47ab3 100644
--- a/x11-toolkits/ruby-fox10/Makefile
+++ b/x11-toolkits/ruby-fox10/Makefile
@@ -21,7 +21,9 @@ LIB_DEPENDS= FOX.1:${PORTSDIR}/x11-toolkits/fox \
png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
-FOX_VERSION= 0.99.172
+BROKEN= "Out of sync with FOX"
+
+FOX_VERSION= 0.99.173
#FXRUBY_REVISION=
.if defined(FXRUBY_REVISION) && !empty(FXRUBY_REVISION)
FXRUBY_PORTVERSION= ${FOX_VERSION}.${FXRUBY_REVISION}
@@ -32,33 +34,27 @@ FXRUBY_DISTNAME= FXRuby-${FOX_VERSION}
.endif
USE_RUBY= yes
-USE_RUBY_EXTCONF= yes
+USE_RUBY_SETUP= yes
USE_XLIB= yes
USE_MESA= yes
-WRKSRC= ${WRKDIR}/${DISTNAME}/src
-INSTALL_TARGET= site-install
-CONFIGURE_ARGS= --with-fox-include="${LOCALBASE}/include/fox" \
- --with-fox-lib="${LOCALBASE}/lib"
-#MAKE_ARGS= LOCAL_LIBS="-lgcc"
-
-DOCS_EN= README index.html
+DOCS_EN= ANNOUNCE ChangeLog README \
+ index.html doc
post-patch:
- ${RUBY} -i -pe 'sub %r:/usr/X11R6\b:, "${X11BASE}"' ${WRKSRC}/extconf.rb
-
-pre-build:
-# cd ${WRKSRC}/../swig-interfaces; ${MAKE}
- ${RUBY} -i -pe 'sub %r:^CXXFLAGS *=.*:, "CXXFLAGS = $$(CFLAGS) $$(CPPFLAGS)"' ${WRKSRC}/Makefile
+ ${RUBY} -i -p \
+ -e 'gsub %r:/usr/local\b:, "${LOCALBASE}"' \
+ -e 'gsub %r:/usr/X11R6\b:, "${X11BASE}"' \
+ ${WRKSRC}/ext/fox/extconf.rb
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_EXAMPLESDIR}/fox
- ${CP} -R ${WRKSRC}/../examples/* ${RUBY_EXAMPLESDIR}/fox/
- ${MKDIR} ${RUBY_DOCDIR}/fox
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/examples/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/../${f} ${RUBY_DOCDIR}/fox/
+ ${CP} -R ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
.endfor
.endif