aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/ruby-wx
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2005-05-30 22:58:42 +0800
committerfjoe <fjoe@FreeBSD.org>2005-05-30 22:58:42 +0800
commitfe7c3763a8b7ed577796ebb2ad9ecd3867e74384 (patch)
tree20076a3e34716ea05d56d3bf51e86cc872574bd0 /x11-toolkits/ruby-wx
parentd549fcfbd4a7d53445e02c3d080ad48144159294 (diff)
downloadfreebsd-ports-gnome-fe7c3763a8b7ed577796ebb2ad9ecd3867e74384.tar.gz
freebsd-ports-gnome-fe7c3763a8b7ed577796ebb2ad9ecd3867e74384.tar.zst
freebsd-ports-gnome-fe7c3763a8b7ed577796ebb2ad9ecd3867e74384.zip
- Fix the build: Use wxgtk2-2.4-config instead of wx-config.
- Bump PORTREVISION.
Diffstat (limited to 'x11-toolkits/ruby-wx')
-rw-r--r--x11-toolkits/ruby-wx/Makefile2
-rw-r--r--x11-toolkits/ruby-wx/files/patch-extconf.rb16
2 files changed, 11 insertions, 7 deletions
diff --git a/x11-toolkits/ruby-wx/Makefile b/x11-toolkits/ruby-wx/Makefile
index ea19dbb3c26f..dddedf65035e 100644
--- a/x11-toolkits/ruby-wx/Makefile
+++ b/x11-toolkits/ruby-wx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wx
PORTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-toolkits ruby
MASTER_SITES= http://rubyforge.org/frs/download.php/1983/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
diff --git a/x11-toolkits/ruby-wx/files/patch-extconf.rb b/x11-toolkits/ruby-wx/files/patch-extconf.rb
index b018405af9f1..8efacb0c6bd1 100644
--- a/x11-toolkits/ruby-wx/files/patch-extconf.rb
+++ b/x11-toolkits/ruby-wx/files/patch-extconf.rb
@@ -1,15 +1,19 @@
---- extconf.rb.orig Wed Nov 17 15:56:22 2004
-+++ extconf.rb Fri Feb 11 00:42:43 2005
+--- extconf.rb.orig Wed Nov 17 20:56:22 2004
++++ extconf.rb Mon May 30 21:50:18 2005
@@ -32,13 +32,16 @@
end
-if /linux/ =~ RUBY_PLATFORM or /i386-freebsd/ =~ RUBY_PLATFORM
+- CONFIG['CC'] = `wx-config --cxx`
+- CONFIG['LDSHARED'].gsub!("gcc",`wx-config --cxx`.strip)
+- $CFLAGS += " `wx-config --cxxflags`"
+- $LDFLAGS += " `wx-config --libs` -Wl,--version-script,./version-script "
+if /linux/ =~ RUBY_PLATFORM or /freebsd/ =~ RUBY_PLATFORM
- CONFIG['CC'] = `wx-config --cxx`
- CONFIG['LDSHARED'].gsub!("gcc",`wx-config --cxx`.strip)
- $CFLAGS += " `wx-config --cxxflags`"
- $LDFLAGS += " `wx-config --libs` -Wl,--version-script,./version-script "
++ CONFIG['CC'] = `wxgtk2-2.4-config --cxx`
++ CONFIG['LDSHARED'].gsub!("gcc",`wxgtk2-2.4-config --cxx`.strip)
++ $CFLAGS += " `wxgtk2-2.4-config --cxxflags`"
++ $LDFLAGS += " `wxgtk2-2.4-config --libs` -Wl,--version-script,./version-script "
["htmlprocessor.o", "htmlwindow.o", "htmleasyprinting.o"].each do |str|
$objs.delete(str)
+ end