aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/scintilla
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2005-02-04 04:05:48 +0800
committerkwm <kwm@FreeBSD.org>2005-02-04 04:05:48 +0800
commitd12cb299fab32d605ed84277b1b5e93db8607103 (patch)
treed41ffd07b3dd11aaa063e9c28756563e5f689588 /x11-toolkits/scintilla
parent785aef39be9f2780a2cd92f234b92789160cd482 (diff)
downloadfreebsd-ports-gnome-d12cb299fab32d605ed84277b1b5e93db8607103.tar.gz
freebsd-ports-gnome-d12cb299fab32d605ed84277b1b5e93db8607103.tar.zst
freebsd-ports-gnome-d12cb299fab32d605ed84277b1b5e93db8607103.zip
Update to 0.62, based on [1].
Fix build on sparc64 by not adding -fpic to CFLAGS. PR: 68879 Submitted by: Piotr Smyrak
Diffstat (limited to 'x11-toolkits/scintilla')
-rw-r--r--x11-toolkits/scintilla/Makefile8
-rw-r--r--x11-toolkits/scintilla/distinfo4
-rw-r--r--x11-toolkits/scintilla/files/patch-aa31
3 files changed, 24 insertions, 19 deletions
diff --git a/x11-toolkits/scintilla/Makefile b/x11-toolkits/scintilla/Makefile
index 67c7efffb494..bc78517681a7 100644
--- a/x11-toolkits/scintilla/Makefile
+++ b/x11-toolkits/scintilla/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= scintilla
-PORTVERSION= 1.59
+PORTVERSION= 1.62
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.scintilla.org/
@@ -29,13 +29,15 @@ USE_GNOME= gtk20
PKGNAMESUFFIX= -gtk2
.else
USE_GNOME= gtk12
-MAKE_ARGS= GTK1=yes
+MAKE_ARGS+= GTK1=yes
.endif
.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
-BROKEN= "Build fails on sparc64"
+MAKE_ARGS+= PICFLAGS=-DPIC
+.else
+MAKE_ARGS+= PICFLAGS="-DPIC -fpic"
.endif
do-install:
diff --git a/x11-toolkits/scintilla/distinfo b/x11-toolkits/scintilla/distinfo
index 28cfda804e45..f11e2b7d7d3d 100644
--- a/x11-toolkits/scintilla/distinfo
+++ b/x11-toolkits/scintilla/distinfo
@@ -1,2 +1,2 @@
-MD5 (scite159.tgz) = 91e33588270ee9b3f5d629f085a4a200
-SIZE (scite159.tgz) = 922148
+MD5 (scite162.tgz) = 4d34c8b669f0a8e0ae862a8e56fd8d01
+SIZE (scite162.tgz) = 1140114
diff --git a/x11-toolkits/scintilla/files/patch-aa b/x11-toolkits/scintilla/files/patch-aa
index 9daa0643d016..0b7f4d4f9ed0 100644
--- a/x11-toolkits/scintilla/files/patch-aa
+++ b/x11-toolkits/scintilla/files/patch-aa
@@ -1,12 +1,13 @@
---- makefile.orig Wed Dec 24 08:45:12 2003
-+++ makefile Sun Jan 11 19:50:44 2004
-@@ -8,15 +8,16 @@
+--- makefile.orig Fri Jul 9 02:56:56 2004
++++ makefile Fri Jul 9 03:08:57 2004
+@@ -8,16 +8,17 @@
# To force GTK+ 1 build, define GTK1 on the make command line.
- .SUFFIXES: .cxx .o .h .a
+ .SUFFIXES: .cxx .c .o .h .a
-CC = g++
--AR = ar
+CC ?= g++
+ CCOMP = gcc
+-AR = ar
+AR = $(CC) -shared
RANLIB = touch
@@ -20,7 +21,7 @@
vpath %.h ../src ../include
vpath %.cxx ../src
-@@ -31,29 +32,29 @@
+@@ -32,31 +33,31 @@
endif
ifdef DEBUG
@@ -36,6 +37,7 @@
ifdef GTK2
-CONFIGFLAGS=pkg-config --cflags gtk+-2.0
+CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
+ MARSHALLER=scintilla-marshal.o
else
ifdef GTK1
-CONFIGFLAGS=gtk-config --cflags
@@ -44,6 +46,7 @@
ifneq (,$(findstring /,$(shell whereis pkg-config)))
-CONFIGFLAGS=pkg-config --cflags gtk+-2.0
+CONFIGFLAGS=pkg-config --cflags gtk+-2.0 gthread-2.0
+ MARSHALLER=scintilla-marshal.o
else
-CONFIGFLAGS=gtk-config --cflags
+CONFIGFLAGS=gtk-config --cflags gtk+ gthread
@@ -53,12 +56,12 @@
.cxx.o:
- $(CC) `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
-+ $(CC) -DPIC -fpic `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
++ $(CC) $(PICFLAGS) `$(CONFIGFLAGS)` $(CXXFLAGS) -c $<
+ .c.o:
+ $(CCOMP) `$(CONFIGFLAGS)` $(CXXFLAGS) -w -c $<
- #++Autogenerated -- run src/LexGen.py to regenerate
- #**LEXOBJS=\\\n\(\*.o \)
-@@ -66,7 +67,7 @@
- LexYAML.o
+@@ -72,7 +73,7 @@
+ LexVerilog.o LexYAML.o
#--Autogenerated -- end of automatically generated section
-all: $(COMPLIB)
@@ -66,15 +69,15 @@
clean:
rm -f *.o $(COMPLIB)
-@@ -77,10 +78,11 @@
+@@ -83,10 +84,11 @@
$(COMPLIB): DocumentAccessor.o WindowAccessor.o KeyWords.o StyleContext.o Document.o CallTip.o \
ScintillaBase.o ContractionState.o Editor.o ExternalLexer.o PropSet.o PlatGTK.o \
KeyMap.o LineMarker.o ScintillaGTK.o CellBuffer.o ViewStyle.o \
- RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o \
-- $(LEXOBJS)
+- $(MARSHALLER) $(LEXOBJS)
- $(AR) rc $@ $^
- $(RANLIB) $@
-+ RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o
++ RESearch.o Style.o Indicator.o AutoComplete.o UniConversion.o XPM.o $(MARSHALLER)
+ $(AR) `$(CONFIGFLAGS:cflags=libs)` -o $@ $^
+
+$(LEXRLIB): $(LEXOBJS)