aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/swt
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-03-27 03:37:41 +0800
committermarino <marino@FreeBSD.org>2015-03-27 03:37:41 +0800
commit535df03b1b445cb1b78051502839b10563ffed98 (patch)
treec4cb8b7c393a1cfd63e2701a71d5c4dac95431d0 /x11-toolkits/swt
parent2e564512b0141d744a9529d88a8355ab40721568 (diff)
downloadfreebsd-ports-gnome-535df03b1b445cb1b78051502839b10563ffed98.tar.gz
freebsd-ports-gnome-535df03b1b445cb1b78051502839b10563ffed98.tar.zst
freebsd-ports-gnome-535df03b1b445cb1b78051502839b10563ffed98.zip
x11-toolkits/swt: Add DragonFly support
Bring in fix from dports (port is not maintained)
Diffstat (limited to 'x11-toolkits/swt')
-rw-r--r--x11-toolkits/swt/Makefile4
-rw-r--r--x11-toolkits/swt/files/patch-build.sh22
2 files changed, 20 insertions, 6 deletions
diff --git a/x11-toolkits/swt/Makefile b/x11-toolkits/swt/Makefile
index ec34166faa23..a3665b7f602a 100644
--- a/x11-toolkits/swt/Makefile
+++ b/x11-toolkits/swt/Makefile
@@ -83,6 +83,10 @@ post-extract:
@(cd ${WRKSRC} && ${UNZIP_CMD} -qo "*.zip")
@${RM} -f ${WRKSRC}/*.o ${WRKSRC}/*.so ${WRKSRC}/*.jar
+post-patch:
+ ${SED} -e 's|freebsd|dragonfly|g' ${WRKSRC}/make_freebsd.mak \
+ ${WRKSRC}/make_dragonfly.mak
+
do-install:
@${MKDIR} ${STAGEDIR}${JAVAJARDIR}
${INSTALL_LIB} ${WRKSRC}/libswt-*.so ${STAGEDIR}${PREFIX}/lib
diff --git a/x11-toolkits/swt/files/patch-build.sh b/x11-toolkits/swt/files/patch-build.sh
index e3b5483cb957..6fb1b85aa9ae 100644
--- a/x11-toolkits/swt/files/patch-build.sh
+++ b/x11-toolkits/swt/files/patch-build.sh
@@ -1,6 +1,16 @@
---- build.sh.orig 2009-06-11 16:10:54.000000000 -0500
-+++ build.sh 2009-12-01 14:42:09.000000000 -0600
-@@ -44,6 +44,9 @@
+--- build.sh.orig 2010-02-12 17:49:56 UTC
++++ build.sh
+@@ -41,9 +41,19 @@ case $OS in
+ MAKE_TYPE=gmake
+ fi
+ ;;
++ "DragonFly")
++ SWT_OS=dragonfly
++ MAKEFILE=make_dragonfly.mak
++ if uname -p > /dev/null 2>&1; then
++ MODEL=`uname -p`
++ fi
++ ;;
"FreeBSD")
SWT_OS=freebsd
MAKEFILE=make_freebsd.mak
@@ -10,7 +20,7 @@
;;
*)
SWT_OS=`uname -s | tr -s '[:upper:]' '[:lower:]'`
-@@ -75,15 +78,16 @@
+@@ -75,15 +85,16 @@ case $MODEL in
esac
# For 64-bit CPUs, we have a switch
@@ -29,7 +39,7 @@
if [ x`pkg-config --exists gnome-vfs-module-2.0 libgnome-2.0 libgnomeui-2.0 && echo YES` = "xYES" ]; then
echo "libgnomeui-2.0 found, compiling SWT program support using GNOME"
MAKE_GNOME=make_gnome
-@@ -91,7 +95,9 @@
+@@ -91,7 +102,9 @@ else
echo "libgnome-2.0 and libgnomeui-2.0 not found:"
echo " *** SWT Program support for GNOME will not be compiled."
fi
@@ -39,7 +49,7 @@
if [ x`pkg-config --exists cairo && echo YES` = "xYES" ]; then
echo "Cairo found, compiling SWT support for the cairo graphics library."
MAKE_CAIRO=make_cairo
-@@ -99,30 +105,17 @@
+@@ -99,30 +112,17 @@ else
echo "Cairo not found:"
echo " *** Advanced graphics support using cairo will not be compiled."
fi