aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/tix/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2010-12-07 05:04:57 +0800
committerpav <pav@FreeBSD.org>2010-12-07 05:04:57 +0800
commit575bf139c19504eddfe15f2bb9b2c67fdfd47d36 (patch)
treee4c7b61fe25bc5518826ef974fd1c31a8482f37f /x11-toolkits/tix/Makefile
parent91a81209c63a8319b31606b78623df48ff779894 (diff)
downloadfreebsd-ports-gnome-575bf139c19504eddfe15f2bb9b2c67fdfd47d36.tar.gz
freebsd-ports-gnome-575bf139c19504eddfe15f2bb9b2c67fdfd47d36.tar.zst
freebsd-ports-gnome-575bf139c19504eddfe15f2bb9b2c67fdfd47d36.zip
- Build and install shared library again
Submitted by: thierry (thanks!!)
Diffstat (limited to 'x11-toolkits/tix/Makefile')
-rw-r--r--x11-toolkits/tix/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/x11-toolkits/tix/Makefile b/x11-toolkits/tix/Makefile
index 14151291e1ef..df8ac7e3cefe 100644
--- a/x11-toolkits/tix/Makefile
+++ b/x11-toolkits/tix/Makefile
@@ -7,13 +7,14 @@
PORTNAME= tix
PORTVERSION= 8.4.3
+PORTREVISION= 1
CATEGORIES= x11-toolkits tk
MASTER_SITES= SF
+DISTNAME= Tix${DISTVERSION}-src${DISTVERSIONSUFFIX}
MAINTAINER= doconnor@gsoft.com.au
COMMENT= An extension to the Tk toolkit
-DISTNAME= Tix${DISTVERSION}-src${DISTVERSIONSUFFIX}
WRKSRC= ${WRKDIR}/Tix${DISTVERSION}
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -38,6 +39,8 @@ MANN= TixIntro.n compound.n pixmap.n tix.n tixBalloon.n \
tixScrolledWindow.n tixSelect.n tixStdButtonBox.n tixTList.n \
tixTree.n tixUtils.n
+TIX_LIB= libTix${PORTVERSION}.so
+TIX_LIB_FILE= ${TIX_LIB}.0
.include <bsd.port.pre.mk>
pre-extract:
@@ -60,5 +63,16 @@ post-configure:
post-install:
${INSTALL_MAN} ${WRKSRC}/man/*.n ${PREFIX}/man/mann/
+ ${RM} ${PREFIX}/lib/Tix${PORTVERSION}/${TIX_LIB}
+ ${CP} -p ${WRKSRC}/${TIX_LIB} ${WRKSRC}/${TIX_LIB_FILE}
+ ${INSTALL_LIB} ${WRKSRC}/${TIX_LIB_FILE} ${PREFIX}/lib
+ ${LN} -fs ${PREFIX}/lib/${TIX_LIB_FILE} ${PREFIX}/lib/${TIX_LIB}
+ ${LN} -fs ${PREFIX}/lib/${TIX_LIB_FILE} ${PREFIX}/lib/Tix${PORTVERSION}/${TIX_LIB}
+.for dir in generic unix
+ ${MKDIR} ${PREFIX}/include/tix/${dir}
+ ${INSTALL_DATA} ${WRKSRC}/${dir}/*.h ${PREFIX}/include/tix/${dir}
+.endfor
+ ${LN} -sf ${PREFIX}/include/tix/generic/tix.h ${PREFIX}/include/tix.h
+ ${RMDIR} ${PREFIX}/lib/Tix${PORTVERSION}/html
.include <bsd.port.post.mk>