aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/wxgtk-devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-10-06 09:39:44 +0800
committermarcus <marcus@FreeBSD.org>2003-10-06 09:39:44 +0800
commit86f04b91a7f60670f1772f7134f43cc45d8d22ab (patch)
tree91d1271f8929289ce9c6c5ea7b7ddaf0031b500e /x11-toolkits/wxgtk-devel
parent78a527137435c929ae79adda0a8bcafcf27e71b9 (diff)
downloadfreebsd-ports-gnome-86f04b91a7f60670f1772f7134f43cc45d8d22ab.tar.gz
freebsd-ports-gnome-86f04b91a7f60670f1772f7134f43cc45d8d22ab.tar.zst
freebsd-ports-gnome-86f04b91a7f60670f1772f7134f43cc45d8d22ab.zip
Add a hack to properly setup I18N on FreeBSD.
Diffstat (limited to 'x11-toolkits/wxgtk-devel')
-rw-r--r--x11-toolkits/wxgtk-devel/Makefile1
-rw-r--r--x11-toolkits/wxgtk-devel/files/patch-src_common_intl.cpp22
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-toolkits/wxgtk-devel/Makefile b/x11-toolkits/wxgtk-devel/Makefile
index 177c18999a64..2faeef556aae 100644
--- a/x11-toolkits/wxgtk-devel/Makefile
+++ b/x11-toolkits/wxgtk-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wxgtk
PORTVERSION= 2.4.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/
diff --git a/x11-toolkits/wxgtk-devel/files/patch-src_common_intl.cpp b/x11-toolkits/wxgtk-devel/files/patch-src_common_intl.cpp
new file mode 100644
index 000000000000..f8e465e4cbc3
--- /dev/null
+++ b/x11-toolkits/wxgtk-devel/files/patch-src_common_intl.cpp
@@ -0,0 +1,22 @@
+--- src/common/intl.cpp.orig Sat Oct 4 23:10:24 2003
++++ src/common/intl.cpp Sun Oct 5 21:35:30 2003
+@@ -743,8 +742,18 @@
+ }
+ if ( !retloc )
+ {
++ wxString langFull;
++ if (wxGetEnv(wxT("LC_ALL"), &langFull)||
++ wxGetEnv(wxT("LC_MESSAGES"), &langFull) ||
++ wxGetEnv(wxT("LANG"), &langFull))
++ {
++ retloc = wxSetlocale(LC_ALL, langFull);
++ }
++ }
++ if ( !retloc )
++ {
+ wxLogError(wxT("Cannot set locale to '%s'."), locale.c_str());
+- return FALSE;
++ //return FALSE;
+ }
+ #elif defined(__WIN32__)
+