aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/wxmozilla
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-10-12 11:15:04 +0800
committermarcus <marcus@FreeBSD.org>2004-10-12 11:15:04 +0800
commitb71c2e2bc173b49dfee5478a4aca01e219060ecc (patch)
tree806ff2a5b832f8288b262e424101fc0e1cc5e414 /x11-toolkits/wxmozilla
parent33b57ab915e0556cdb6bd72bb8683b855cd30aee (diff)
downloadfreebsd-ports-gnome-b71c2e2bc173b49dfee5478a4aca01e219060ecc.tar.gz
freebsd-ports-gnome-b71c2e2bc173b49dfee5478a4aca01e219060ecc.tar.zst
freebsd-ports-gnome-b71c2e2bc173b49dfee5478a4aca01e219060ecc.zip
Fix the build with PTHREAD_LIBS=-pthread. I'm also unmarking this port as
broken on 4.X as I think this will fix that build as well. Reported by: pointyhat via kris
Diffstat (limited to 'x11-toolkits/wxmozilla')
-rw-r--r--x11-toolkits/wxmozilla/Makefile14
-rw-r--r--x11-toolkits/wxmozilla/files/patch-ltmain.sh15
2 files changed, 4 insertions, 25 deletions
diff --git a/x11-toolkits/wxmozilla/Makefile b/x11-toolkits/wxmozilla/Makefile
index 45d49baef586..b9daeb64b194 100644
--- a/x11-toolkits/wxmozilla/Makefile
+++ b/x11-toolkits/wxmozilla/Makefile
@@ -8,7 +8,7 @@
PORTNAME= wxmozilla
PORTVERSION= 0.5.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,16 +22,10 @@ LIB_DEPENDS= wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2
RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PYTHON= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehack gnometarget
WXGTK_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --with-wx-config=${WXGTK_CONFIG} --enable-python
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/wxmozilla/files/patch-ltmain.sh b/x11-toolkits/wxmozilla/files/patch-ltmain.sh
deleted file mode 100644
index e5e27078e805..000000000000
--- a/x11-toolkits/wxmozilla/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Mon Feb 2 14:01:02 2004
-+++ ltmain.sh Mon Feb 2 14:01:19 2004
-@@ -4394,10 +4394,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"