aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/wxmozilla
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-12-29 15:21:02 +0800
committermarcus <marcus@FreeBSD.org>2005-12-29 15:21:02 +0800
commite8d4d45f71583db29e5435324a45e29bbdfc1725 (patch)
treeadb7c44b4252e10c68df5c916dc309cfdfdf0a2b /x11-toolkits/wxmozilla
parent111307c73342208db629159422a361a8634e19a1 (diff)
downloadfreebsd-ports-gnome-e8d4d45f71583db29e5435324a45e29bbdfc1725.tar.gz
freebsd-ports-gnome-e8d4d45f71583db29e5435324a45e29bbdfc1725.tar.zst
freebsd-ports-gnome-e8d4d45f71583db29e5435324a45e29bbdfc1725.zip
Use the nspr.pc from devel/npsr instead of looking for one installed by
Mozilla. This fixes the build with the new Gecko World Order.
Diffstat (limited to 'x11-toolkits/wxmozilla')
-rw-r--r--x11-toolkits/wxmozilla/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/x11-toolkits/wxmozilla/Makefile b/x11-toolkits/wxmozilla/Makefile
index 726a9e448e82..faf8a7af1a95 100644
--- a/x11-toolkits/wxmozilla/Makefile
+++ b/x11-toolkits/wxmozilla/Makefile
@@ -26,6 +26,7 @@ USE_GECKO= mozilla
WXGTK_CONFIG?= ${X11BASE}/bin/wxgtk2-2.4-config
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS= --with-wx-config=${WXGTK_CONFIG} --enable-python
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -35,4 +36,8 @@ INSTALLS_SHLIB= yes
IGNORE= does not build on 4.X
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|mozilla-nspr|nspr|g' \
+ ${WRKSRC}/configure
+
.include <bsd.port.post.mk>