aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2014-07-23 16:28:39 +0800
committerdanfe <danfe@FreeBSD.org>2014-07-23 16:28:39 +0800
commit087673959c983dd6612a37a4354eb385258470d3 (patch)
tree3497b6382c0881e283e0313ec8fd84cf26a17c20 /x11-toolkits
parent9ce5873c3b33de0a5029057d22aca28055d34b28 (diff)
downloadfreebsd-ports-gnome-087673959c983dd6612a37a4354eb385258470d3.tar.gz
freebsd-ports-gnome-087673959c983dd6612a37a4354eb385258470d3.tar.zst
freebsd-ports-gnome-087673959c983dd6612a37a4354eb385258470d3.zip
- Do not advertise that port is BROKEN on PowerPC as it builds fine there
- Rearrange Makefile for better readability, remove extraneous bdeps, etc.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/nucleo/Makefile34
1 files changed, 16 insertions, 18 deletions
diff --git a/x11-toolkits/nucleo/Makefile b/x11-toolkits/nucleo/Makefile
index 2cb4a156c959..566150e51b98 100644
--- a/x11-toolkits/nucleo/Makefile
+++ b/x11-toolkits/nucleo/Makefile
@@ -19,11 +19,11 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
USES= gmake libtool pathfix pkgconfig shebangfix tar:bzip2
USE_GL= glu
-SHEBANG_FILES= docs/MacOSX/nBundle.in
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-opencv
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
+SHEBANG_FILES= docs/MacOSX/nBundle.in
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -32,26 +32,28 @@ OPTIONS_DEFINE= FFMPEG GD GNUTLS QT4
OPTIONS_RADIO= DNSSD
OPTIONS_RADIO_DNSSD= AVAHI MDNSRESPONDER
OPTIONS_SUB= yes
+DNSSD_DESC= Service discovery
-AVAHI_BUILD_DEPENDS= avahi-libdns>0:${PORTSDIR}/net/avahi-libdns
AVAHI_LIB_DEPENDS= libdns_sd.so:${PORTSDIR}/net/avahi-libdns
AVAHI_CPPFLAGS= -I${LOCALBASE}/include/avahi-compat-libdns_sd
-DNSSD_DESC= DNS-SD support
-FFMPEG_DESC= FFmpeg plugin
+
+FFMPEG_DESC= Build FFmpeg plugin
FFMPEG_LIB_DEPENDS= libavformat.so:${PORTSDIR}/multimedia/ffmpeg
-FFMPEG_CONFIGURE_WITH= ffmpeg
-GD_DESC= GD plugin
+FFMPEG_CONFIGURE_OFF= --without-ffmpeg
+
+GD_DESC= Build GD plugin
GD_LIB_DEPENDS= libgd.so:${PORTSDIR}/graphics/gd
-QT4_DESC= Qt4 plugin
-GD_CONFIGURE_WITH= gd
+
+QT4_DESC= Build Qt 4 plugin
+GD_CONFIGURE_OFF= --without-gd
+
GNUTLS_LIB_DEPENDS= libgnutls.so:${PORTSDIR}/security/gnutls
-GNUTLS_CONFIGURE_WITH= gnutls
-MDNSRESPONDER_BUILD_DEPENDS=\
- mDNSResponder>0:${PORTSDIR}/net/mDNSResponder
-MDNSRESPONDER_LIB_DEPENDS=\
- libdns_sd.so:${PORTSDIR}/net/mDNSResponder
+GNUTLS_CONFIGURE_OFF= --without-gnutls
+
+MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:${PORTSDIR}/net/mDNSResponder
+
QT4_USE= QT4=moc_build,corelib
-QT4_CONFIGURE_WITH= qt
+QT4_CONFIGURE_OFF= --without-qt
QT4_MAKE_ARGS= QT4MOC="${MOC}"
.include <bsd.port.options.mk>
@@ -64,10 +66,6 @@ CONFIGURE_ARGS+= --without-dns-sd
QT_NONSTANDARD= yes
.endif
-.if ${ARCH} == "powerpc" && ${OPSYS} == FreeBSD && ${OSVERSION} > 900000
-BROKEN= Does not compile on powerpc-9
-.endif
-
post-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/nucleo