aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkmoore <kmoore@FreeBSD.org>2010-10-16 04:54:22 +0800
committerkmoore <kmoore@FreeBSD.org>2010-10-16 04:54:22 +0800
commit0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2 (patch)
tree9edca83c5624dbb8d8da9c6132b1e46c0dba6f90 /x11-toolkits
parent29e168c9d1e2abe9221d5ffabeaeea1e29d66899 (diff)
downloadfreebsd-ports-gnome-0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2.tar.gz
freebsd-ports-gnome-0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2.tar.zst
freebsd-ports-gnome-0aff5294d5ac96c05f31d00af7f4f512c5a7c5e2.zip
Improve handing of LD_LIBRARY_PATH when doing non-standard LOCALBASE builds.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt33/Makefile2
-rw-r--r--x11-toolkits/qt4-gui/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index ef6ffe172f24..74cb8bdc4b80 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -49,7 +49,7 @@ CONFIGURE_ARGS+=-system-libpng -system-libjpeg -system-libmng \
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
MAKE_ENV?= TMPDIR=${TMPDIR} \
QTDIR=${WRKSRC} \
- LD_LIBRARY_PATH=${WRKSRC}/lib \
+ LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
ALL_TARGET= sub-tools
EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 25ce7d69204b..65a9220d15f1 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -32,7 +32,7 @@ USE_XORG= xrender xrandr xinerama inputproto xfixes \
ALL_TARGET= first
CONFIGURE_ENV?= QTDIR=${WRKSRC} PATH=${WRKSRC}/bin:$$PATH
-MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib \
+MAKE_ENV?= QTDIR=${WRKSRC} LD_LIBRARY_PATH=${WRKSRC}/lib:$$LD_LIBRARY_PATH \
PATH=${WRKSRC}/bin:$$PATH
DO_NOT_EXTRACT= demos doc examples mkspecs qmake tools translations \