aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2007-10-01 06:42:46 +0800
committermarcus <marcus@FreeBSD.org>2007-10-01 06:42:46 +0800
commit144a1a11ce5ba5b7bf80a7be54f614b9b1bab5e9 (patch)
tree34a2b8043e5edc3e2cfd60d5bfc4aa17176358b6 /x11-toolkits
parentc42bc1f6a273f55a9be5c710bce56d82ac441975 (diff)
downloadfreebsd-ports-gnome-144a1a11ce5ba5b7bf80a7be54f614b9b1bab5e9.tar.gz
freebsd-ports-gnome-144a1a11ce5ba5b7bf80a7be54f614b9b1bab5e9.tar.zst
freebsd-ports-gnome-144a1a11ce5ba5b7bf80a7be54f614b9b1bab5e9.zip
Fix build and subsequent functionality of the CUPS printer backend
in GTK+. PR: 116750 Obtained from: http://bugzilla.gnome.org/show_bug.cgi?id=467414
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk20/Makefile2
-rw-r--r--x11-toolkits/gtk20/files/patch-modules_printbackends_cups_gtkcupsutils.c13
-rw-r--r--x11-toolkits/gtk30/Makefile2
-rw-r--r--x11-toolkits/gtk30/files/patch-modules_printbackends_cups_gtkcupsutils.c13
4 files changed, 28 insertions, 2 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index 3550b156cc63..02f312ec599d 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.10.14
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/v2.10/ \
diff --git a/x11-toolkits/gtk20/files/patch-modules_printbackends_cups_gtkcupsutils.c b/x11-toolkits/gtk20/files/patch-modules_printbackends_cups_gtkcupsutils.c
new file mode 100644
index 000000000000..db213c989555
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-modules_printbackends_cups_gtkcupsutils.c
@@ -0,0 +1,13 @@
+--- modules/printbackends/cups/gtkcupsutils.c.orig 2007-09-30 18:40:09.000000000 -0400
++++ modules/printbackends/cups/gtkcupsutils.c 2007-09-30 18:40:45.000000000 -0400
+@@ -627,9 +627,7 @@ _post_send (GtkCupsRequest *request)
+ httpClearFields(request->http);
+ httpSetField(request->http, HTTP_FIELD_CONTENT_LENGTH, length);
+ httpSetField(request->http, HTTP_FIELD_CONTENT_TYPE, "application/ipp");
+-#ifdef HAVE_HTTP_AUTHSTRING
+- httpSetField(request->http, HTTP_FIELD_AUTHORIZATION, request->http->authstring);
+-#endif
++ httpSetField (request->http, HTTP_FIELD_AUTHORIZATION, httpGetAuthString (request->http));
+
+ if (httpPost(request->http, request->resource))
+ {
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index 3550b156cc63..02f312ec599d 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gtk
PORTVERSION= 2.10.14
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/,} \
ftp://ftp.gtk.org/pub/gtk/v2.10/ \
diff --git a/x11-toolkits/gtk30/files/patch-modules_printbackends_cups_gtkcupsutils.c b/x11-toolkits/gtk30/files/patch-modules_printbackends_cups_gtkcupsutils.c
new file mode 100644
index 000000000000..db213c989555
--- /dev/null
+++ b/x11-toolkits/gtk30/files/patch-modules_printbackends_cups_gtkcupsutils.c
@@ -0,0 +1,13 @@
+--- modules/printbackends/cups/gtkcupsutils.c.orig 2007-09-30 18:40:09.000000000 -0400
++++ modules/printbackends/cups/gtkcupsutils.c 2007-09-30 18:40:45.000000000 -0400
+@@ -627,9 +627,7 @@ _post_send (GtkCupsRequest *request)
+ httpClearFields(request->http);
+ httpSetField(request->http, HTTP_FIELD_CONTENT_LENGTH, length);
+ httpSetField(request->http, HTTP_FIELD_CONTENT_TYPE, "application/ipp");
+-#ifdef HAVE_HTTP_AUTHSTRING
+- httpSetField(request->http, HTTP_FIELD_AUTHORIZATION, request->http->authstring);
+-#endif
++ httpSetField (request->http, HTTP_FIELD_AUTHORIZATION, httpGetAuthString (request->http));
+
+ if (httpPost(request->http, request->resource))
+ {