aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2017-07-08 14:17:46 +0800
committeracm <acm@FreeBSD.org>2017-07-08 14:17:46 +0800
commit1d5962d0a623bd4386e7790caef3e4624af26273 (patch)
treee4a02daa4c4bec25db8fa93bdd59bcdf9f9c74cc /x11-toolkits
parentdffa62aeb4fbca8f8bfa490ff3093229e773fc19 (diff)
downloadfreebsd-ports-gnome-1d5962d0a623bd4386e7790caef3e4624af26273.tar.gz
freebsd-ports-gnome-1d5962d0a623bd4386e7790caef3e4624af26273.tar.zst
freebsd-ports-gnome-1d5962d0a623bd4386e7790caef3e4624af26273.zip
- New port: x11-toolkits/qt5pas
Provide a Qt5 binding for FreePascal that may be of use to provide the Lazarus LCL library with a Qt interface This binding does not aim to cover the whole Qt5 framework, but only just enough to satisfy the LCL needs. If any LCL/Qt developer needs an extra class, just ask and it will be added promptly. Some of the methods that have parameters based upon templates have been omitted. If however you need any of those, just ask. WWW: http://wiki.lazarus.freepascal.org/index.php/Qt_Interface
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/qt5pas/Makefile23
-rw-r--r--x11-toolkits/qt5pas/distinfo3
-rw-r--r--x11-toolkits/qt5pas/pkg-descr11
-rw-r--r--x11-toolkits/qt5pas/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 26ec5c4edf8a..e669d5b30c27 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -239,6 +239,7 @@
SUBDIR += qt5-uiplugin
SUBDIR += qt5-virtualkeyboard
SUBDIR += qt5-widgets
+ SUBDIR += qt5pas
SUBDIR += qtermwidget
SUBDIR += qwt5
SUBDIR += qwt5-designerplugin
diff --git a/x11-toolkits/qt5pas/Makefile b/x11-toolkits/qt5pas/Makefile
new file mode 100644
index 000000000000..e380d5b1a3ec
--- /dev/null
+++ b/x11-toolkits/qt5pas/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= qt5pas
+PORTVERSION= 2.6
+CATEGORIES= x11-toolkits
+MASTER_SITES= LOCAL/acm/
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Qt5 binding for FreePascal
+
+USE_LDCONFIG= yes
+USES= qmake
+USE_QT5= buildtools_build core gui network printsupport x11extras
+
+QT5_VER_MIN= 5.6.1
+
+.include <bsd.port.pre.mk>
+
+.if ${QT5_VERSION:S/.//g} < ${QT5_VER_MIN:S/.//g}
+IGNORE= please update your current qt5 version to ${QT5_VER_MIN}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/qt5pas/distinfo b/x11-toolkits/qt5pas/distinfo
new file mode 100644
index 000000000000..8f93d83f1684
--- /dev/null
+++ b/x11-toolkits/qt5pas/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1499492238
+SHA256 (qt5pas-2.6.tar.gz) = d3595531fcd97b6271c42386dde7c724da76b045fb05917127e4ba5c3dbdd9dd
+SIZE (qt5pas-2.6.tar.gz) = 530537
diff --git a/x11-toolkits/qt5pas/pkg-descr b/x11-toolkits/qt5pas/pkg-descr
new file mode 100644
index 000000000000..8c58d8e2b11a
--- /dev/null
+++ b/x11-toolkits/qt5pas/pkg-descr
@@ -0,0 +1,11 @@
+Provide a Qt5 binding for FreePascal that may be of use to provide the Lazarus
+LCL library with a Qt interface
+
+This binding does not aim to cover the whole Qt5 framework, but only just
+enough to satisfy the LCL needs. If any LCL/Qt developer needs an extra class,
+just ask and it will be added promptly. Some of the methods that have parameters
+based upon templates have been omitted.
+
+If however you need any of those, just ask.
+
+WWW: http://wiki.lazarus.freepascal.org/index.php/Qt_Interface
diff --git a/x11-toolkits/qt5pas/pkg-plist b/x11-toolkits/qt5pas/pkg-plist
new file mode 100644
index 000000000000..803c21b42981
--- /dev/null
+++ b/x11-toolkits/qt5pas/pkg-plist
@@ -0,0 +1,4 @@
+lib/qt5/libQt5Pas.so
+lib/qt5/libQt5Pas.so.1
+lib/qt5/libQt5Pas.so.1.2
+lib/qt5/libQt5Pas.so.1.2.6