diff options
author | gahr <gahr@FreeBSD.org> | 2010-12-20 23:42:07 +0800 |
---|---|---|
committer | gahr <gahr@FreeBSD.org> | 2010-12-20 23:42:07 +0800 |
commit | 79dc645ff203fa6430dd2f3bb86c2539e3a1f537 (patch) | |
tree | eaea5f7f81fc1f0b94befe11c7b4fa8cc2802885 /x11-toolkits | |
parent | bbe34db9130394800030cc04e70905a9730696c7 (diff) | |
download | freebsd-ports-gnome-79dc645ff203fa6430dd2f3bb86c2539e3a1f537.tar.gz freebsd-ports-gnome-79dc645ff203fa6430dd2f3bb86c2539e3a1f537.tar.zst freebsd-ports-gnome-79dc645ff203fa6430dd2f3bb86c2539e3a1f537.zip |
- Update to 1.7.25
Changes since last port update (1.7.23)
* Added FXMat2f, FXMat2d.
* Vectorized many functions in FXMat2d, FXMat2f, FXMat3d, FXMat3f, FXMat4d,
FXMat4f (using SSE/SSE2/SSE3).
* Some fixes to FXPath::isInside().
* Fix to drawImage() in FXDCPrint.
* Added FXPtrList.
* Add FXbool return value to some API's in FXArray.
* Change in configure.ac to check intrinsics header files with modified
compiler flags; header files are not compilable with default options.
* Updated Borland C++ makefiles.
* Update Visual Studio 6 project files with missing headers.
* Small fixes in FXAutoPtr.h.
* Change some inlined API's of FXProgressDialog to non-inline.
Diffstat (limited to 'x11-toolkits')
-rw-r--r-- | x11-toolkits/fox17/Makefile | 2 | ||||
-rw-r--r-- | x11-toolkits/fox17/distinfo | 5 | ||||
-rw-r--r-- | x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp | 36 | ||||
-rw-r--r-- | x11-toolkits/fox17/pkg-plist | 3 |
4 files changed, 24 insertions, 22 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile index 60bfdb9b7e32..b9c9fb7e6113 100644 --- a/x11-toolkits/fox17/Makefile +++ b/x11-toolkits/fox17/Makefile @@ -6,7 +6,7 @@ # PORTNAME= fox -PORTVERSION= 1.7.23 +PORTVERSION= 1.7.25 CATEGORIES= x11-toolkits MASTER_SITES= http://www.fox-toolkit.org/ftp/ \ ftp://ftp.fox-toolkit.org/pub/ diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo index 2a95b1445895..b0ff998b7e89 100644 --- a/x11-toolkits/fox17/distinfo +++ b/x11-toolkits/fox17/distinfo @@ -1,3 +1,2 @@ -MD5 (fox-1.7.23.tar.gz) = ee8430d6480d3289d54b847f47405670 -SHA256 (fox-1.7.23.tar.gz) = 5fad49a8c06c6c8ecc5bda1c559577cad834523adbea0dd4e612fcda730f9652 -SIZE (fox-1.7.23.tar.gz) = 4924875 +SHA256 (fox-1.7.25.tar.gz) = 508a18ac7eda524ea207d206d2aff2f3f78b53ad7e2e749e6149d9a5e985afdc +SIZE (fox-1.7.25.tar.gz) = 4946475 diff --git a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp index c97860685857..649ced565c7e 100644 --- a/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp +++ b/x11-toolkits/fox17/files/patch-lib_FXAtomic.cpp @@ -1,20 +1,20 @@ ---- lib/FXAtomic.cpp.orig 2010-09-18 00:09:37.000000000 +0000 -+++ lib/FXAtomic.cpp 2010-09-27 18:35:26.000000000 +0000 +--- lib/FXAtomic.cpp.orig 2010-12-20 09:35:19.000000000 +0000 ++++ lib/FXAtomic.cpp 2010-12-20 09:35:58.000000000 +0000 @@ -101,7 +101,7 @@ - // Have API to find out which. - - // If neither windows, nor inline assembly, then fallback to global mutex --#if !(defined(WIN32) || (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || defined(__x86_64__)))) -+#if !(defined(WIN32) || (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || defined(__x86_64__)))) || defined(__FreeBSD__) - static pthread_mutex_t global_mutex=PTHREAD_MUTEX_INITIALIZER; - #endif - + // Have API to find out which.
+
+ // If neither windows, nor inline assembly, then fallback to global mutex
+-#if !(defined(WIN32) || (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || defined(__x86_64__))))
++#if !(defined(WIN32) || (defined(HAVE_INLINE_ASSEMBLY) && (defined(__i386__) || defined(__x86_64__)))) || defined(__FreeBSD__)
+ static pthread_mutex_t global_mutex=PTHREAD_MUTEX_INITIALIZER;
+ #endif
+
@@ -323,7 +323,7 @@ - "movl %%esi,%%ebx\n\t" // Swap ESI back to restore EBX - "setz %0\n\t" : "=a"(ret), "=D"(ptr) : "D"(ptr), "a"(cmpa), "d"(cmpb), "S"(a), "c"(b) : "memory", "cc"); - return ret; --#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__x86_64__)) -+#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__x86_64__)) && !defined(__FreeBSD__) - register FXbool ret; - // CMPXCHG16B: if(RDX:RAX == MEM128){ MEM128 = RCX:RBX } else { RDX:RAX = MEM128; } - __asm__ __volatile__ ("lock\n\t" + "movl %%esi,%%ebx\n\t" // Swap ESI back to restore EBX
+ "setz %0\n\t" : "=a"(ret), "=D"(ptr) : "D"(ptr), "a"(cmpa), "d"(cmpb), "S"(a), "c"(b) : "memory", "cc");
+ return ret;
+-#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__x86_64__))
++#elif (defined(HAVE_INLINE_ASSEMBLY) && defined(__x86_64__)) && !defined(__FreeBSD__)
+ register FXbool ret;
+ // CMPXCHG16B: if(RDX:RAX == MEM128){ MEM128 = RCX:RBX } else { RDX:RAX = MEM128; }
+ __asm__ __volatile__ ("lock\n\t"
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist index 20648b37ca9d..7e39596af466 100644 --- a/x11-toolkits/fox17/pkg-plist +++ b/x11-toolkits/fox17/pkg-plist @@ -182,6 +182,8 @@ include/fox-%%MAJORVER%%/FXMDIButton.h include/fox-%%MAJORVER%%/FXMDIChild.h include/fox-%%MAJORVER%%/FXMDIClient.h include/fox-%%MAJORVER%%/FXMainWindow.h +include/fox-%%MAJORVER%%/FXMat2d.h +include/fox-%%MAJORVER%%/FXMat2f.h include/fox-%%MAJORVER%%/FXMat3d.h include/fox-%%MAJORVER%%/FXMat3f.h include/fox-%%MAJORVER%%/FXMat4d.h @@ -219,6 +221,7 @@ include/fox-%%MAJORVER%%/FXPopup.h include/fox-%%MAJORVER%%/FXPrintDialog.h include/fox-%%MAJORVER%%/FXProgressBar.h include/fox-%%MAJORVER%%/FXProgressDialog.h +include/fox-%%MAJORVER%%/FXPtrList.h include/fox-%%MAJORVER%%/FXPtrQueue.h include/fox-%%MAJORVER%%/FXQuatd.h include/fox-%%MAJORVER%%/FXQuatf.h |