aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-11-11 05:06:15 +0800
committermarino <marino@FreeBSD.org>2013-11-11 05:06:15 +0800
commit7d5bbe85a8b06556a9a039c54f17a275d8524e17 (patch)
treeb69e6602d86634e8b43dd36b8fb945d2e7a416d4 /x11-toolkits
parent03c468ea7919ae691555268ef5125fdfc1a75774 (diff)
downloadfreebsd-ports-gnome-7d5bbe85a8b06556a9a039c54f17a275d8524e17.tar.gz
freebsd-ports-gnome-7d5bbe85a8b06556a9a039c54f17a275d8524e17.tar.zst
freebsd-ports-gnome-7d5bbe85a8b06556a9a039c54f17a275d8524e17.zip
x11-toolkits/qtada: Convert to staging
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qtada/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/x11-toolkits/qtada/Makefile b/x11-toolkits/qtada/Makefile
index b99c11df1f7f..18921f1aeb2d 100644
--- a/x11-toolkits/qtada/Makefile
+++ b/x11-toolkits/qtada/Makefile
@@ -17,27 +17,24 @@ BUILD_DEPENDS= gprbuild>=20120510:${PORTSDIR}/devel/gprbuild \
USES= ada gmake pkgconfig
GNU_CONFIGURE= yes
USE_QT4= corelib gui xml designer sql opengl webkit
-DESTINY= ${WRKDIR}/destino
-MAKE_ENV= DESTDIR=${DESTINY}
+NO_MTREE= yes
#CONFIGURE_ARGS= --with-gtkada=NO
-NO_STAGE= yes
post-install:
- ${MV} ${DESTINY}${PREFIX}/examples ${DESTINY}${PREFIX}/share/
- ${CP} -pR ${DESTINY}${PREFIX}/ ${PREFIX}/
- @cd ${DESTINY}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
- ${SORT} > ${WRKDIR}/PLIST.all
- @cd ${DESTINY}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share
+ ${MV} ${STAGEDIR}${PREFIX}/examples ${STAGEDIR}${PREFIX}/share/
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * \( -type f -or -type l \) | \
+ ${SORT} > ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d | ${AWK} '/\//' | \
${SORT} -r | ${SED} -e '/lib\/gnat$$/d' -e '/share\/doc$$/d' \
-e '/share\/gps$$/d' -e '/share\/gps\/plug-ins$$/d' \
-e '/share\/gprconfig$$/d' -e 's/^/@dirrm /g' \
- >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gprconfig 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${WRKDIR}/PLIST.all
- @${CAT} ${WRKDIR}/PLIST.all >> ${TMPPLIST}
+ >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/lib/gnat 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/doc 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gprconfig 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps/plug-ins 2>/dev/null || true" >> ${TMPPLIST}
+ @echo "@unexec rmdir %D/share/gps 2>/dev/null || true" >> ${TMPPLIST}
.include <bsd.port.mk>