aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-07-31 20:51:19 +0800
committergahr <gahr@FreeBSD.org>2014-07-31 20:51:19 +0800
commit85c2c002bb595df41e85369127fbfe8dece22689 (patch)
treea50e5299affa164fc393e0bcfaa0af5b77d84898 /x11-toolkits
parent1b02604931ab13cbca6fae79f9270cfce48d76e5 (diff)
downloadfreebsd-ports-gnome-85c2c002bb595df41e85369127fbfe8dece22689.tar.gz
freebsd-ports-gnome-85c2c002bb595df41e85369127fbfe8dece22689.tar.zst
freebsd-ports-gnome-85c2c002bb595df41e85369127fbfe8dece22689.zip
- Update to 1.7.49
Changes: * Major API changes to FXThreadPool: mostly, much more sane implementation, and optional FXCompletion parameter passed to perform wait on subset of tasks; see FXCompletion notes below. * Added FXCompletion synchronization object. FXCompletion is now used in FXTaskGroup, FXThreadPool, but can also be used in your own programs whenever one thread needs to await the completion of multiple worker threads. * Fixed bug in FXJSON parser: properly stop parsing at offending character. * Byte order mark handling fix in FXJSON parser. * Added toChars() API to FXVariant; it returns empty string unless variant is of type string. This is very similar to asChars(), except that toChars() is safe (always returns a non-NULL pointer). * Renamed toPointer() to toPtr() in FXVariant for consistency. * FXParallel implementation changes: don't kick off tasks via FXThreadPool in ParallelFor if there's only one task. Also, split ParallelFor into a number of pieces corresponding to the number of threads available in the FXThreadPool, unless this number is passed explicitly. * Ensured FXParallelForFunctor's are aligned in ParallelFor. * Updated VC++ 2008 Visual Studio project files. - Remove a patch that was applied upstream
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox17/Makefile2
-rw-r--r--x11-toolkits/fox17/distinfo4
-rw-r--r--x11-toolkits/fox17/files/patch-include_FXParallel.h11
-rw-r--r--x11-toolkits/fox17/pkg-plist5
4 files changed, 6 insertions, 16 deletions
diff --git a/x11-toolkits/fox17/Makefile b/x11-toolkits/fox17/Makefile
index 72b69cf031c4..c6f760eaf192 100644
--- a/x11-toolkits/fox17/Makefile
+++ b/x11-toolkits/fox17/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fox
-PORTVERSION= 1.7.48
+PORTVERSION= 1.7.49
CATEGORIES= x11-toolkits
MASTER_SITES= http://ftp.fox-toolkit.org/pub/ \
ftp://ftp.fox-toolkit.org/pub/
diff --git a/x11-toolkits/fox17/distinfo b/x11-toolkits/fox17/distinfo
index 87b855b5bdf8..23aeaba95ac5 100644
--- a/x11-toolkits/fox17/distinfo
+++ b/x11-toolkits/fox17/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fox-1.7.48.tar.gz) = 90e011aa83eed8a1b3ffe1c1571cb5de41fae8162c7ae01e22697f98aeaa9b7f
-SIZE (fox-1.7.48.tar.gz) = 5334145
+SHA256 (fox-1.7.49.tar.gz) = 2435c56cde3ba6617c638af4f3bac39e8f4d5dd5a5c6d0805d274c7ba05c520c
+SIZE (fox-1.7.49.tar.gz) = 5336321
diff --git a/x11-toolkits/fox17/files/patch-include_FXParallel.h b/x11-toolkits/fox17/files/patch-include_FXParallel.h
deleted file mode 100644
index 002f83348d9a..000000000000
--- a/x11-toolkits/fox17/files/patch-include_FXParallel.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/FXParallel.h.orig 2014-07-15 12:35:48.000000000 +0200
-+++ include/FXParallel.h 2014-07-15 12:35:18.000000000 +0200
-@@ -287,7 +287,7 @@
- const FXuval size((sizeof(FXParallelLoopFunctor<Functor,Index>)+sizeof(FXulong)-1)/sizeof(FXulong));
- if(fm<to){
- FXTaskGroup group(pool);
-- FXlong space[128*size];
-+ FXlong space[128*(sizeof(FXParallelLoopFunctor<Functor,Index>)+sizeof(FXulong)-1)/sizeof(FXulong)];
- Index nits=1+(to-fm-1)/by,ni,c;
- if(nc>128) nc=128;
- if(nc>nits) nc=nits;
diff --git a/x11-toolkits/fox17/pkg-plist b/x11-toolkits/fox17/pkg-plist
index 68bf185afa46..b5b9ea5f34fe 100644
--- a/x11-toolkits/fox17/pkg-plist
+++ b/x11-toolkits/fox17/pkg-plist
@@ -11,12 +11,12 @@ lib/libCHART-%%MAJORVER%%.a
lib/libCHART-%%MAJORVER%%.la
lib/libCHART-%%MAJORVER%%.so
lib/libCHART-%%MAJORVER%%.so.0
-lib/libCHART-%%MAJORVER%%.so.0.0.48
+lib/libCHART-%%MAJORVER%%.so.0.0.49
lib/libFOX-%%MAJORVER%%.a
lib/libFOX-%%MAJORVER%%.la
lib/libFOX-%%MAJORVER%%.so
lib/libFOX-%%MAJORVER%%.so.0
-lib/libFOX-%%MAJORVER%%.so.0.0.48
+lib/libFOX-%%MAJORVER%%.so.0.0.49
include/fox-%%MAJORVER%%/FX4Splitter.h
include/fox-%%MAJORVER%%/FX7Segment.h
include/fox-%%MAJORVER%%/FX885910Codec.h
@@ -49,6 +49,7 @@ include/fox-%%MAJORVER%%/FXBitmap.h
include/fox-%%MAJORVER%%/FXBitmapFrame.h
include/fox-%%MAJORVER%%/FXBitmapView.h
include/fox-%%MAJORVER%%/FXButton.h
+include/fox-%%MAJORVER%%/FXCompletion.h
include/fox-%%MAJORVER%%/FXCP1250Codec.h
include/fox-%%MAJORVER%%/FXCP1251Codec.h
include/fox-%%MAJORVER%%/FXCP1252Codec.h