aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-09-02 17:36:29 +0800
committeraz <az@FreeBSD.org>2013-09-02 17:36:29 +0800
commit9c4cca1df5edd7f22e07934853ab7f2318b3e6f1 (patch)
tree859ba2ba077471a41f3eb1e1e8f1a0b3571ab0e5 /x11-toolkits
parent6ff983cb6a6caabe6c82f1b446d42fc882f0b015 (diff)
downloadfreebsd-ports-gnome-9c4cca1df5edd7f22e07934853ab7f2318b3e6f1.tar.gz
freebsd-ports-gnome-9c4cca1df5edd7f22e07934853ab7f2318b3e6f1.tar.zst
freebsd-ports-gnome-9c4cca1df5edd7f22e07934853ab7f2318b3e6f1.zip
- convert to the new perl5 framework
Approved by: portmgr (bapt@, blanket)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnome-desktop-sharp20/Makefile3
-rw-r--r--x11-toolkits/gnome-sharp20/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp10/Makefile3
-rw-r--r--x11-toolkits/gtk-sharp20/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-Chmod/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-Ex-Utils/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-GladeXML/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2-PathButtonBar/Makefile3
-rw-r--r--x11-toolkits/p5-Gtk2/Makefile3
-rw-r--r--x11-toolkits/p5-Pango/Makefile3
-rw-r--r--x11-toolkits/p5-Tk-FileDialog/Makefile3
-rw-r--r--x11-toolkits/p5-Tk-FontDialog/Makefile3
13 files changed, 26 insertions, 13 deletions
diff --git a/x11-toolkits/gnome-desktop-sharp20/Makefile b/x11-toolkits/gnome-desktop-sharp20/Makefile
index b05e94340b05..0cb6c9c60f79 100644
--- a/x11-toolkits/gnome-desktop-sharp20/Makefile
+++ b/x11-toolkits/gnome-desktop-sharp20/Makefile
@@ -18,7 +18,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gnomepanel gtkhtml3 gtksharp20 gnomesharp20 librsvg2 vte \
libgnomeprintui gtksourceview2 gnomepanel libwnck nautiluscdburner
diff --git a/x11-toolkits/gnome-sharp20/Makefile b/x11-toolkits/gnome-sharp20/Makefile
index a4f02a184500..bd771dcd556d 100644
--- a/x11-toolkits/gnome-sharp20/Makefile
+++ b/x11-toolkits/gnome-sharp20/Makefile
@@ -19,7 +19,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gnomepanel gtksharp20 librsvg2 vte libgnomeprintui \
libgnomeui
MAKE_JOBS_UNSAFE= yes
diff --git a/x11-toolkits/gtk-sharp10/Makefile b/x11-toolkits/gtk-sharp10/Makefile
index b3225311c9f5..b6cdf2ac1524 100644
--- a/x11-toolkits/gtk-sharp10/Makefile
+++ b/x11-toolkits/gtk-sharp10/Makefile
@@ -22,7 +22,8 @@ LATEST_LINK= gtk-sharp10
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gtkhtml3 vte librsvg2 libgnomecanvas \
libgnomeprintui libglade2 libgnomeui
diff --git a/x11-toolkits/gtk-sharp20/Makefile b/x11-toolkits/gtk-sharp20/Makefile
index 9e2f8b5f9589..cd4e84af9e47 100644
--- a/x11-toolkits/gtk-sharp20/Makefile
+++ b/x11-toolkits/gtk-sharp20/Makefile
@@ -24,7 +24,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_GNOME= gnomehack gtk20 libglade2
post-patch:
diff --git a/x11-toolkits/p5-Gtk2-Chmod/Makefile b/x11-toolkits/p5-Gtk2-Chmod/Makefile
index fa2be17ea8d3..5970ab1e2e5a 100644
--- a/x11-toolkits/p5-Gtk2-Chmod/Makefile
+++ b/x11-toolkits/p5-Gtk2-Chmod/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= p5-File-Stat-Bits>=0:${PORTSDIR}/sysutils/p5-File-Stat-Bits \
p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::Chmod.3
diff --git a/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile b/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile
index ef44991253a7..9474061f0ea0 100644
--- a/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile
+++ b/x11-toolkits/p5-Gtk2-Ex-Dialogs/Makefile
@@ -19,7 +19,8 @@ BUILD_DEPENDS= p5-File-Type>=0:${PORTSDIR}/devel/p5-File-Type \
p5-Gtk2-Ex-Utils>=0:${PORTSDIR}/x11-toolkits/p5-Gtk2-Ex-Utils
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::Ex::Dialogs::Question.3 \
Gtk2::Ex::Dialogs::ChooseDirectory.3 \
Gtk2::Ex::Dialogs::Message.3 \
diff --git a/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile b/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
index 67b69de0bae6..d4337b729313 100644
--- a/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
+++ b/x11-toolkits/p5-Gtk2-Ex-Utils/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
RUN_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::Ex::Constants.3 \
Gtk2::Ex::Utils.3
diff --git a/x11-toolkits/p5-Gtk2-GladeXML/Makefile b/x11-toolkits/p5-Gtk2-GladeXML/Makefile
index 3a6a2d39f0b8..11df941c96ff 100644
--- a/x11-toolkits/p5-Gtk2-GladeXML/Makefile
+++ b/x11-toolkits/p5-Gtk2-GladeXML/Makefile
@@ -25,7 +25,8 @@ RUN_DEPENDS= p5-Glib2>=1.00:${PORTSDIR}/devel/p5-Glib2 \
USE_GNOME= libglade2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ${PORTNAME:S/-/::/g}.3
.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile b/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile
index fac81a382fe8..36ec8af911c0 100644
--- a/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile
+++ b/x11-toolkits/p5-Gtk2-PathButtonBar/Makefile
@@ -18,7 +18,8 @@ COMMENT= Creates a bar for path manipulation
RUN_DEPENDS= p5-Gtk2>=1.060:${PORTSDIR}/x11-toolkits/p5-Gtk2
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Gtk2::PathButtonBar.3
diff --git a/x11-toolkits/p5-Gtk2/Makefile b/x11-toolkits/p5-Gtk2/Makefile
index d147cc7bc95e..d23855c5dc91 100644
--- a/x11-toolkits/p5-Gtk2/Makefile
+++ b/x11-toolkits/p5-Gtk2/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= p5-Pango>=0:${PORTSDIR}/x11-toolkits/p5-Pango \
p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2
USE_GNOME= gtk20 pango
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
USE_GMAKE= yes
CONFIGURE_ENV+= FORCE_GMAKE=yes
MAKE_ENV+= LANG=C
diff --git a/x11-toolkits/p5-Pango/Makefile b/x11-toolkits/p5-Pango/Makefile
index 798ff3829828..9133a729d3f7 100644
--- a/x11-toolkits/p5-Pango/Makefile
+++ b/x11-toolkits/p5-Pango/Makefile
@@ -23,7 +23,8 @@ BUILD_DEPENDS= p5-ExtUtils-Depends>=0.300:${PORTSDIR}/devel/p5-ExtUtils-Depends
RUN_DEPENDS= p5-Glib2>=1.220:${PORTSDIR}/devel/p5-Glib2
USE_GNOME= pango
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAKE_JOBS_UNSAFE=yes
post-install:
diff --git a/x11-toolkits/p5-Tk-FileDialog/Makefile b/x11-toolkits/p5-Tk-FileDialog/Makefile
index 45bad5e42ba3..9c02cdeb18c1 100644
--- a/x11-toolkits/p5-Tk-FileDialog/Makefile
+++ b/x11-toolkits/p5-Tk-FileDialog/Makefile
@@ -16,7 +16,8 @@ COMMENT= Tk::FileDialog - A file selector dialog for perl/Tk
BUILD_DEPENDS= p5-Tk>=0:${PORTSDIR}/x11-toolkits/p5-Tk
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Tk::FileDialog.3
PLIST_SUB= PERL_VERSION=${PERL_VERSION}
diff --git a/x11-toolkits/p5-Tk-FontDialog/Makefile b/x11-toolkits/p5-Tk-FontDialog/Makefile
index a22c1bd3991f..280e5bc303df 100644
--- a/x11-toolkits/p5-Tk-FontDialog/Makefile
+++ b/x11-toolkits/p5-Tk-FontDialog/Makefile
@@ -18,7 +18,8 @@ COMMENT= Font dialog widget
BUILD_DEPENDS= p5-Tk>=804:${PORTSDIR}/x11-toolkits/p5-Tk
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= ${PORTNAME:S/-/::/g}.3
.include <bsd.port.mk>