aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2011-03-13 06:20:49 +0800
committernaddy <naddy@FreeBSD.org>2011-03-13 06:20:49 +0800
commitb78f03dd05dd959691e0f35dc1cbd021ce6ef960 (patch)
tree89ed3d03a6a85272155c5a2db2d1a92b902524d2 /x11-toolkits
parentb9de0e2482daec1194447a1e07d743fecd53d0b0 (diff)
downloadfreebsd-ports-gnome-b78f03dd05dd959691e0f35dc1cbd021ce6ef960.tar.gz
freebsd-ports-gnome-b78f03dd05dd959691e0f35dc1cbd021ce6ef960.tar.zst
freebsd-ports-gnome-b78f03dd05dd959691e0f35dc1cbd021ce6ef960.zip
Remove need for gmake (and it breaks with 3.82).
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtkextra/Makefile1
-rw-r--r--x11-toolkits/gtkextra/files/patch-ac28
2 files changed, 24 insertions, 5 deletions
diff --git a/x11-toolkits/gtkextra/Makefile b/x11-toolkits/gtkextra/Makefile
index 2b0b6c734366..195c6da256d7 100644
--- a/x11-toolkits/gtkextra/Makefile
+++ b/x11-toolkits/gtkextra/Makefile
@@ -20,7 +20,6 @@ COMMENT= A useful widget set complementary to GTK+
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_GNOME= gtk12
-USE_GMAKE= yes
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/x11-toolkits/gtkextra/files/patch-ac b/x11-toolkits/gtkextra/files/patch-ac
index b640137d09c7..61dc0fa18919 100644
--- a/x11-toolkits/gtkextra/files/patch-ac
+++ b/x11-toolkits/gtkextra/files/patch-ac
@@ -1,9 +1,9 @@
$FreeBSD$
---- Makefile.in.orig Fri Mar 9 17:19:15 2001
-+++ Makefile.in Sun Mar 11 12:36:59 2001
-@@ -448,6 +448,8 @@
+--- Makefile.in.orig 2001-11-30 16:28:45.000000000 +0100
++++ Makefile.in 2011-03-12 23:15:59.000000000 +0100
+@@ -448,17 +448,19 @@ install uninstall-am uninstall all-redir
installdirs mostlyclean-generic distclean-generic clean-generic \
maintainer-clean-generic clean mostlyclean distclean maintainer-clean
@@ -11,4 +11,24 @@ $FreeBSD$
+ cp gtk.m4 gtk+extra.m4
files:
- @files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
+- @files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
+- echo $$p; \
+- done
+- @for subdir in $(SUBDIRS); do \
+- files=`cd $$subdir; $(MAKE) files | grep -v "make\[[1-9]\]"`; \
+- for file in $$files; do \
+- echo $$subdir/$$file; \
+- done; \
+- done
++ @files=`ls $(DISTFILES) 2> /dev/null `; for p in $$files; do \
++ echo $$p; \
++ done
++ @for subdir in $(SUBDIRS); do \
++ files=`cd $$subdir; $(MAKE) files | grep -v "make\[[1-9]\]"`; \
++ for file in $$files; do \
++ echo $$subdir/$$file; \
++ done; \
++ done
+ release:
+ rm -rf .deps */.deps
+ $(MAKE) distcheck