aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2014-03-10 22:53:49 +0800
committerkwm <kwm@FreeBSD.org>2014-03-10 22:53:49 +0800
commitf27756246f470be94e925ed1ed91cf46696d5dac (patch)
treebd369af970da45d6241beba74a5e0221db7faf4f /x11-toolkits
parent79115653f3e43065adb235ab82c487c7ee391ae0 (diff)
downloadfreebsd-ports-gnome-f27756246f470be94e925ed1ed91cf46696d5dac.tar.gz
freebsd-ports-gnome-f27756246f470be94e925ed1ed91cf46696d5dac.tar.zst
freebsd-ports-gnome-f27756246f470be94e925ed1ed91cf46696d5dac.zip
Disable gnome-panel support. gnome-panel will be updated to a incompatible
version in the near future. While here stagify and use new lib_depends syntax.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gai/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/x11-toolkits/gai/Makefile b/x11-toolkits/gai/Makefile
index bd81846a728f..26e06f5db31a 100644
--- a/x11-toolkits/gai/Makefile
+++ b/x11-toolkits/gai/Makefile
@@ -3,22 +3,23 @@
PORTNAME= gai
PORTVERSION= 0.5.10
-PORTREVISION= 13
+PORTREVISION= 14
CATEGORIES= x11-toolkits gnome
MASTER_SITES= SF/${PORTNAME}/GAI%20-%20Library/${PORTNAME}-${PORTVERSION}
MAINTAINER= lx@redundancy.redundancy.org
COMMENT= General Applet Interface Library
-LIB_DEPENDS= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
USE_BZIP2= yes
USES= pkgconfig
USE_GL= gl
USE_SDL= sdl
-USE_GNOME= gnomepanel libgnomeui
+USE_GNOME= libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= SDLCONF=${SDL_CONFIG}
+CONFIGURE_ARGS= --disable-gnome
CPPFLAGS+= `pkg-config --cflags libgnomeui-2.0`
PLIST_FILES= include/gai/gai.h lib/libgai.so.${PORTVERSION} \
@@ -28,7 +29,6 @@ PLIST_DIRS= include/gai
PORTDOCS= *
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e "s|sdl-config --|${SDL_CONFIG} --|g; \
s|/usr/X11R6|${LOCALBASE}|g" ${WRKSRC}/configure
@@ -36,17 +36,17 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
cd ${WRKSRC}/docs && \
- ${FIND} * -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
- ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+ ${FIND} * -type d -exec ${MKDIR} "${STAGEDIR}${DOCSDIR}/{}" \; && \
+ ${FIND} * -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${DOCSDIR}/{}" \;
.endif
.for dir in docking examples templates
cd ${WRKSRC} && \
- ${FIND} ${dir} -type d -exec ${MKDIR} "${EXAMPLESDIR}/{}" \; && \
- ${FIND} ${dir} -type f -exec ${INSTALL_DATA} "{}" "${EXAMPLESDIR}/{}" \;
+ ${FIND} ${dir} -type d -exec ${MKDIR} "${STAGEDIR}${EXAMPLESDIR}/{}" \; && \
+ ${FIND} ${dir} -type f -exec ${INSTALL_DATA} "{}" "${STAGEDIR}${EXAMPLESDIR}/{}" \;
.endfor
- @${FIND} ${EXAMPLESDIR} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${EXAMPLESDIR} -type d | ${SORT} -r | \
- ${SED} "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type f | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${EXAMPLESDIR} -type d | ${SORT} -r | \
+ ${SED} "s,^${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST}
.include <bsd.port.mk>