aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-07-23 18:28:03 +0800
committertijl <tijl@FreeBSD.org>2014-07-23 18:28:03 +0800
commitffbef41617a13ad3e9a79df15b02c3ae51cee136 (patch)
tree544858c7e8531f55637ace19f7fe9ce4ac601ede /x11-toolkits
parentbe5687fcd4aa53facc12b059c5a25986711524cd (diff)
downloadfreebsd-ports-gnome-ffbef41617a13ad3e9a79df15b02c3ae51cee136.tar.gz
freebsd-ports-gnome-ffbef41617a13ad3e9a79df15b02c3ae51cee136.tar.zst
freebsd-ports-gnome-ffbef41617a13ad3e9a79df15b02c3ae51cee136.zip
Remove two libtool fixes from Mk/Uses/libtool.mk. They don't always work
when an older version of a package is installed. This is the case when an executable links with installed libraries and with uninstalled libraries that link with other uninstalled libraries. For each of the directly linked libraries the executable will have an rpath (/usr/local/lib for the installed libraries and a path under WRKDIR for each of the uninstalled libraries), but not for the indirect libraries. Both ld(1) and rtld(1) search the rpath of the executable first before any rpath of libraries, so the indirectly linked libraries will be found in /usr/local/lib if they are installed instead of in WRKDIR. With this commit executables will overlink with uninstalled indirect libraries again so their location is added to the rpath of the executable. This partially reverts r358784. PR: 191611 Approved by: portmgr (bapt)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gdl/Makefile4
-rw-r--r--x11-toolkits/libgdiplus/Makefile5
-rw-r--r--x11-toolkits/open-motif/Makefile62
3 files changed, 0 insertions, 71 deletions
diff --git a/x11-toolkits/gdl/Makefile b/x11-toolkits/gdl/Makefile
index c1b0b3462254..fe51f85de348 100644
--- a/x11-toolkits/gdl/Makefile
+++ b/x11-toolkits/gdl/Makefile
@@ -19,8 +19,4 @@ CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-post-patch:
- @${REINPLACE_CMD} '/^test_dock_LDADD =/s/$$/ $$(GDL_DEPENDENCIES_LIBS)/' \
- ${WRKSRC}/gdl/Makefile.in
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/libgdiplus/Makefile b/x11-toolkits/libgdiplus/Makefile
index 0722ea319375..9a233c3f9e90 100644
--- a/x11-toolkits/libgdiplus/Makefile
+++ b/x11-toolkits/libgdiplus/Makefile
@@ -31,9 +31,4 @@ PLIST_FILES= lib/libgdiplus.a \
lib/libgdiplus.so.0.0.0 \
libdata/pkgconfig/libgdiplus.pc
-post-patch:
- @${REINPLACE_CMD} \
- '/^testgdi_LDADD =/s/$$/ $$(BASE_DEPENDENCIES_LIBS) -lX11/' \
- ${WRKSRC}/tests/Makefile.in
-
.include <bsd.port.mk>
diff --git a/x11-toolkits/open-motif/Makefile b/x11-toolkits/open-motif/Makefile
index 37425b0f10c0..e57e198cab25 100644
--- a/x11-toolkits/open-motif/Makefile
+++ b/x11-toolkits/open-motif/Makefile
@@ -50,68 +50,6 @@ post-patch:
${XARGS} ${REINPLACE_CMD} -e 's|special file|5| ; \
s|file formats|5|'
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/configure.ac
- @${REINPLACE_CMD} '/^mwm_LDADD =/s/$$/ -lXt -lXext -lX11/' \
- ${WRKSRC}/clients/mwm/Makefile.am
- @${REINPLACE_CMD} '/^uil_LDADD =/s/$$/ -lXt/' \
- ${WRKSRC}/clients/uil/Makefile.am
- @${REINPLACE_CMD} '/^LDADD =/s/\\*$$/ -lXt -lX11 &/' \
- ${WRKSRC}/clients/xmbind/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch05/Scale/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch06/combo_box/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch06/spin_box/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch08/Container/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch08/Notebook/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch16/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch17/simple_drag/Makefile.am \
- ${WRKSRC}/demos/doc/programGuide/ch17/simple_drop/Makefile.am \
- ${WRKSRC}/demos/programs/ColorSel/Makefile.am \
- ${WRKSRC}/demos/programs/Column/Makefile.am \
- ${WRKSRC}/demos/programs/Exm/simple_app/Makefile.am \
- ${WRKSRC}/demos/programs/Ext18List/Makefile.am \
- ${WRKSRC}/demos/programs/IconB/Makefile.am \
- ${WRKSRC}/demos/programs/TabStack/Makefile.am \
- ${WRKSRC}/demos/programs/Tree/Makefile.am \
- ${WRKSRC}/demos/programs/airport/Makefile.am \
- ${WRKSRC}/demos/programs/animate/Makefile.am \
- ${WRKSRC}/demos/programs/drag_and_drop/Makefile.am \
- ${WRKSRC}/demos/programs/draw/Makefile.am \
- ${WRKSRC}/demos/programs/filemanager/Makefile.am \
- ${WRKSRC}/demos/programs/fileview/Makefile.am \
- ${WRKSRC}/demos/programs/getsubres/Makefile.am \
- ${WRKSRC}/demos/programs/i18ninput/Makefile.am \
- ${WRKSRC}/demos/programs/panner/Makefile.am \
- ${WRKSRC}/demos/programs/periodic/Makefile.am \
- ${WRKSRC}/demos/programs/piano/Makefile.am \
- ${WRKSRC}/demos/programs/popups/Makefile.am \
- ${WRKSRC}/demos/programs/sampler2_0/Makefile.am \
- ${WRKSRC}/demos/programs/setdate/Makefile.am \
- ${WRKSRC}/demos/programs/workspace/Makefile.am \
- ${WRKSRC}/demos/unsupported/aicon/Makefile.am \
- ${WRKSRC}/demos/unsupported/dainput/Makefile.am \
- ${WRKSRC}/demos/unsupported/dogs/Makefile.am \
- ${WRKSRC}/demos/unsupported/motifshell/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmapdef/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmfonts/Makefile.am
- @${REINPLACE_CMD} '/^LDADD =/s/$$/ -lXt/' \
- ${WRKSRC}/demos/lib/Exm/wml/Makefile.am \
- ${WRKSRC}/demos/lib/Xmd/Makefile.am \
- ${WRKSRC}/demos/programs/ButtonBox/Makefile.am \
- ${WRKSRC}/demos/programs/Combo2/Makefile.am \
- ${WRKSRC}/demos/programs/FontSel/Makefile.am \
- ${WRKSRC}/demos/programs/Outline/Makefile.am \
- ${WRKSRC}/demos/programs/Paned/Makefile.am \
- ${WRKSRC}/demos/programs/hellomotif/Makefile.am \
- ${WRKSRC}/demos/programs/hellomotifi18n/Makefile.am \
- ${WRKSRC}/demos/programs/tooltips/Makefile.am \
- ${WRKSRC}/demos/unsupported/hellomotif/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmforc/Makefile.am \
- ${WRKSRC}/demos/unsupported/xmform/Makefile.am
- @${REINPLACE_CMD} '/^LDADD =/s/\\*$$/ -lXt -lXext -lX11 &/' \
- ${WRKSRC}/demos/programs/Exm/app_in_c/Makefile.am \
- ${WRKSRC}/demos/programs/earth/Makefile.am \
- ${WRKSRC}/demos/programs/todo/Makefile.am
- @${REINPLACE_CMD} '/^wmldbcreate_LDADD =/s/$$/ -lXt/' \
- ${WRKSRC}/tools/wml/Makefile.am
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}