aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-03-25 09:46:10 +0800
committerijliao <ijliao@FreeBSD.org>2004-03-25 09:46:10 +0800
commit025aef844a5665442d9376e586c3e115d48af710 (patch)
tree5c58eea8f363e472278b8b1f213d2ad97861fe00 /x11-toolkits
parent194b19e1eaab48a72d9a0d770b3050ea20fef25e (diff)
downloadfreebsd-ports-gnome-025aef844a5665442d9376e586c3e115d48af710.tar.gz
freebsd-ports-gnome-025aef844a5665442d9376e586c3e115d48af710.tar.zst
freebsd-ports-gnome-025aef844a5665442d9376e586c3e115d48af710.zip
better way to fix build problem on -stable
Submitted by: olker Stolz <stolz@i2.informatik.rwth-aachen.de>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/inti/Makefile4
-rw-r--r--x11-toolkits/inti/files/patch-configure11
2 files changed, 13 insertions, 2 deletions
diff --git a/x11-toolkits/inti/Makefile b/x11-toolkits/inti/Makefile
index d99faca0f158..2bc73130227d 100644
--- a/x11-toolkits/inti/Makefile
+++ b/x11-toolkits/inti/Makefile
@@ -16,9 +16,9 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A set of C++ classes for developing GNOME and GTK+ applications
USE_GNOME= glib20 gtk20 atk pango gnomehack gnomeprefix
-USE_GCC= 3.3
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
+CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
PLIST_FILES= bin/inti-demo \
diff --git a/x11-toolkits/inti/files/patch-configure b/x11-toolkits/inti/files/patch-configure
new file mode 100644
index 000000000000..1b8e49ea823c
--- /dev/null
+++ b/x11-toolkits/inti/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Wed Mar 24 10:00:38 2004
++++ configure Wed Mar 24 10:00:48 2004
+@@ -18775,7 +18775,7 @@
+ if test "x$GCC" = "xyes"; then
+ case " $CXXFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+- *) CXXFLAGS="$CXXFLAGS -Wall -ansi -pedantic-errors" ;;
++ *) CXXFLAGS="$CXXFLAGS -Wall -ansi" ;;
+ esac
+ fi
+