aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorfluffy <fluffy@FreeBSD.org>2010-05-11 18:43:10 +0800
committerfluffy <fluffy@FreeBSD.org>2010-05-11 18:43:10 +0800
commit047c5dc3ed506f926511002f3cbf5e8d2d32bf6c (patch)
treeac5f20c985d806fe0160460fdaadbbed44ca0a97 /x11-toolkits
parent31319b4c08a3200ebff8c4578fd63981a72a5657 (diff)
downloadfreebsd-ports-gnome-047c5dc3ed506f926511002f3cbf5e8d2d32bf6c.tar.gz
freebsd-ports-gnome-047c5dc3ed506f926511002f3cbf5e8d2d32bf6c.tar.zst
freebsd-ports-gnome-047c5dc3ed506f926511002f3cbf5e8d2d32bf6c.zip
- The FreeBSD KDE team is pleased to announce SIP-4.10.2, PyQt-4.7.3
and QScintilla-2.4.3 for FreeBSD. With hat on: kde@
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-kde/Makefile4
-rw-r--r--x11-toolkits/py-qt/Makefile4
-rw-r--r--x11-toolkits/py-qt/files/patch-configure.py9
-rw-r--r--x11-toolkits/py-qt4-gui/Makefile9
-rw-r--r--x11-toolkits/py-qt4-gui/distinfo6
5 files changed, 9 insertions, 23 deletions
diff --git a/x11-toolkits/py-kde/Makefile b/x11-toolkits/py-kde/Makefile
index 24258ce3dc00..77c0f90c4e2f 100644
--- a/x11-toolkits/py-kde/Makefile
+++ b/x11-toolkits/py-kde/Makefile
@@ -35,7 +35,7 @@ OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
ARGS= -i -k ${LOCALBASE} -v ${DATADIR} -d ${PYTHON_SITELIBDIR}
.include "../../devel/py-sip/files/bsd.pyqt.mk"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
ARGS+= -u
@@ -98,4 +98,4 @@ post-install:
${INSTALL_DATA} basic/* ${EXAMPLESDIR}/templates/basic
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt/Makefile b/x11-toolkits/py-qt/Makefile
index 468712a81e3c..9e295180606d 100644
--- a/x11-toolkits/py-qt/Makefile
+++ b/x11-toolkits/py-qt/Makefile
@@ -38,7 +38,7 @@ ARGS= -b ${PREFIX}/bin -d ${PYTHON_SITELIBDIR}\
MODULES= qt qtcanvas qtnetwork qttable qtxml qtui qtsql qtext
.include "../../devel/py-sip/files/bsd.pyqt.mk"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
ARGS+= -u
@@ -98,4 +98,4 @@ post-install:
${INSTALL_DATA} webbrowser/* ${EXAMPLESDIR}/webbrowser
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt/files/patch-configure.py b/x11-toolkits/py-qt/files/patch-configure.py
index b0489c79e591..f42fc0938f36 100644
--- a/x11-toolkits/py-qt/files/patch-configure.py
+++ b/x11-toolkits/py-qt/files/patch-configure.py
@@ -1,14 +1,5 @@
--- configure.py.orig Sun May 13 20:08:01 2007
+++ configure.py Sun May 13 20:14:01 2007
-@@ -107,7 +107,7 @@
- sys.stdout.write(" -a tag explicitly enable the qtpe module\n")
- sys.stdout.write(" -b dir where pyuic and pylupdate will be installed [default %s]\n" % opt_pyqtbindir)
- sys.stdout.write(" -c concatenate each module's C/C++ source files\n")
-- sys.stdout.write(" -d dir where the PyQt modules will be installed [default %\ns]" % opt_pyqtmoddir)
-+ sys.stdout.write(" -d dir where the PyQt modules will be installed [default %s]\n" % opt_pyqtmoddir)
- sys.stdout.write(" -f keep any existing features file (when cross-compiling) [default remove]\n")
- sys.stdout.write(" -g dir where the Qt qconfig.h file can be found [default Qt include directory]\n")
- sys.stdout.write(" -i enable checking of signed interpreters using the VendorID package [default disabled]\n")
@@ -1081,15 +1081,12 @@
macros["LIBDIR_QT"] = qt_libdir
diff --git a/x11-toolkits/py-qt4-gui/Makefile b/x11-toolkits/py-qt4-gui/Makefile
index 0fc300cc5851..29ef10f2349c 100644
--- a/x11-toolkits/py-qt4-gui/Makefile
+++ b/x11-toolkits/py-qt4-gui/Makefile
@@ -6,7 +6,6 @@
PORTNAME= gui
PORTVERSION= ${PYQT4_VERSION}
-PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= x11-toolkits devel python
MASTER_SITES= ${MASTER_SITES_PYQT4}
@@ -42,7 +41,7 @@ ARGS= -b ${PREFIX}/bin\
--enable QtGui
.include "../../devel/py-sip/files/bsd.pyqt.mk"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_DEBUG)
ARGS+= --debug
@@ -70,10 +69,6 @@ ARGS+= --trace
BROKEN= Does not compile on sparc64
.endif
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
-
do-configure:
cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV}\
${PYTHON_CMD} configure.py ${ARGS}
@@ -85,4 +80,4 @@ post-configure:
-e 's|LINK = c++|LINK = ${CXX}|'\
${WRKSRC}/QtGui/Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/py-qt4-gui/distinfo b/x11-toolkits/py-qt4-gui/distinfo
index a5eccc57a770..9a0976bb9c38 100644
--- a/x11-toolkits/py-qt4-gui/distinfo
+++ b/x11-toolkits/py-qt4-gui/distinfo
@@ -1,3 +1,3 @@
-MD5 (PyQt-x11-gpl-4.7.tar.gz) = 4882179ab4da128aaa8520f146afb955
-SHA256 (PyQt-x11-gpl-4.7.tar.gz) = 7fee05d926f33c290544965960262f1866256d95021332f8ab6918fe22419743
-SIZE (PyQt-x11-gpl-4.7.tar.gz) = 7888435
+MD5 (PyQt-x11-gpl-4.7.3.tar.gz) = 42fdda73f07810abba002af8a939ee50
+SHA256 (PyQt-x11-gpl-4.7.3.tar.gz) = 574ad672b4171272028c49d5867087db04287c4dc7be8af17d71542db3a8225c
+SIZE (PyQt-x11-gpl-4.7.3.tar.gz) = 7803557