aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-07-26 04:43:12 +0800
committermarcus <marcus@FreeBSD.org>2004-07-26 04:43:12 +0800
commitba3c2394a02b277c8853f84dcb12fb6c6210be53 (patch)
treed5a912cccc6d59964f0a6e9dd3673db65de34167 /x11-toolkits
parent1b1e7dc74db11ce1ac3582b48188f0e9f741a57e (diff)
downloadfreebsd-ports-gnome-ba3c2394a02b277c8853f84dcb12fb6c6210be53.tar.gz
freebsd-ports-gnome-ba3c2394a02b277c8853f84dcb12fb6c6210be53.tar.zst
freebsd-ports-gnome-ba3c2394a02b277c8853f84dcb12fb6c6210be53.zip
* Fix detection of i18n support [1]
* Use the new libtool scheme Reported by: Rui Lopes <rui@ruilopes.com> [1]
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-gtk2/Makefile8
-rw-r--r--x11-toolkits/py-gtk2/files/patch-configure10
-rw-r--r--x11-toolkits/py-gtk2/files/patch-ltmain.sh19
3 files changed, 6 insertions, 31 deletions
diff --git a/x11-toolkits/py-gtk2/Makefile b/x11-toolkits/py-gtk2/Makefile
index 6eb3862064d6..bfa643ea5972 100644
--- a/x11-toolkits/py-gtk2/Makefile
+++ b/x11-toolkits/py-gtk2/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gtk
PORTVERSION= 2.2.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= x11-toolkits python
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/pygtk/2.2
@@ -23,7 +23,11 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnometarget libglade2
USE_PYTHON= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
+USE_GETTEXT= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-lintl"
+LDFLAGS+= -L${LOCALBASE}/lib
EG_SRC_DIR= ${WRKSRC}/examples
EG_DST_DIR= ${PREFIX}/share/examples/py-gtk
diff --git a/x11-toolkits/py-gtk2/files/patch-configure b/x11-toolkits/py-gtk2/files/patch-configure
deleted file mode 100644
index db094d10bcf0..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Sun Mar 23 21:43:20 2003
-+++ configure Sun Mar 23 21:43:42 2003
-@@ -7958,6 +7958,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11-toolkits/py-gtk2/files/patch-ltmain.sh b/x11-toolkits/py-gtk2/files/patch-ltmain.sh
deleted file mode 100644
index 7cefa767ece6..000000000000
--- a/x11-toolkits/py-gtk2/files/patch-ltmain.sh
+++ /dev/null
@@ -1,19 +0,0 @@
---- ltmain.sh.orig Sun Mar 23 21:36:18 2003
-+++ ltmain.sh Sun Mar 23 21:38:57 2003
-@@ -1085,8 +1085,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-