aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-01-08 15:06:24 +0800
committerbapt <bapt@FreeBSD.org>2013-01-08 15:06:24 +0800
commit424941746fab63c1edfc32ba5e7c221f2cfa52e3 (patch)
treea7b4bed52842c2ad668f11ae7f5f5d4d02c1df8b /x11-toolkits
parent2d7d02066042eb68dc50872da09cf7eb6bfb0b41 (diff)
downloadfreebsd-ports-gnome-424941746fab63c1edfc32ba5e7c221f2cfa52e3.tar.gz
freebsd-ports-gnome-424941746fab63c1edfc32ba5e7c221f2cfa52e3.tar.zst
freebsd-ports-gnome-424941746fab63c1edfc32ba5e7c221f2cfa52e3.zip
Convert last python@ ports to new options framework
for both make options work as expected (previous version were missing include <bsd.port.options.mk>) for databases/py-pyPgSQL reverse the logic for the option test so that it actually works as expected Approved by: python (crees)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/py-gui/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/x11-toolkits/py-gui/Makefile b/x11-toolkits/py-gui/Makefile
index 52f9fc3e4994..73fa9518bd67 100644
--- a/x11-toolkits/py-gui/Makefile
+++ b/x11-toolkits/py-gui/Makefile
@@ -1,7 +1,4 @@
-# Ports collection makefile for: py-gui
-# Date created: 21 June 2004
-# Whom: Hye-Shik Chang
-#
+# Created by: Hye-Shik Chang
# $FreeBSD$
PORTNAME= gui
@@ -32,11 +29,12 @@ LATEST_LINK= py-${PORTNAME}
WRKSRC= ${WRKDIR}/PyGUI-${PORTVERSION}
-OPTIONS= GL "Enable GL support" off
+OPTIONS_DEFINE= OPENGL DOCS
+OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_GL)
+.if ${PORT_OPTIONS:MOPENGL}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/gtk-2.0/gtk/gdkgl/__init__.py:${PORTSDIR}/x11-toolkits/py-gtkglext
.endif
@@ -49,7 +47,7 @@ post-patch:
${REINPLACE_CMD} -e 's/"GUI.Cocoa",//g' ${WRKSRC}/setup.py
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${PREFIX}/${DOCSDIR}
${TAR} -C ${WRKSRC}/Doc -cf - . | ${TAR} -C ${PREFIX}/${DOCSDIR} -xf -
${MKDIR} ${PREFIX}/${EXAMPLESDIR}
@@ -59,4 +57,4 @@ post-install:
${TAR} -C ${PREFIX}/${EXAMPLESDIR} -xf -
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>