aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-09-05 21:40:43 +0800
committerdemon <demon@FreeBSD.org>2003-09-05 21:40:43 +0800
commit69ee14275b93148e63616a97dec1f34722486c0c (patch)
treee37a894b0a812841652a43ebb2ccc931b1d01b76 /x11-toolkits
parentfafd6fae90628f9f9020c8d61ff7961b901d1849 (diff)
downloadfreebsd-ports-gnome-69ee14275b93148e63616a97dec1f34722486c0c.tar.gz
freebsd-ports-gnome-69ee14275b93148e63616a97dec1f34722486c0c.tar.zst
freebsd-ports-gnome-69ee14275b93148e63616a97dec1f34722486c0c.zip
Add WITH_THREADS knob to compile with threads support.
Submitted by: dave <dave@gufi.org>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fltk/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11-toolkits/fltk/Makefile b/x11-toolkits/fltk/Makefile
index a21056c4d4ed..4e224fd2d764 100644
--- a/x11-toolkits/fltk/Makefile
+++ b/x11-toolkits/fltk/Makefile
@@ -40,6 +40,10 @@ CONFIGURE_ENV= CXXFLAGS=-DUSE_XUNICODE
_PORTVERSION+= ${VERSION}
.endif
+.if defined(WITH_THREADS)
+CONFIGURE_ARGS+=--enable-threads
+.endif
+
VERSION= 1.1.3
USE_BZIP2= yes
INSTALLS_SHLIB= yes
@@ -59,4 +63,8 @@ post-extract:
cd ${WRKSRC} && ${LN} -s ${X11BASE}/include/xunicode
.endif
+pre-everything::
+ @${ECHO_MSG} "===> You can enable threads support by defining WITH_THREADS"
+ @${ECHO_MSG} "===>"
+
.include <bsd.port.mk>