aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-09-04 00:13:25 +0800
committerdinoex <dinoex@FreeBSD.org>2011-09-04 00:13:25 +0800
commit7a4b8cf822d415fe7a589e6717785fb00fbfa452 (patch)
tree91bd4f89f3a78362b9a1043f9643cba7057fcbda /x11-toolkits
parent7fc9098934be60fb0d7bdb9bce1b85efc8d184c9 (diff)
downloadfreebsd-ports-gnome-7a4b8cf822d415fe7a589e6717785fb00fbfa452.tar.gz
freebsd-ports-gnome-7a4b8cf822d415fe7a589e6717785fb00fbfa452.tar.zst
freebsd-ports-gnome-7a4b8cf822d415fe7a589e6717785fb00fbfa452.zip
- Security fix for reading GIF images
Security: CVE-2007-5137
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/tk83/Makefile2
-rw-r--r--x11-toolkits/tk83/files/patch-tkImgGIF.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/x11-toolkits/tk83/Makefile b/x11-toolkits/tk83/Makefile
index d43a0f370b92..79cc4dc1eb14 100644
--- a/x11-toolkits/tk83/Makefile
+++ b/x11-toolkits/tk83/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tk
PORTVERSION= 8.3.5
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= x11-toolkits tk
MASTER_SITES= SF/tcl/Tcl/${PORTVERSION}
DISTNAME= ${PORTNAME}${PORTVERSION}-src
diff --git a/x11-toolkits/tk83/files/patch-tkImgGIF.c b/x11-toolkits/tk83/files/patch-tkImgGIF.c
new file mode 100644
index 000000000000..c70dcae78556
--- /dev/null
+++ b/x11-toolkits/tk83/files/patch-tkImgGIF.c
@@ -0,0 +1,11 @@
+--- ../generic/tkImgGIF.c 2002-03-26 03:29:01.000000000 +0100
++++ ../generic/tkImgGIF.new.c 2007-10-04 20:40:09.000000000 +0200
+@@ -960,7 +960,7 @@
+ /* If interlacing, the next ypos is not just +1 */
+ if (interlace) {
+ ypos += interlaceStep[pass];
+- while (ypos >= height) {
++ while (ypos >= rows) {
+ pass++;
+ if (pass > 3) {
+ return TCL_OK;