aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorlkoeller <lkoeller@FreeBSD.org>2000-12-24 20:55:37 +0800
committerlkoeller <lkoeller@FreeBSD.org>2000-12-24 20:55:37 +0800
commit7f4f0a16207baecca8ee931258dbb24ac997f158 (patch)
tree2726a1927f88b219047a9d52e000bed576fd02bd /x11-toolkits
parent57b9c6c1124d8dd48a0a52f93e27730cdd89f0f7 (diff)
downloadfreebsd-ports-gnome-7f4f0a16207baecca8ee931258dbb24ac997f158.tar.gz
freebsd-ports-gnome-7f4f0a16207baecca8ee931258dbb24ac997f158.tar.zst
freebsd-ports-gnome-7f4f0a16207baecca8ee931258dbb24ac997f158.zip
Update to version 1.1.7, needed be grace-5.1.2. Alas the imake build of the
source tree is toally broken: It's necessary to use the Makefiles and do the install by "hand" with manually callinmg libtool, etc. PR: ports/20464, ports/20577, ports/21836
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/xmhtml/Makefile38
1 files changed, 28 insertions, 10 deletions
diff --git a/x11-toolkits/xmhtml/Makefile b/x11-toolkits/xmhtml/Makefile
index f0fb5afce108..5ef806e32ab4 100644
--- a/x11-toolkits/xmhtml/Makefile
+++ b/x11-toolkits/xmhtml/Makefile
@@ -6,27 +6,38 @@
#
PORTNAME= XmHTML
-PORTVERSION= 1.1.0
+PORTVERSION= 1.1.7
CATEGORIES= x11-toolkits www
-MASTER_SITES= ftp://crl.nmsu.edu/pub/XmHTML/ \
- ftp://ftp.ist.co.uk/pub/motif/XmHTML/ \
- ftp://ftp.nerdnet.nl/pub/X11/Widgets/XmHTML/
+MASTER_SITES= http://www.xs4all.nl/~ripley/XmHTML/dist/
-PATCH_SITES= ftp://crl.nmsu.edu/pub/XmHTML/
-PATCHFILES= patch-102697.gz
-
-MAINTAINER= thepish@freebsd.org
+MAINTAINER= Lars.Koeller@Uni-Bielefeld.de
LIB_DEPENDS= png.4:${PORTSDIR}/graphics/png \
jpeg.9:${PORTSDIR}/graphics/jpeg
+REQUIRES_MOTIF= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+USE_X_PREFIX= yes
USE_MOTIF= yes
-USE_IMAKE= yes
-XMKMF= PORTOBJFORMAT=${PORTOBJFORMAT} xmkmf -a
+
+INSTALLS_SHLIB= yes
+
+EXMP_DIR= ${X11BASE}/share/examples/${DISTNAME}/
+DOCS_DIR= ${X11BASE}/share/doc/${DISTNAME}/
EXMP_DIR= ${PREFIX}/share/examples/${DISTNAME}/
DOCS_DIR= ${PREFIX}/share/doc/${DISTNAME}/
+post-patch:
+ ${TOUCH} ${WRKSRC}/configure
+ ${CHMOD} 755 ${WRKSRC}/configure
+
+post-build:
+ ${RM} -rf ${WRKSRC}/examples/.libs ${WRKSRC}/examples/*.lo ${WRKSRC}/examples/*.o
+ ${RM} -rf ${WRKSRC}/book/.libs ${WRKSRC}/book/*.lo ${WRKSRC}/book/*.o
+ ${RM} -rf ${WRKSRC}/contrib/.libs ${WRKSRC}/contrib/*.lo ${WRKSRC}/contrib/*.o
+
pre-install:
${ECHO} "installing examples into ${EXMP_DIR}"
@ ${MKDIR} ${EXMP_DIR}
@@ -35,6 +46,13 @@ pre-install:
@ ${MKDIR} ${DOCS_DIR}
@ (cd ${WRKSRC}/html; tar -cpf- * | tar -xvpf- -C ${DOCS_DIR} )
+do-install:
+ ${LIBTOOL} --mode=install ${INSTALL_DATA} \
+ ${WRKSRC}/lib/libXmHTML.la ${X11BASE}/lib
+ ${RM} -f ${X11BASE}/lib/libXmHTML.la
+ ${MKDIR} ${X11BASE}/include/XmHTML
+ ${INSTALL_DATA} ${WRKSRC}/include/XmHTML/*.h ${X11BASE}/include/XmHTML
+
post-install:
@ ${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib