aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2003-02-08 08:16:15 +0800
committerlioux <lioux@FreeBSD.org>2003-02-08 08:16:15 +0800
commit82983e5d61937374d8f0b89819580dcbaf7cc427 (patch)
tree0276a46d74b54461909e2b576f2a677a20f221b0 /x11-toolkits
parent26f77cd9c7bc4d7db9b0e13b7fa9d2bbcf6917cb (diff)
downloadfreebsd-ports-gnome-82983e5d61937374d8f0b89819580dcbaf7cc427.tar.gz
freebsd-ports-gnome-82983e5d61937374d8f0b89819580dcbaf7cc427.tar.zst
freebsd-ports-gnome-82983e5d61937374d8f0b89819580dcbaf7cc427.zip
o After being repo copied to fox-devel port:
- Add a conflict management mechanism: do not install port if fox-devel port is already installed Repo copy performed by: cvs (joe)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox/Makefile13
-rw-r--r--x11-toolkits/fox10/Makefile13
2 files changed, 24 insertions, 2 deletions
diff --git a/x11-toolkits/fox/Makefile b/x11-toolkits/fox/Makefile
index 0046bc81b46f..5e644c9a959d 100644
--- a/x11-toolkits/fox/Makefile
+++ b/x11-toolkits/fox/Makefile
@@ -133,4 +133,15 @@ pre-everything::
.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+##
+## Port conflict management
+##
+.if exists(${LOCALBASE}/lib/libFOX-1.1.so)
+IGNORE= Conflict management: you have port fox-devel installed. The\
+ fox port is incompatible with fox-devel one. You have to\
+ uninstall fox-devel port if you really need the fox one
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index 0046bc81b46f..5e644c9a959d 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -133,4 +133,15 @@ pre-everything::
.endif
@${ECHO_MSG}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+##
+## Port conflict management
+##
+.if exists(${LOCALBASE}/lib/libFOX-1.1.so)
+IGNORE= Conflict management: you have port fox-devel installed. The\
+ fox port is incompatible with fox-devel one. You have to\
+ uninstall fox-devel port if you really need the fox one
+.endif
+
+.include <bsd.port.post.mk>