aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-08-15 05:56:14 +0800
committermarcus <marcus@FreeBSD.org>2003-08-15 05:56:14 +0800
commitad22ef5b98216aef16cead73dee0d26743d67a88 (patch)
tree96bde37fca06d676733ef4663ab47f8cfa03a548 /x11-toolkits
parent2f1d5d26c2ce9e4844d3b2ea4311b72b73cb3685 (diff)
downloadfreebsd-ports-gnome-ad22ef5b98216aef16cead73dee0d26743d67a88.tar.gz
freebsd-ports-gnome-ad22ef5b98216aef16cead73dee0d26743d67a88.tar.zst
freebsd-ports-gnome-ad22ef5b98216aef16cead73dee0d26743d67a88.zip
Add a patch from gtk+ CVS that fixes the corrupt thumbnails in
gnome-theme-manager. Obtained from: gtk+ CVS
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gtk20/Makefile1
-rw-r--r--x11-toolkits/gtk20/files/patch-gtk_gtkwidget.c12
-rw-r--r--x11-toolkits/gtk30/Makefile1
-rw-r--r--x11-toolkits/gtk30/files/patch-gtk_gtkwidget.c12
4 files changed, 26 insertions, 0 deletions
diff --git a/x11-toolkits/gtk20/Makefile b/x11-toolkits/gtk20/Makefile
index a608a77edcc0..454d1df0acec 100644
--- a/x11-toolkits/gtk20/Makefile
+++ b/x11-toolkits/gtk20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.2,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk20/files/patch-gtk_gtkwidget.c b/x11-toolkits/gtk20/files/patch-gtk_gtkwidget.c
new file mode 100644
index 000000000000..43203977a68a
--- /dev/null
+++ b/x11-toolkits/gtk20/files/patch-gtk_gtkwidget.c
@@ -0,0 +1,12 @@
+--- gtk/gtkwidget.c.orig Thu Aug 14 17:51:56 2003
++++ gtk/gtkwidget.c Thu Aug 14 17:52:52 2003
+@@ -3041,6 +3041,9 @@
+ static gboolean
+ event_window_is_still_viewable (GdkEvent *event)
+ {
++ if (GDK_IS_PIXMAP (event->any.window))
++ return event->type == GDK_EXPOSE;
++
+ /* Check that we think the event's window is viewable before
+ * delivering the event, to prevent suprises. We do this here
+ * at the last moment, since the event may have been queued
diff --git a/x11-toolkits/gtk30/Makefile b/x11-toolkits/gtk30/Makefile
index a608a77edcc0..454d1df0acec 100644
--- a/x11-toolkits/gtk30/Makefile
+++ b/x11-toolkits/gtk30/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gtk
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= x11-toolkits
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/gtk+/2.2,} \
ftp://ftp.gtk.org/pub/gtk/v2.0/ \
diff --git a/x11-toolkits/gtk30/files/patch-gtk_gtkwidget.c b/x11-toolkits/gtk30/files/patch-gtk_gtkwidget.c
new file mode 100644
index 000000000000..43203977a68a
--- /dev/null
+++ b/x11-toolkits/gtk30/files/patch-gtk_gtkwidget.c
@@ -0,0 +1,12 @@
+--- gtk/gtkwidget.c.orig Thu Aug 14 17:51:56 2003
++++ gtk/gtkwidget.c Thu Aug 14 17:52:52 2003
+@@ -3041,6 +3041,9 @@
+ static gboolean
+ event_window_is_still_viewable (GdkEvent *event)
+ {
++ if (GDK_IS_PIXMAP (event->any.window))
++ return event->type == GDK_EXPOSE;
++
+ /* Check that we think the event's window is viewable before
+ * delivering the event, to prevent suprises. We do this here
+ * at the last moment, since the event may have been queued