aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-03-29 18:52:52 +0800
committerrafan <rafan@FreeBSD.org>2007-03-29 18:52:52 +0800
commitb0291234689e4a693270e1f2ae8e5800078132c7 (patch)
treeb26310d3575889e0ee8fac4c0b4fba81a1d2601a /x11-toolkits
parente39bfe034ac7a2cd660648b68ca120096f76ae43 (diff)
downloadfreebsd-ports-gnome-b0291234689e4a693270e1f2ae8e5800078132c7.tar.gz
freebsd-ports-gnome-b0291234689e4a693270e1f2ae8e5800078132c7.tar.zst
freebsd-ports-gnome-b0291234689e4a693270e1f2ae8e5800078132c7.zip
- Trasnfer maintainership from alecn2002@yandex.ru to
araujo@bsdmail.org except fox14 (owned by shuan@) - Correctly register CONFLICTS - While I'm here, correctly respect NOPORTDOCS Approved by: maintainer (fox10, fox12, fox16), shuan (implicit for fox14)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/fox10/Makefile13
-rw-r--r--x11-toolkits/fox12/Makefile15
-rw-r--r--x11-toolkits/fox14/Makefile13
-rw-r--r--x11-toolkits/fox16/Makefile16
4 files changed, 28 insertions, 29 deletions
diff --git a/x11-toolkits/fox10/Makefile b/x11-toolkits/fox10/Makefile
index 1c4c7b521a11..28e067596bba 100644
--- a/x11-toolkits/fox10/Makefile
+++ b/x11-toolkits/fox10/Makefile
@@ -21,6 +21,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
tiff.4:${PORTSDIR}/graphics/tiff
+CONFLICTS= fox-1.2.* fox-1.4.* fox-1.6.*
+
LATEST_LINK= fox10
USE_AUTOTOOLS= libtool:15
@@ -74,12 +76,6 @@ CXXFLAGS+= -Wuninitialized ${SPECFLAGS}
.if defined(WITH_PROFILING)
CONFIGURE_ARGS+=--with-profiling=gprof
.endif
-#
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= DOC=
-.else
-MAKE_ARGS+= DOC=doc
-.endif
post-patch:
# Remove additional flags
@@ -109,6 +105,11 @@ post-patch:
@${REINPLACE_CMD} -E -e \
's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/screenshots/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s/ doc//' \
+ ${WRKSRC}/Makefile.in
+.endif
.if !defined(WITH_FOX_APPLICATIONS)
@${REINPLACE_CMD} -E -e \
's,^(SUBDIRS.*)adie,\1,; \
diff --git a/x11-toolkits/fox12/Makefile b/x11-toolkits/fox12/Makefile
index 4e50c3369cf2..79c014b590af 100644
--- a/x11-toolkits/fox12/Makefile
+++ b/x11-toolkits/fox12/Makefile
@@ -12,7 +12,7 @@ MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
ftp://ftp.fox-toolkit.org/pub/ \
http://fresh.t-systems-sfr.com/unix/src/misc/
-MAINTAINER?= alecn2002@yandex.ru
+MAINTAINER?= araujo@bsdmail.org
COMMENT= Fast and extensive C++ GUI toolkit -- ver.1.2
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -20,7 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
Xft.2:${PORTSDIR}/x11-fonts/libXft
-CONFLICTS= fox-1.0.* fox-1.4.*
+CONFLICTS= fox-1.0.* fox-1.4.* fox-1.6.*
LATEST_LINK= fox12
@@ -88,12 +88,6 @@ CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-point
.if defined(WITH_PROFILING)
CONFIGURE_ARGS+= --with-profiling=gprof
.endif
-#
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= DOC=
-.else
-MAKE_ARGS+= DOC=doc
-.endif
post-patch:
# CXXFLAGS safeness
@@ -112,6 +106,11 @@ post-patch:
@${REINPLACE_CMD} -E -e \
's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/screenshots/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s/ doc//' \
+ ${WRKSRC}/Makefile.in
+.endif
.if !defined(WITH_FOX_APPLICATIONS)
@${REINPLACE_CMD} -E -e \
's,^(SUBDIRS.*)adie,\1,; \
diff --git a/x11-toolkits/fox14/Makefile b/x11-toolkits/fox14/Makefile
index 9d3cf17de9a5..4cac8aa57565 100644
--- a/x11-toolkits/fox14/Makefile
+++ b/x11-toolkits/fox14/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
Xft.2:${PORTSDIR}/x11-fonts/libXft
-CONFLICTS= fox-1.0.*
+CONFLICTS= fox-1.0.* fox-1.2.* fox-1.6.*
LATEST_LINK= fox14
@@ -96,12 +96,6 @@ CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-point
.if defined(WITH_PROFILING)
CONFIGURE_ARGS+= --with-profiling=gprof
.endif
-#
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= DOC=
-.else
-MAKE_ARGS+= DOC=doc
-.endif
post-patch:
# CXXFLAGS safeness
@@ -120,6 +114,11 @@ post-patch:
@${REINPLACE_CMD} -E -e \
's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/screenshots/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s/ doc//' \
+ ${WRKSRC}/Makefile.in
+.endif
.if !defined(WITH_FOX_APPLICATIONS)
@${REINPLACE_CMD} -E -e \
's,^(SUBDIRS.*)adie,\1,; \
diff --git a/x11-toolkits/fox16/Makefile b/x11-toolkits/fox16/Makefile
index b21fa244d54e..4437d48b2491 100644
--- a/x11-toolkits/fox16/Makefile
+++ b/x11-toolkits/fox16/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://www.fox-toolkit.org/ftp/ \
http://fresh.t-systems-sfr.com/unix/src/misc/ \
http://freebsd.unixfreunde.de/sources/
-MAINTAINER?= alecn2002@yandex.ru
+MAINTAINER?= araujo@bsdmail.org
COMMENT= Fast and extensive C++ GUI toolkit -- ver.1.6
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -21,7 +21,8 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
Xft.2:${PORTSDIR}/x11-fonts/libXft
-CONFLICTS= fox-1.0.* fox-1.4.* fox-1.2.*
+CONFLICTS= fox-1.0.* fox-1.2.* fox-1.4.*
+
LATEST_LINK= fox16
MAJORVER= 1.6
@@ -91,12 +92,6 @@ CXXFLAGS+= -O2 -Wuninitialized -ffast-math -finline-functions -fomit-frame-point
.if defined(WITH_PROFILING)
CONFIGURE_ARGS+= --with-profiling=gprof
.endif
-#
-.if defined(NOPORTDOCS)
-MAKE_ARGS+= DOC=
-.else
-MAKE_ARGS+= DOC=doc
-.endif
post-patch:
# CXXFLAGS safeness
@@ -115,6 +110,11 @@ post-patch:
@${REINPLACE_CMD} -E -e \
's|^(screenshotsdir).*$$|\1=${DOCSDIR}/html|' \
${WRKSRC}/doc/screenshots/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e \
+ '/^SUBDIRS/s/ doc//' \
+ ${WRKSRC}/Makefile.in
+.endif
.if !defined(WITH_FOX_APPLICATIONS)
@${REINPLACE_CMD} -E -e \
's,^(SUBDIRS.*)adie,\1,; \