aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-01-26 05:26:25 +0800
committerrakuco <rakuco@FreeBSD.org>2014-01-26 05:26:25 +0800
commit63ee42f6688e6bc489cc6353e77a03f0af2ddcde (patch)
tree0e8a1c8380b25949fa6a896a4cd61d13bafa098f /x11-toolkits
parent2167040190c46109ae7a57a4ffc024f36a71f7dd (diff)
downloadfreebsd-ports-gnome-63ee42f6688e6bc489cc6353e77a03f0af2ddcde.tar.gz
freebsd-ports-gnome-63ee42f6688e6bc489cc6353e77a03f0af2ddcde.tar.zst
freebsd-ports-gnome-63ee42f6688e6bc489cc6353e77a03f0af2ddcde.zip
- Add a patch to fix the build with clang (a function is used before being
declared). [1] - Support staging. - Set LICENSE. - Remove tab from the WWW line in pkg-descr. PR: ports/185558 [1] Submitted by: Jan Henrik Sylvester <me@janh.de> Approved by: maintainer timeout (18 days) MFH: 2014Q1
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/sdl_pango/Makefile3
-rw-r--r--x11-toolkits/sdl_pango/files/patch-src_SDL_Pango.c14
-rw-r--r--x11-toolkits/sdl_pango/pkg-descr2
3 files changed, 17 insertions, 2 deletions
diff --git a/x11-toolkits/sdl_pango/Makefile b/x11-toolkits/sdl_pango/Makefile
index dff2c790cdf4..c29ceb9f53e9 100644
--- a/x11-toolkits/sdl_pango/Makefile
+++ b/x11-toolkits/sdl_pango/Makefile
@@ -14,6 +14,8 @@ PATCHFILES= SDL_Pango-0.1.2-API-adds.patch
MAINTAINER= edwin@mavetju.org
COMMENT= SDL_Pango is the SDL API to the Pango text rendering engine of GNOME 2.x
+LICENSE= LGPL21
+
USES= pkgconfig
USE_AUTOTOOLS= libtool
USE_SDL= sdl
@@ -21,5 +23,4 @@ USE_GNOME= pango
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/x11-toolkits/sdl_pango/files/patch-src_SDL_Pango.c b/x11-toolkits/sdl_pango/files/patch-src_SDL_Pango.c
new file mode 100644
index 000000000000..67b8ccf1a103
--- /dev/null
+++ b/x11-toolkits/sdl_pango/files/patch-src_SDL_Pango.c
@@ -0,0 +1,14 @@
+--- src/SDL_Pango.c~ 2013-12-31 14:26:31.000000000 +0000
++++ src/SDL_Pango.c 2013-12-31 14:22:36.000000000 +0000
+@@ -330,6 +330,11 @@
+ @param *rect [in] Draw on this area
+ @param baseline [in] Horizontal location of glyphs
+ */
++void SDLPango_CopyFTBitmapToSurface(
++ const FT_Bitmap *bitmap,
++ SDL_Surface *surface,
++ const SDLPango_Matrix *matrix,
++ SDL_Rect *rect);
+ static void
+ drawGlyphString(
+ SDLPango_Context *context,
diff --git a/x11-toolkits/sdl_pango/pkg-descr b/x11-toolkits/sdl_pango/pkg-descr
index 44171462c26a..d65d5511784c 100644
--- a/x11-toolkits/sdl_pango/pkg-descr
+++ b/x11-toolkits/sdl_pango/pkg-descr
@@ -14,4 +14,4 @@ your support desk. You should carefully design your installation
process.
Author: NAKAMURA Ken'ichi <nakamura@sbp.fp.a.u-tokyo.ac.jp>
-WWW: http://sdlpango.sourceforge.net/
+WWW: http://sdlpango.sourceforge.net/