aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-12-01 08:54:16 +0800
committerkris <kris@FreeBSD.org>2002-12-01 08:54:16 +0800
commitbc2560ee500dd76514bdc42b389cf904a7a6ac9b (patch)
treeeb0d12b4d49820937ff2da6620ed9cbaa779c812 /x11-toolkits
parent577cf88345164fd1aef77f01b31342dcda5dd4d2 (diff)
downloadfreebsd-ports-gnome-bc2560ee500dd76514bdc42b389cf904a7a6ac9b.tar.gz
freebsd-ports-gnome-bc2560ee500dd76514bdc42b389cf904a7a6ac9b.tar.zst
freebsd-ports-gnome-bc2560ee500dd76514bdc42b389cf904a7a6ac9b.zip
Protect targets with .if target(...) ... .endif for targets that are
redefined in slave ports. Slave port maintainers need to check that they aren't actually relying on the master port target to be executed.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gal/Makefile2
-rw-r--r--x11-toolkits/qt23/Makefile4
2 files changed, 6 insertions, 0 deletions
diff --git a/x11-toolkits/gal/Makefile b/x11-toolkits/gal/Makefile
index 1c9d9334b285..ab5895560734 100644
--- a/x11-toolkits/gal/Makefile
+++ b/x11-toolkits/gal/Makefile
@@ -33,8 +33,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_SUB= VERSION=${PORTVERSION}
+.if !target(post-patch)
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>
diff --git a/x11-toolkits/qt23/Makefile b/x11-toolkits/qt23/Makefile
index 9ff3d5ba1d32..41f9f95c107e 100644
--- a/x11-toolkits/qt23/Makefile
+++ b/x11-toolkits/qt23/Makefile
@@ -85,8 +85,10 @@ pre-fetch:
@${FALSE}
.endif
+.if !target(qt-pre-configure)
qt-pre-configure:
@true
+.endif
pre-configure: qt-pre-configure
${PERL} -pi -e "s,gcc,${CC},g; s,g\+\+,${CXX},g; \
@@ -109,6 +111,7 @@ post-configure:
# Add hack to bring in support for GL. The last line is necessary to ensure that
# one can rebuild with the same tree and get the same results.
+.if !target(do-build)
do-build:
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
.if !defined(WANT_STATIC)
@@ -122,6 +125,7 @@ do-build:
${CP} ${WRKSRC}/lib/libqt2-real.so.4 ${WRKSRC}/lib/libqt2.so.4
${CP} ${WRKSRC}/src/Makefile.orig ${WRKSRC}/src/Makefile
.endif
+.endif
# XXX: This target looks like crap now.
do-install: