aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-10-14 06:12:15 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-10-14 06:12:15 +0800
commitc3446582ed42a7d70b14d1052cd49223821b3e4a (patch)
tree37cb9ee6b565d0bdb31abef466108f1d36a71581 /x11-toolkits
parent8dc61c28573057363edf94f803e0d43eec19d70c (diff)
downloadfreebsd-ports-gnome-c3446582ed42a7d70b14d1052cd49223821b3e4a.tar.gz
freebsd-ports-gnome-c3446582ed42a7d70b14d1052cd49223821b3e4a.tar.zst
freebsd-ports-gnome-c3446582ed42a7d70b14d1052cd49223821b3e4a.zip
FXRuby is a Ruby extension module that provides an interface to the
FOX GUI library. Author: Lyle Johnson <ljohnson@resgen.com> WWW: http://fxruby.sourceforge.net/ PR: 128006 Submitted by: Luiz Eduardo Roncato Cordeiro <cordeiro at luinil dot cert dot br>
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/ruby-fox16/Makefile47
-rw-r--r--x11-toolkits/ruby-fox16/distinfo3
-rw-r--r--x11-toolkits/ruby-fox16/pkg-descr5
-rw-r--r--x11-toolkits/ruby-fox16/pkg-plist30
5 files changed, 86 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 64109cb04fdf..a087ac65fd15 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -232,6 +232,7 @@
SUBDIR += rep-gtk2
SUBDIR += ruby-fox10
SUBDIR += ruby-fox12
+ SUBDIR += ruby-fox16
SUBDIR += ruby-gnomeprintui
SUBDIR += ruby-gtk
SUBDIR += ruby-gtk2
diff --git a/x11-toolkits/ruby-fox16/Makefile b/x11-toolkits/ruby-fox16/Makefile
new file mode 100644
index 000000000000..e77bc09c0a6b
--- /dev/null
+++ b/x11-toolkits/ruby-fox16/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: FXRuby
+# Date created: 8 October 2008
+# Whom: Luiz Eduardo Roncato Cordeiro <lercordeiro@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fox
+PORTVERSION= 1.6.16
+CATEGORIES= x11-toolkits ruby
+MASTER_SITES= RF
+MASTER_SITE_SUBDIR= fxruby
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= FXRuby-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= lercordeiro@gmail.com
+COMMENT= Ruby extension module to use FOX 1.6, aka FXRuby
+
+LIB_DEPENDS= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16 \
+ png.5:${PORTSDIR}/graphics/png \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ fxscintilla.19:${PORTSDIR}/x11-toolkits/fxscintilla
+
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}12
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+NOHARM_ARGS= --no-harm
+USE_XORG= xcursor xproto x11 xextproto xext xrandr
+USE_GL= yes
+
+.include <bsd.port.pre.mk>
+
+install-noharm:
+ cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${RUBY} ${RUBY_FLAGS} ${RUBY_SETUP} install ${NOHARM_ARGS} ${RUBY_INSTALL_ARGS}
+
+post-configure:
+.if ${OSVERSION} >= 700000
+ @${REINPLACE_CMD} -e 's|CPPFLAGS = -DHAVE_SYS_TIME_H -DHAVE_SIGNAL_H -I/usr/local/include/fxscintilla -I/usr/local/include/fox-1.6|CPPFLAGS = -ffriend-injection -DHAVE_SYS_TIME_H -DHAVE_SIGNAL_H -I/usr/local/include/fxscintilla -I/usr/local/include/fox-1.6|' \
+ ${WRKSRC}/ext/fox16/Makefile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-toolkits/ruby-fox16/distinfo b/x11-toolkits/ruby-fox16/distinfo
new file mode 100644
index 000000000000..d72d8e9ab5d2
--- /dev/null
+++ b/x11-toolkits/ruby-fox16/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/FXRuby-1.6.16.tar.gz) = 2eeef754f565b820d73ac39f6492ea4c
+SHA256 (ruby/FXRuby-1.6.16.tar.gz) = d9adc6733ba57a7f877edaab5969d6e4c60c6ecea0df42f6d5afc470f99e3613
+SIZE (ruby/FXRuby-1.6.16.tar.gz) = 1810781
diff --git a/x11-toolkits/ruby-fox16/pkg-descr b/x11-toolkits/ruby-fox16/pkg-descr
new file mode 100644
index 000000000000..53388260077d
--- /dev/null
+++ b/x11-toolkits/ruby-fox16/pkg-descr
@@ -0,0 +1,5 @@
+FXRuby is a Ruby extension module that provides an interface to the
+FOX GUI library.
+
+Author: Lyle Johnson <ljohnson@resgen.com>
+WWW: http://fxruby.sourceforge.net/
diff --git a/x11-toolkits/ruby-fox16/pkg-plist b/x11-toolkits/ruby-fox16/pkg-plist
new file mode 100644
index 000000000000..1d2a7a9e72de
--- /dev/null
+++ b/x11-toolkits/ruby-fox16/pkg-plist
@@ -0,0 +1,30 @@
+%%RUBY_SITELIBDIR%%/fox16/aliases.rb
+%%RUBY_SITELIBDIR%%/fox16/bitmapview.rb
+%%RUBY_SITELIBDIR%%/fox16/calendar.rb
+%%RUBY_SITELIBDIR%%/fox16/chore.rb
+%%RUBY_SITELIBDIR%%/fox16/colors.rb
+%%RUBY_SITELIBDIR%%/fox16/core.rb
+%%RUBY_SITELIBDIR%%/fox16/dict.rb
+%%RUBY_SITELIBDIR%%/fox16/exceptions_for_fxerror.rb
+%%RUBY_SITELIBDIR%%/fox16/execute_nonmodal.rb
+%%RUBY_SITELIBDIR%%/fox16/glgroup.rb
+%%RUBY_SITELIBDIR%%/fox16/glshapes.rb
+%%RUBY_SITELIBDIR%%/fox16/input.rb
+%%RUBY_SITELIBDIR%%/fox16/irb.rb
+%%RUBY_SITELIBDIR%%/fox16/iterators.rb
+%%RUBY_SITELIBDIR%%/fox16/keys.rb
+%%RUBY_SITELIBDIR%%/fox16/kwargs.rb
+%%RUBY_SITELIBDIR%%/fox16/missingdep.rb
+%%RUBY_SITELIBDIR%%/fox16/pseudokeyboard.rb
+%%RUBY_SITELIBDIR%%/fox16/pseudomouse.rb
+%%RUBY_SITELIBDIR%%/fox16/responder.rb
+%%RUBY_SITELIBDIR%%/fox16/responder2.rb
+%%RUBY_SITELIBDIR%%/fox16/scintilla.rb
+%%RUBY_SITELIBDIR%%/fox16/settings.rb
+%%RUBY_SITELIBDIR%%/fox16/signal.rb
+%%RUBY_SITELIBDIR%%/fox16/splashscreen.rb
+%%RUBY_SITELIBDIR%%/fox16/timeout.rb
+%%RUBY_SITELIBDIR%%/fox16/undolist.rb
+%%RUBY_SITELIBDIR%%/fox16/version.rb
+%%RUBY_SITEARCHLIBDIR%%/fox16.so
+@dirrm %%RUBY_SITELIBDIR%%/fox16