aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-12-25 19:16:14 +0800
committerbapt <bapt@FreeBSD.org>2014-12-25 19:16:14 +0800
commitd226f40b1cc9100cce476f5bfaa792ed751a4866 (patch)
tree10b27c7cfcaea862047a0c2d7e0880c810f8ec06 /x11-toolkits
parent44f024f1aa98bca7c456e5644b7c195d7f144d3c (diff)
downloadfreebsd-ports-gnome-d226f40b1cc9100cce476f5bfaa792ed751a4866.tar.gz
freebsd-ports-gnome-d226f40b1cc9100cce476f5bfaa792ed751a4866.tar.zst
freebsd-ports-gnome-d226f40b1cc9100cce476f5bfaa792ed751a4866.zip
Properly support png 1.5
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/nucleo/Makefile2
-rw-r--r--x11-toolkits/nucleo/files/patch-nucleo_image_encoding_PNGenc.cxx30
2 files changed, 21 insertions, 11 deletions
diff --git a/x11-toolkits/nucleo/Makefile b/x11-toolkits/nucleo/Makefile
index 0cbae90aade5..5ea25e5fda3b 100644
--- a/x11-toolkits/nucleo/Makefile
+++ b/x11-toolkits/nucleo/Makefile
@@ -14,7 +14,7 @@ LICENSE= LGPL21
LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libexif.so:${PORTSDIR}/graphics/libexif \
- libpng15.so:${PORTSDIR}/graphics/png \
+ libpng.so:${PORTSDIR}/graphics/png \
libfreetype.so:${PORTSDIR}/print/freetype2
USES= gmake libtool pathfix pkgconfig shebangfix tar:bzip2
diff --git a/x11-toolkits/nucleo/files/patch-nucleo_image_encoding_PNGenc.cxx b/x11-toolkits/nucleo/files/patch-nucleo_image_encoding_PNGenc.cxx
index 004549d63585..6e293898b145 100644
--- a/x11-toolkits/nucleo/files/patch-nucleo_image_encoding_PNGenc.cxx
+++ b/x11-toolkits/nucleo/files/patch-nucleo_image_encoding_PNGenc.cxx
@@ -1,14 +1,24 @@
---- nucleo/image/encoding/PNGenc.cxx.orig 2008-06-05 14:52:33.000000000 +0200
-+++ nucleo/image/encoding/PNGenc.cxx 2012-05-05 08:40:18.000000000 +0200
-@@ -16,6 +16,7 @@
- #include <nucleo/image/encoding/PNGenc.H>
+--- nucleo/image/encoding/PNGenc.cxx.orig 2008-06-05 12:52:33 UTC
++++ nucleo/image/encoding/PNGenc.cxx
+@@ -35,7 +35,7 @@ namespace nucleo {
+ static void
+ png_memory_write_data(png_structp png_ptr,
+ png_bytep data, png_size_t length) {
+- png_in_memory *pim = (png_in_memory*)png_ptr->io_ptr ;
++ png_in_memory *pim = (png_in_memory*)png_get_io_ptr(png_ptr);
+
+ void *pdst = pim->data+pim->p ;
+ // std::cerr << "PNG: writing " << length << " bytes from " << (void *)data << " to " << pdst << std::endl ;
+@@ -130,7 +130,7 @@ namespace nucleo {
- #include <png.h>
-+#include <pngpriv.h>
-
- namespace nucleo {
-
-@@ -170,7 +171,7 @@
+ static void
+ png_memory_read_data(png_structp png_ptr, png_bytep data, png_size_t length) {
+- png_in_memory *pim = (png_in_memory*)png_ptr->io_ptr ;
++ png_in_memory *pim = (png_in_memory*)png_get_io_ptr(png_ptr);
+ memmove(data, pim->data+pim->p, length) ;
+ pim->p+=length ;
+ }
+@@ -170,7 +170,7 @@ namespace nucleo {
&compression_type, &filter_type) ;
if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)