aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-01-28 15:06:06 +0800
committertobik <tobik@FreeBSD.org>2019-01-28 15:06:06 +0800
commit0bf5cf28845a32e4c5eae4cf5434b71efb01151b (patch)
treefa44f5e2dd852d1c88e2f142fe976bb8a1c531cc /x11-toolkits
parent7215ed6794ba5e77373190231850ef733aa30615 (diff)
downloadfreebsd-ports-gnome-0bf5cf28845a32e4c5eae4cf5434b71efb01151b.tar.gz
freebsd-ports-gnome-0bf5cf28845a32e4c5eae4cf5434b71efb01151b.tar.zst
freebsd-ports-gnome-0bf5cf28845a32e4c5eae4cf5434b71efb01151b.zip
x11-toolkits/wxgtk30: Add NOTIFY option
Without this libnotify might be autodetected and automatically picked up if present in the build environment. - Add some missing dependencies - Pet portlint - Reset maintainer after the long timeout PR: 231399 Submitted by: avos Approved by: portmaster@bsdforge.com (maintainer timeout, ~4 months)
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/wxgtk30/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/x11-toolkits/wxgtk30/Makefile b/x11-toolkits/wxgtk30/Makefile
index a27b58f9b8f0..30d669ef777b 100644
--- a/x11-toolkits/wxgtk30/Makefile
+++ b/x11-toolkits/wxgtk30/Makefile
@@ -2,29 +2,31 @@
PORTNAME= wx
PORTVERSION= 3.0.4
-PORTREVISION= 4
DISTVERSIONPREFIX= v
+PORTREVISION= 5
CATEGORIES= x11-toolkits
PKGNAMESUFFIX= 30-gtk2
-MAINTAINER= portmaster@bsdforge.com
+MAINTAINER= ports@FreeBSD.org
COMMENT= The wxWidgets GUI toolkit with GTK+ bindings
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/docs/gpl.txt
-LIB_DEPENDS= libpng.so:graphics/png \
- libtiff.so:graphics/tiff \
- libexpat.so:textproc/expat2
+LIB_DEPENDS= libexpat.so:textproc/expat2 \
+ libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libpng.so:graphics/png \
+ libtiff.so:graphics/tiff
USE_GITHUB= yes
GH_ACCOUNT= wxWidgets
GH_PROJECT= wxWidgets
-USES= compiler:c++11-lib gmake iconv jpeg localbase pkgconfig
+USES= compiler:c++11-lib gl gmake gnome iconv jpeg localbase pkgconfig
USE_XORG= x11 sm xxf86vm xinerama
-USE_GL= glu
-USE_GNOME= gtk20
+USE_GL= gl glu
+USE_GNOME= cairo gdkpixbuf2 gtk20
USE_LDCONFIG= yes
USE_CXXSTD= c++11
GNU_CONFIGURE= yes
@@ -48,7 +50,7 @@ CONFIGURE_ARGS= --with-libpng=sys \
CONFIGURE_ENV= X11BASE="${LOCALBASE}" \
ac_cv_header_sys_inotify_h=no
-OPTIONS_DEFINE= GSTREAMER MSPACK NLS WEBKIT
+OPTIONS_DEFINE= GSTREAMER NOTIFY MSPACK NLS WEBKIT
OPTIONS_DEFAULT=GSTREAMER MSPACK WEBKIT
MSPACK_DESC= Microsoft archives support
OPTIONS_SUB= yes
@@ -58,6 +60,9 @@ NLS_USES= gettext
GSTREAMER_CONFIGURE_ENABLE= mediactrl
GSTREAMER_USE= GNOME=gconf2 GSTREAMER1=yes
+NOTIFY_CONFIGURE_WITH= libnotify
+NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+
MSPACK_CONFIGURE_WITH= libmspack
MSPACK_LIB_DEPENDS= libmspack.so:archivers/libmspack