aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2007-02-25 21:24:12 +0800
committerdinoex <dinoex@FreeBSD.org>2007-02-25 21:24:12 +0800
commit618552a7d9fe969d18e472b923cdb8755ca65325 (patch)
tree201d8e8e982788857ed55d207967cd25d8ca3b03 /x11-toolkits
parentaeb54ee2769ce0137f5e030e65574142e52e8613 (diff)
downloadfreebsd-ports-gnome-618552a7d9fe969d18e472b923cdb8755ca65325.tar.gz
freebsd-ports-gnome-618552a7d9fe969d18e472b923cdb8755ca65325.tar.zst
freebsd-ports-gnome-618552a7d9fe969d18e472b923cdb8755ca65325.zip
- new option WITH_PORTAUDIO2
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index 2296a665ec71..a8f1dbb07a10 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -38,6 +38,7 @@ USE_GNUSTEP_LDCONFIG= ${GNUSTEP_SYSTEM_LIBRARIES}
USE_XLIB= yes
EXTRA_PATCHES+= ${FILESDIR}/GNUmakefile.patch
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAKE_FLAGS+= OPTFLAG="${CFLAGS}"
BREAKS_IF_PEDANTIC= yes
@@ -49,6 +50,13 @@ IGNORE= requires procfs mounted to build or run, for details see procfs(5)
.endif
.endif
+.if defined(WITH_PORTAUDIO2)
+LIB_DEPENDS+= portaudio:${PORTSDIR}/audio/portaudio2
+CPPFLAGS+= -I${LOCALBASE}/include/portaudio2 ${PTHREAD_CFLAGS}
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib/portaudio2 ${PTHREAD_LIBS}
+.endif
+
.if !defined(WITHOUT_CUPS)
LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-base
PLIST_SUB+= WITH_CUPS=""