aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2014-10-03 02:40:10 +0800
committerrakuco <rakuco@FreeBSD.org>2014-10-03 02:40:10 +0800
commit79e629ff0f2244acbe558653989e43d173a3bffd (patch)
treeb673bef08614c39827fb3367997bbf56d76e1cd4 /x11-toolkits
parent490d95efad94f2fb00c3d72fbddf737ebf7180d6 (diff)
downloadfreebsd-ports-gnome-79e629ff0f2244acbe558653989e43d173a3bffd.tar.gz
freebsd-ports-gnome-79e629ff0f2244acbe558653989e43d173a3bffd.tar.zst
freebsd-ports-gnome-79e629ff0f2244acbe558653989e43d173a3bffd.zip
- Use a new-style helper for the special powerpc64 CFLAGS setting.
- Include only bsd.port.mk, the bsd.port.{pre,post}.mk combo is not needed here.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt4-gui/Makefile8
-rw-r--r--x11-toolkits/qt5-gui/Makefile8
2 files changed, 4 insertions, 12 deletions
diff --git a/x11-toolkits/qt4-gui/Makefile b/x11-toolkits/qt4-gui/Makefile
index 175b7c331b17..4be3bc145c9e 100644
--- a/x11-toolkits/qt4-gui/Makefile
+++ b/x11-toolkits/qt4-gui/Makefile
@@ -75,11 +75,7 @@ RUN_DEPENDS+= ${FONTSCALE}:${PORTSDIR}/x11-fonts/xorg-fonts-truetype \
${FONTENCOD}:${PORTSDIR}/x11-fonts/encodings
.endif
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == powerpc64
-CFLAGS+= -mminimal-toc
-.endif
+CFLAGS_powerpc64= -mminimal-toc
pre-configure:
${MKDIR} ${WRKSRC}/mkspecs
@@ -100,4 +96,4 @@ post-install:
${INSTALL_DATA} ${BUILD_WRKSRC}/dialogs/images/qtlogo-64.png \
${STAGEDIR}${PREFIX}/share/pixmaps/qtlogo.png
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/x11-toolkits/qt5-gui/Makefile b/x11-toolkits/qt5-gui/Makefile
index 52b5bb6317c2..d1f4cb7aaf4e 100644
--- a/x11-toolkits/qt5-gui/Makefile
+++ b/x11-toolkits/qt5-gui/Makefile
@@ -61,12 +61,8 @@ RUN_DEPENDS+= ${LOCALBASE}/lib/X11/fonts/encodings/encodings.dir:${PORTSDIR}/x11
${LOCALBASE}/lib/X11/fonts/TTF/luximb.ttf:${PORTSDIR}/x11-fonts/xorg-fonts-truetype
.endif
-.include <bsd.port.pre.mk>
-
# Inherited from Qt 4.
-.if ${ARCH} == powerpc64
-CFLAGS+= -mminimal-toc
-.endif
+CFLAGS_powerpc64= -mminimal-toc
post-patch:
@${REINPLACE_CMD} -e 's/-ldl/$$$$QMAKE_LIBS_DYNLOAD/' \
@@ -92,4 +88,4 @@ post-install:
${MAKE_ARGS} ${INSTALL_TARGET}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>