aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorcpiazza <cpiazza@FreeBSD.org>1999-07-18 14:27:18 +0800
committercpiazza <cpiazza@FreeBSD.org>1999-07-18 14:27:18 +0800
commitb3b634eb3d8b457cf56dfb87daedf6d7b5793d93 (patch)
tree49c5e57ae4d4d5bb7741d907598d88d7756b4d15 /x11-toolkits
parent2e4a12970021a8ab322329a3780c61a2ac41f599 (diff)
downloadfreebsd-ports-gnome-b3b634eb3d8b457cf56dfb87daedf6d7b5793d93.tar.gz
freebsd-ports-gnome-b3b634eb3d8b457cf56dfb87daedf6d7b5793d93.tar.zst
freebsd-ports-gnome-b3b634eb3d8b457cf56dfb87daedf6d7b5793d93.zip
Give this port a USE_XLIB so it'll link. Also move the CC=egcc
into the ${OSVERSION} check so it'll actually compile on -current with egcs.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/gnustep-gui/Makefile6
-rw-r--r--x11-toolkits/gnustep-xgps/Makefile6
2 files changed, 8 insertions, 4 deletions
diff --git a/x11-toolkits/gnustep-gui/Makefile b/x11-toolkits/gnustep-gui/Makefile
index cd04a664fc82..009f7a228e1c 100644
--- a/x11-toolkits/gnustep-gui/Makefile
+++ b/x11-toolkits/gnustep-gui/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/10 11:31:58 tg Exp $
#
DISTNAME= gstep-core-0.5.5
@@ -24,18 +24,20 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.elif ${OSVERSION} < 400000
BUILD_DEPENDS= egcc:${PORTSDIR}/lang/egcs
RUN_DEPENDS= egcc:${PORTSDIR}/lang/egcs
+CC= egcc
.endif
WRKSRC= ${WRKDIR}/gstep-0.5.5
PREFIX= ${LOCALBASE}/GNUstep
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CC=egcc INSTALL_PROGRAM="install -c" INSTALL_DATA="install -c"
+CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xraw \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include
USE_GMAKE= yes
+USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
diff --git a/x11-toolkits/gnustep-xgps/Makefile b/x11-toolkits/gnustep-xgps/Makefile
index cd04a664fc82..009f7a228e1c 100644
--- a/x11-toolkits/gnustep-xgps/Makefile
+++ b/x11-toolkits/gnustep-xgps/Makefile
@@ -3,7 +3,7 @@
# Date created: 03 October 1998
# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1999/05/10 11:31:58 tg Exp $
#
DISTNAME= gstep-core-0.5.5
@@ -24,18 +24,20 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.elif ${OSVERSION} < 400000
BUILD_DEPENDS= egcc:${PORTSDIR}/lang/egcs
RUN_DEPENDS= egcc:${PORTSDIR}/lang/egcs
+CC= egcc
.endif
WRKSRC= ${WRKDIR}/gstep-0.5.5
PREFIX= ${LOCALBASE}/GNUstep
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CC=egcc INSTALL_PROGRAM="install -c" INSTALL_DATA="install -c"
+CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xraw \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include
USE_GMAKE= yes
+USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes