aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2000-10-30 05:49:44 +0800
committervanilla <vanilla@FreeBSD.org>2000-10-30 05:49:44 +0800
commitf739bd51b59febc9078d5cf227fac8a97470b63b (patch)
tree5fdf9fe222d5dea13e6a365d35c9775b302285b1 /x11-toolkits
parentb4a2e8b63fa602d7c544fceba42b70fdf32d6245 (diff)
downloadfreebsd-ports-gnome-f739bd51b59febc9078d5cf227fac8a97470b63b.tar.gz
freebsd-ports-gnome-f739bd51b59febc9078d5cf227fac8a97470b63b.tar.zst
freebsd-ports-gnome-f739bd51b59febc9078d5cf227fac8a97470b63b.zip
It's a perl module to access gnome library.
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/p5-Gnome/Makefile28
-rw-r--r--x11-toolkits/p5-Gnome/distinfo1
-rw-r--r--x11-toolkits/p5-Gnome/files/patch-Makefile.PL35
-rw-r--r--x11-toolkits/p5-Gnome/pkg-comment1
-rw-r--r--x11-toolkits/p5-Gnome/pkg-descr3
-rw-r--r--x11-toolkits/p5-Gnome/pkg-plist14
7 files changed, 83 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index f88bb0a93d48..dca6c79e15ba 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -51,6 +51,7 @@
SUBDIR += p5-GdkImlib
SUBDIR += p5-GdkPixbuf
SUBDIR += p5-Glade
+ SUBDIR += p5-Gnome
SUBDIR += p5-Gtk
SUBDIR += p5-Tcl-Tk
SUBDIR += p5-Tk
diff --git a/x11-toolkits/p5-Gnome/Makefile b/x11-toolkits/p5-Gnome/Makefile
new file mode 100644
index 000000000000..9052bbc66419
--- /dev/null
+++ b/x11-toolkits/p5-Gnome/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Gnome
+# Date created: 30 Oct 2000
+# Whom: vanilla
+#
+# $FreeBSD$
+#
+
+PORTNAME= Gnome
+PORTVERSION= 0.7004
+CATEGORIES= x11-toolkits lang perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Gtk
+PKGNAMEPREFIX= p5-
+DISTNAME= Gtk-Perl-${PORTVERSION}
+
+MAINTAINER= vanilla@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/mach/Gtk/Gdk/ImlibImage.pm:${PORTSDIR}/x11-toolkits/p5-GdkImlib
+
+USE_PERL5= yes
+USE_GNOME= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+do-configure:
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ --with-panel CC="${CC}" CCFLAGS="${CFLAGS}"
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/p5-Gnome/distinfo b/x11-toolkits/p5-Gnome/distinfo
new file mode 100644
index 000000000000..ebd8f2180544
--- /dev/null
+++ b/x11-toolkits/p5-Gnome/distinfo
@@ -0,0 +1 @@
+MD5 (Gtk-Perl-0.7004.tar.gz) = f8f5d889e7a005667a93946ab1bf3e69
diff --git a/x11-toolkits/p5-Gnome/files/patch-Makefile.PL b/x11-toolkits/p5-Gnome/files/patch-Makefile.PL
new file mode 100644
index 000000000000..ee3779a021d1
--- /dev/null
+++ b/x11-toolkits/p5-Gnome/files/patch-Makefile.PL
@@ -0,0 +1,35 @@
+--- Makefile.PL.orig Tue Jun 20 18:36:15 2000
++++ Makefile.PL Mon Oct 30 03:52:25 2000
+@@ -1,7 +1,5 @@
+ use ExtUtils::MakeMaker;
+ use File::Basename;
+-use blib '..';
+-use blib '../GdkImlib';
+ use Gtk::Install::Files;
+ use Gtk::Gdk::ImlibImage::Install::Files;
+ use Cwd;
+@@ -46,12 +44,12 @@
+ $typemaps, [keys %defs], [@defines], [@headers], $pm);
+
+ foreach (@typemaps) {
+- print "Add typemap: $Gtk::Install::Files::CORE/$_\n";
+- push(@$typemaps, cwd() .'/'.$Gtk::Install::Files::CORE . '/'. $_);
++ print "Add typemap: $Gtk::Install::Files::CORE$_\n";
++ push(@$typemaps, '/'.$Gtk::Install::Files::CORE . $_);
+ }
+ foreach (@Gtk::Gdk::ImlibImage::Install::Files::typemaps) {
+- print "Add typemap: $Gtk::Gdk::ImlibImage::Install::Files::CORE/$_\n";
+- push(@$typemaps, cwd() .'/'.$Gtk::Gdk::ImlibImage::Install::Files::CORE . '/'. $_);
++ print "Add typemap: $Gtk::Gdk::ImlibImage::Install::Files::CORE$_\n";
++ push(@$typemaps, '/'.$Gtk::Gdk::ImlibImage::Install::Files::CORE . $_);
+ }
+ push(@defines, @Gtk::Install::Files::defines, @Gtk::Gdk::ImlibImage::Install::Files::defines);
+ #push(@defines, '-I../build', '-Ibuild', '-I.', '-I../Gtk');
+@@ -127,7 +125,6 @@
+ 'LIBS' => [$libs],
+ 'OBJECT' => $object,
+ 'clean' => {FILES => join(' ', @clean) },
+- 'OPTIMIZE' => '-O2 -g',
+ #'LDFROM' => $ldfrom,
+ 'depend' => $depend,
+ );
diff --git a/x11-toolkits/p5-Gnome/pkg-comment b/x11-toolkits/p5-Gnome/pkg-comment
new file mode 100644
index 000000000000..77356f9525f4
--- /dev/null
+++ b/x11-toolkits/p5-Gnome/pkg-comment
@@ -0,0 +1 @@
+The main Gnome module of Gtk-Perl
diff --git a/x11-toolkits/p5-Gnome/pkg-descr b/x11-toolkits/p5-Gnome/pkg-descr
new file mode 100644
index 000000000000..1b286efaf0f1
--- /dev/null
+++ b/x11-toolkits/p5-Gnome/pkg-descr
@@ -0,0 +1,3 @@
+The main Gnome module of Gtk-Perl (Gnome namespace).
+
+WWW: http://projects.prosa.it/gtkperl/
diff --git a/x11-toolkits/p5-Gnome/pkg-plist b/x11-toolkits/p5-Gnome/pkg-plist
new file mode 100644
index 000000000000..08066ed9557a
--- /dev/null
+++ b/x11-toolkits/p5-Gnome/pkg-plist
@@ -0,0 +1,14 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Types.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Install/Files.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Install/GnomeDefs.h
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Install/GnomeTypemap
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Install/PerlGnomeInt.h
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Install/pkg.typemap
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Gnome.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/Gnome.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome/Install
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Gnome
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Gnome