aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2012-08-20 20:01:03 +0800
committergahr <gahr@FreeBSD.org>2012-08-20 20:01:03 +0800
commit2ae63eeed14d7bd372f4b71c8e55646c6d94592a (patch)
tree9b25571c6406d348e9bf41fe0bc68495983a9aa3 /x11-toolkits
parentbe61d491c2e61cf8e0c9f5a294de9ac596084a9b (diff)
downloadfreebsd-ports-gnome-2ae63eeed14d7bd372f4b71c8e55646c6d94592a.tar.gz
freebsd-ports-gnome-2ae63eeed14d7bd372f4b71c8e55646c6d94592a.tar.zst
freebsd-ports-gnome-2ae63eeed14d7bd372f4b71c8e55646c6d94592a.zip
- New port -- x11-toolkits/vtkfox
FOX/VTK canvas widget and interactor to allow VTK to interact with your FOX application. WWW: http://www.gahr.ch/vtkfox/
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/vtkfox/Makefile67
-rw-r--r--x11-toolkits/vtkfox/distinfo2
-rw-r--r--x11-toolkits/vtkfox/pkg-descr6
4 files changed, 76 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 88c10f94f958..68dafeb20739 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -285,6 +285,7 @@
SUBDIR += viewklass
SUBDIR += vte
SUBDIR += vte-reference
+ SUBDIR += vtkfox
SUBDIR += wmapp
SUBDIR += wxd
SUBDIR += wxgtk24
diff --git a/x11-toolkits/vtkfox/Makefile b/x11-toolkits/vtkfox/Makefile
new file mode 100644
index 000000000000..6c320b038929
--- /dev/null
+++ b/x11-toolkits/vtkfox/Makefile
@@ -0,0 +1,67 @@
+# New ports collection Makefile for: vtkfox
+# Date created: 7 August 2012
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= vtkfox
+PORTVERSION= 1.0.0
+CATEGORIES= x11-toolkits
+MASTER_SITES= http://www.gahr.ch/vtkfox/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= FOX/VTK Widget and Interactor
+
+LIB_DEPENDS= vtkCommon.5:${PORTSDIR}/math/vtk5
+
+OPTIONS_SINGLE= FOX
+OPTIONS_SINGLE_FOX= FOX16 FOX17
+FOX16_DESC= Link against FOX-1.6
+FOX17_DESC= Link against FOX-1.7
+OPTIONS_DEFAULT=FOX16
+
+USE_GITHUB= yes
+GH_ACCOUNT= gahr
+GH_COMMIT= 378836c
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MFOX16}
+LIB_DEPENDS+= FOX-1.6:${PORTSDIR}/x11-toolkits/fox16
+.endif
+
+.if ${PORT_OPTIONS:MFOX17}
+LIB_DEPENDS+= FOX-1.7:${PORTSDIR}/x11-toolkits/fox17
+CMAKE_ARGS+= -DFOX17:BOOL=TRUE
+.endif
+
+USE_CMAKE= yes
+CMAKE_OUTSOURCE=yes
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/vtkfox/FXVTKCanvas.h \
+ include/vtkfox/vtkFXRenderWindowInteractor.h \
+ include/vtkfox/vtkfox.h \
+ lib/libvtkfox.so \
+ lib/libvtkfox.so.1 \
+ libdata/pkgconfig/vtkfox.pc
+
+post-patch:
+.if defined(NOPORTEXAMPLES)
+ ${REINPLACE_CMD} -e 's| tests||' ${WRKSRC}/CMakeLists.txt
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+SAMPLE_FILES= imgsurf double cone quad xyplot simple
+PORTEXAMPLES= *
+
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+.for sample_file in ${SAMPLE_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/tests/${sample_file}.cpp ${EXAMPLESDIR}
+ @${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/tests/${sample_file} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/vtkfox/distinfo b/x11-toolkits/vtkfox/distinfo
new file mode 100644
index 000000000000..e7d6065e123e
--- /dev/null
+++ b/x11-toolkits/vtkfox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (vtkfox-1.0.0.tar.gz) = b8668a432260a14dd5849447615b609edf34e235b7740d4e873a3019ad6444bd
+SIZE (vtkfox-1.0.0.tar.gz) = 8194
diff --git a/x11-toolkits/vtkfox/pkg-descr b/x11-toolkits/vtkfox/pkg-descr
new file mode 100644
index 000000000000..5c50ded2a7d9
--- /dev/null
+++ b/x11-toolkits/vtkfox/pkg-descr
@@ -0,0 +1,6 @@
+FOX/VTK canvas widget and interactor to allow VTK to interact with your FOX
+application. Allows VTK to render inside a FOX application via the FXGLCanvas
+control. Keyboard and mouse events are translated to allow for "native" VTK
+functionality.
+
+WWW: http://www.gahr.ch/vtkfox